<!doctype html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script> <title>The Bajan Reporter | TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script><link data-optimized="2" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/litespeed/css/be1cdf4bded8152a2d138b48d1370622.css?ver=8e48a" /><!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]--><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /> <script data-cfasync="false" data-pagespeed-no-defer>var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];</script> <meta name="description" content="TRON has made another breakthrough in its cooperation with sovereign states&mdash;appointed as Dominica&#039;s designated national blockchain infrastructure with&#8230;" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2022/10/1-Header-Picture.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="576" /><meta property="og:image:alt" content="1 Header Picture" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind | The Bajan Reporter" /><meta property="og:description" content="TRON has made another breakthrough in its cooperation with sovereign states&mdash;appointed as Dominica&#039;s designated national blockchain infrastructure with endorsement to issue Dominica Coin&mdash;an achievement&#8230;" /><meta property="og:url" content="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="og:updated_time" content="2022-10-12" /><meta property="article:published_time" content="2022-10-12" /><meta property="article:modified_time" content="2022-10-12" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:title" content="TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind | The Bajan Reporter" /><meta name="twitter:description" content="TRON has made another breakthrough in its cooperation with sovereign states&mdash;appointed as Dominica&#039;s designated national blockchain infrastructure with endorsement to issue Dominica Coin&mdash;an achievement&#8230;" /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2022/10/1-Header-Picture.jpg" /><meta name="twitter:image:width" content="1024" /><meta name="twitter:image:height" content="576" /><meta name="twitter:image:alt" content="1 Header Picture" /><link rel="canonical" href="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/new/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/new/business-new/","name":"Business"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/","name":"TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/amp/" /><meta name="generator" content="AMP for WP 1.0.77.51"/><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind Comments Feed" href="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/feed/" /> <script type="litespeed/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLiteSpeedLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings)</script> <script id="bajan-ready" type="litespeed/javascript">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[]</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style> <script type="litespeed/javascript" data-src='https://www.bajanreporter.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script id='responsive-lightbox-js-extra' type="litespeed/javascript">var rlArgs={"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"eb556908ed","preview":"false","postId":"107525","scriptExtension":""}</script> <script id='advanced-ads-advanced-js-js-extra' type="litespeed/javascript">var advads_options={"blog_id":"1","privacy":{"enabled":!1,"state":"not_needed"}}</script> <script id='smp-script-js-extra' type="litespeed/javascript">var smp_vars={"cookie_id":"1664132141812","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"640","popup_height":"480","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}</script> <link rel="https://api.w.org/" href="https://www.bajanreporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bajanreporter.com/wp-json/wp/v2/posts/107525" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2022%2F10%2Ftron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2022%2F10%2Ftron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind%2F&#038;format=xml" /> <script type="litespeed/javascript">advads_items={conditions:{},display_callbacks:{},display_effect_callbacks:{},hide_callbacks:{},backgrounds:{},effect_durations:{},close_functions:{},showed:[]}</script><style type="text/css" id="bajan-layer-custom-css"></style>
 <script data-cfasync="false" data-pagespeed-no-defer>var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["breaking-news","business-new","featured"],"pageAttributes":["blockchain","digital-money","dominica","online-currency"],"pagePostAuthor":"Bajan Reporter"};
	dataLayer.push( dataLayer_content );</script> <script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');</script> 
<script type="litespeed/javascript">var advadsCfpQueue=[];var advadsCfpAd=function(adID){if('undefined'==typeof advadsProCfp){advadsCfpQueue.push(adID)}else{advadsProCfp.addElement(adID)}}</script> <script type="litespeed/javascript">if(typeof advadsGATracking==='undefined'){window.advadsGATracking={delayedAds:{},deferedAds:{}}}</script> </head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/" title="TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind">TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind</a></li><li><a href="https://www.bajanreporter.com/2022/10/fari-from-silver-hill-ch-ch-is-most-recent-wanted-by-tbps/" title="&#8216;Fari&#8217; from Silver Hill, Ch Ch is most recent Wanted by TBPS">&#8216;Fari&#8217; from Silver Hill, Ch Ch is most recent Wanted by TBPS</a></li><li><a href="https://www.bajanreporter.com/2022/10/nilee-from-fairfield-in-blackrock-ditched-police-custody-seen-him/" title="&#8220;Nilee&#8221; from Fairfield in Blackrock ditched Police Custody, seen him?">&#8220;Nilee&#8221; from Fairfield in Blackrock ditched Police Custody, seen him?</a></li><li><a href="https://www.bajanreporter.com/2022/10/bwa-making-a-connection-in-castle-grant-st-joseph/" title="BWA Making a Connection in Castle Grant, St. Joseph">BWA Making a Connection in Castle Grant, St. Joseph</a></li><li><a href="https://www.bajanreporter.com/2022/10/congress-of-trade-unions-declares-sorry-not-enough-for-iadb-questionnaire/" title="Congress of Trade Unions declares &#8220;Sorry,&#8221; not enough for IADB questionnaire">Congress of Trade Unions declares &#8220;Sorry,&#8221; not enough for IADB questionnaire</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI1MDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgNTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="500" height="100" data-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></a> <span id="edition-date"><strong>Today</strong> Wednesday, October 12th, 2022</span></div><div class="sevencol last"><div data-bajan-trackid="98786" data-bajan-trackbid="1" class="bajan-target" id="bajan-1718014419"><a href="https://t.me/joinchat/UjriEOR3KsjETTOW" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI3MjgiIGhlaWdodD0iOTAiIHZpZXdCb3g9IjAgMCA3MjggOTAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/now-also-on-Telegram.gif" alt="now also on Telegram"  width="728" height="90"   /></a></div></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-107525" class="post-107525 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-business-new category-featured tag-blockchain tag-digital-money tag-dominica tag-online-currency"><h1>TRON Becomes the &#8220;National Blockchain&#8221; of Dominica as the First of Its Kind</h1><p class="post-meta">by  Bajan Reporter / October 12th, 2022</p><div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_preferred_1"></a>
<a class="addthis_button_preferred_2"></a>
<a class="addthis_button_preferred_3"></a>
<a class="addthis_button_preferred_4"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a></div> <script type="litespeed/javascript" data-src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <p>TRON has made another breakthrough in its cooperation with sovereign states—appointed as Dominica&#8217;s designated national blockchain infrastructure with endorsement to issue Dominica Coin—an achievement that is the first of its kind in the blockchain industry.</p><p>On October 7 (AST), the Government of Dominica announced on its official website that it had entered into an agreement with TRON, appointing TRON Protocol as its designated national blockchain infrastructure. Meanwhile, TRON has obtained the government&#8217;s endorsement to issue Dominica Coin (DMC), the country&#8217;s fan token. This agreement is, to date, the highest level of cooperation between a sovereign state and a blockchain platform, which cements TRON&#8217;s legal status as the national blockchain infrastructure of Dominica. With this deal as a prelude, TRON is poised to create a new trend of introducing blockchain-based applications to sovereign states.</p><p><a href="https://www.bajanreporter.com/wp-content/uploads/2022/10/Dominica-is-now-a-territory-of-the-TRON-States.png" data-rel="lightbox-gallery-Y5lB9WYy" data-rl_title="" data-rl_caption=""><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNTAiIGhlaWdodD0iMzAwIiB2aWV3Qm94PSIwIDAgMjUwIDMwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" class="aligncenter wp-image-107527 size-medium" title="" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/10/Dominica-is-now-a-territory-of-the-TRON-States-250x300.png" alt="Dominica is now a territory of the TRON States" width="250" height="300" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/10/Dominica-is-now-a-territory-of-the-TRON-States-250x300.png 250w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Dominica-is-now-a-territory-of-the-TRON-States-400x480.png 400w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Dominica-is-now-a-territory-of-the-TRON-States.png 562w" data-sizes="(max-width: 250px) 100vw, 250px" /></a></p><p>The news has sent shock waves across the blockchain industry, with some of the industry practitioners crying that &#8220;Dominica is now a territory of the TRON States.&#8221; The partnership between TRON and Dominica has created many more use cases for blockchain technology and laid the foundation for its success in the future.</p><p>&nbsp;</p><p><a href="https://www.bajanreporter.com/wp-content/uploads/2022/10/Just-like-Grenada-the-country-uses-the-Eastern-Caribbean-dollar.jpg" data-rel="lightbox-gallery-Y5lB9WYy" data-rl_title="" data-rl_caption=""><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNzgiIGhlaWdodD0iMzAwIiB2aWV3Qm94PSIwIDAgMjc4IDMwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" loading="lazy" class="aligncenter size-medium wp-image-107528" title="" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/10/Just-like-Grenada-the-country-uses-the-Eastern-Caribbean-dollar-278x300.jpg" alt="Just like Grenada the country uses the Eastern Caribbean dollar" width="278" height="300" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/10/Just-like-Grenada-the-country-uses-the-Eastern-Caribbean-dollar-278x300.jpg 278w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Just-like-Grenada-the-country-uses-the-Eastern-Caribbean-dollar-400x431.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Just-like-Grenada-the-country-uses-the-Eastern-Caribbean-dollar.jpg 592w" data-sizes="(max-width: 278px) 100vw, 278px" /></a>An island country in the Caribbean region, Dominica has an economy mainly based on agriculture and tourism. Just like Grenada, the country uses the Eastern Caribbean dollar (EC$ or XCD), a currency pegged to the U.S. dollar. The Caribbean, home to 25 sovereign countries and 14 regions, has become the superstar for the development of cryptocurrencies, making itself an integral part of the crypto and blockchain industries. Mostly small islands with relatively simple economic systems, the Caribbean is heavily dependent on trade and faces the challenges of insufficient foreign exchange reserves (U.S. dollar) and lack of financial infrastructure. The rise of blockchain has brought new opportunities for economic and social development in this region. Jamaica and Puerto Rico, among other countries and regions, are actively embracing cryptocurrencies and blockchain to speed up their growth. Now, as Dominica and TRON strike up a partnership, this Caribbean country has joined its neighbors to welcome this innovative technology.</p><p>The collaboration between TRON and Dominica has been long planned. WICNEWS, the largest news website in the Caribbean, reported that the partnership was formed right after the Virtual Asset Business Act was passed in this island country in May. TRON has obtained the government’s endorsement to issue Dominica Coin (DMC), a blockchain-based fan token, to help promote Dominica’s global fanfare for its natural heritage and tourist attractions.</p><p>&nbsp;</p><p>An official statement by Dominica stated that TRON Protocol is one of the leading global blockchain platforms, known for its efficient and cost-effective crypto settlement system. The country is taking a historic step towards enhanced economic growth by embracing digital innovation and appointing TRON Protocol as its designated national blockchain infrastructure.</p><p>The Government of Dominica has been committed to building a more inclusive and diversified economy with the help of new technologies, according to <strong>Roosevelt Skerrit</strong>, Prime Minister of Dominica.</p><p><a href="https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica.png" data-rel="lightbox-gallery-Y5lB9WYy" data-rl_title="" data-rl_caption=""><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMDAiIGhlaWdodD0iMTI3IiB2aWV3Qm94PSIwIDAgMzAwIDEyNyI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" loading="lazy" class="aligncenter wp-image-107526 size-medium" title="" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica-300x127.png" alt="Roosevelt Skerrit Prime Minister of Dominica" width="300" height="127" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica-300x127.png 300w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica-1024x434.png 1024w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica-768x325.png 768w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica-400x169.png 400w, https://www.bajanreporter.com/wp-content/uploads/2022/10/Roosevelt-Skerrit-Prime-Minister-of-Dominica.png 1379w" data-sizes="(max-width: 300px) 100vw, 300px" /></a></p><p>&#8220;The open and cost-effective nature of the TRON blockchain infrastructure will play a vital role to better integrate Small Island Developing States like Dominica into the global economy in the future,&#8221; Roosevelt Skerrit added.</p><p>Founded in 2017 by Justin Sun, TRON has grown to one of the largest public chains, boasting over 115 million users, over 4 billion transactions, and over $50 billion in on-chain assets. Forbes, the world-renowned business media, earmarked TRON as &#8220;one of the largest decentralized organizations&#8221;. The future goal for TRON is to become a mainstream financial service provider.</p><p>While advancing the underlying technologies of TRON and building a comprehensive blockchain ecosystem, Sun is also dedicated to promoting regulatory compliance and the adoption of blockchain worldwide. In late 2021, Sun was appointed as Ambassador and Permanent Representative of Grenada to the WTO. He said that during his tenure, he would proactively promote the integration of cryptocurrencies and sovereign states to build a new financial system that is secure, efficient, and inclusive. Moreover, he would also leverage his experience in the field of digital industry for a joint response to the new challenges regarding digital transformation in the post-pandemic era.</p><p>The WTO&#8217;s 12th Ministerial Conference (MC12) was held in June this year in Geneva, Switzerland. Sun stated at the conference, where he participated as head of the Grenada delegation, that blockchain and stablecoins can empower trade, e-commerce and many other industries, and that blockchain and crypto technologies can inject impetus into the economies of Small Island Developing States (SIDS) in the Caribbean region.</p><p>At TOKEN2049 and the ninth Milken Institute Asia Summit, both just concluded in Singapore, Sun also said that the crypto industry is poised to become the mainstream in the next decade. He believes that blockchain technology and the crypto industry can bring blockchain-powered finance to mass adoption, which benefits everyone across the globe and addresses regulators&#8217; concerns by keeping risks to a minimum.</p></article><div id="article-ad"><div class="ads468x60"><div data-bajan-trackid="98781" data-bajan-trackbid="1" class="bajan-target" id="bajan-442694237"><a href="https://www.instagram.com/bajanreporter/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0NjgiIGhlaWdodD0iODAiIHZpZXdCb3g9IjAgMCA0NjggODAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" alt="Follow on Instagram"  width="468" height="80"   /></a></div></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post">
<a rel="nofollow" id="cancel-comment-reply-link" href="/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p>
<input type="text" name="author" id="author" value="" size="22" tabindex="2" />
<label for="author">Name <em>(required)</em></label></p><p>
<input type="text" name="email" id="email" value="" size="22" tabindex="3" />
<label for="email">Email <em>(required, but never shared)</em></label></p><p>
<input type="text" name="url" id="url" value="" size="22" tabindex="4" />
<label title="Your website address" for="url">Web</label></p><p>
<input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" />
or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2022/10/tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind/trackback/">trackback</a>.</p>
<input type='hidden' name='comment_post_ID' value='107525' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="eb420c419d" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="223"/><script type="litespeed/javascript">document.getElementById("ak_js_1").setAttribute("value",(new Date()).getTime())</script></p></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2022/10/fari-from-silver-hill-ch-ch-is-most-recent-wanted-by-tbps/" rel="prev">&#8216;Fari&#8217; from Silver Hill, Ch Ch is most recent Wanted by TBPS</a></span></li><li><span class="next">Next: </span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><div data-bajan-trackid="98782" data-bajan-trackbid="1" class="bajan-target" id="bajan-624842656"><a href="https://www.mybarbadoslottery.com/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/1-IMG-20220525-WA0014.jpg" alt="1 IMG 20220525 WA0014"  width="336" height="280"   /></a></div></li><li><div data-bajan-trackid="98784" data-bajan-trackbid="1" data-bajan-redirect="1" class="bajan-target" id="bajan-1170779200"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Chef-Richelle-v6.jpg" alt="Chef Richelle v6"  width="336" height="280"   /></a></div></li><li><div data-bajan-trackid="98783" data-bajan-trackbid="1" class="bajan-target" id="bajan-1616026770"><a href="https://www.facebook.com/mytridentbb" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/TrIDent-1.jpg" alt="TrIDent 1"  width="336" height="280"   /></a></div></li></ul><ul class="ad ads120x600 cf"><li><div data-bajan-trackid="98775" data-bajan-trackbid="1" data-bajan-redirect="1" class="bajan-target" id="bajan-1613801047"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAiIGhlaWdodD0iNjAwIiB2aWV3Qm94PSIwIDAgMTIwIDYwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/BR2-If-you-saw-this-then-you-came-to-the-best-place-to-get-seen.png" alt="BR2 If you saw this then you came to the best place to get seen"  width="120" height="600"   /></a></div></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/10/the-leadhership-institute-launches-the-future-is-her-workshop/" title="The LeadHERship Institute launches &#8220;The Future is Her&#8221; Workshop">
The LeadHERship Institute launches &#8220;The Future is Her&#8221; Workshop            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNjUiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTY1IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="165" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/10/1-LeadHERship-TFIH-Workshop-Poster.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="The LeadHERship Institute is a social enterprise recently launched in Barbados. Our mission is to &#039;strategically address the underrepresentation of women in leadership spaces through interventions focused on governance, collaboration, and empowerment.&#039;" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/10/1-LeadHERship-TFIH-Workshop-Poster.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2022/10/1-LeadHERship-TFIH-Workshop-Poster-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2022/10/1-LeadHERship-TFIH-Workshop-Poster-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2022/10/1-LeadHERship-TFIH-Workshop-Poster-768x768.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/10/1-LeadHERship-TFIH-Workshop-Poster-400x400.jpg 400w" data-sizes="(max-width: 165px) 100vw, 165px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/world-animal-day-event-oct-4th-2022/" title="World Animal Day Event: Oct. 4th 2022">
World Animal Day Event: Oct. 4th 2022            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzkiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTM5IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="139" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/1-BIM-World-Animal-Day-Social-Media.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Meeting point is 5:30 pm at Pebbles Beach car park. From Pebbles Beach, we will walk to the Esplanada on Bay Street, opposite Government headquarters." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/1-BIM-World-Animal-Day-Social-Media.jpg 864w, https://www.bajanreporter.com/wp-content/uploads/2022/09/1-BIM-World-Animal-Day-Social-Media-253x300.jpg 253w, https://www.bajanreporter.com/wp-content/uploads/2022/09/1-BIM-World-Animal-Day-Social-Media-768x910.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/1-BIM-World-Animal-Day-Social-Media-400x474.jpg 400w" data-sizes="(max-width: 139px) 100vw, 139px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/qca-week-of-community-fundraising-activities/" title="QCA Week of Community &#038; Fundraising Activities">
QCA Week of Community &#038; Fundraising Activities            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNjUiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTY1IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="165" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities.jpeg" class="attachment-213x165 size-213x165 wp-post-image" alt="This year, the association celebrates 101 years in existence during the week of October 2nd to 8th. We have planned a number of activities during the week, to aid in building community spirit among the current and past students, and as fundraising efforts for the school and alumni in need. (CLICK FOR BIGGER)" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities.jpeg 1080w, https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities-300x300.jpeg 300w, https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities-1024x1024.jpeg 1024w, https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities-150x150.jpeg 150w, https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities-768x768.jpeg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/QCA-Week-of-Community-Fundraising-Activities-400x400.jpeg 400w" data-sizes="(max-width: 165px) 100vw, 165px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/kaleb-burke-teenager-missing-please-help/" title="Kaleb Burke, 13 year old found!">
Kaleb Burke, 13 year old found!            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTkiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTU5IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="159" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/IMG-20220925-WA0025.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="He is 5 feet tall, slim, brown complexion, small ears, small nose speaks with a Barbadian accent. Clothing unknown" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/IMG-20220925-WA0025.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2022/09/IMG-20220925-WA0025-288x300.jpg 288w, https://www.bajanreporter.com/wp-content/uploads/2022/09/IMG-20220925-WA0025-984x1024.jpg 984w, https://www.bajanreporter.com/wp-content/uploads/2022/09/IMG-20220925-WA0025-768x799.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/IMG-20220925-WA0025-400x416.jpg 400w" data-sizes="(max-width: 159px) 100vw, 159px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/care-of-the-elderly-in-a-rapidly-ageing-society-21st-sept-2022-at-700-pm/" title="&#8220;Care of the Elderly in a Rapidly Ageing Society&#8221; &#8211; 22nd Sept. 2022 at 7:00 pm">
&#8220;Care of the Elderly in a Rapidly Ageing Society&#8221; &#8211; 22nd Sept. 2022 at 7:00 pm            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxOTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTk3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="197" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Through this public education webinar, some of these challenges will be explored and discussions on how to manage throughout your older years and even how to take care of elderly loved ones. On the panel of expert discussants will be Gerontologist, Dr. Ambrose Ramsay, President of the Alzheimer&#039;s Association, Ms. Pamelia Brereton, Ms Colleen Walcott - Director of the National Assistance Board (NAB), Gerontology Researcher, Ms. Trudy Rowe-Weeks and Special Advisor to the Government on Elder Affairs Ms. Cynthia Forde J.P., M.P." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a.jpg 940w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a-300x251.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a-768x644.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a-400x335.jpg 400w" data-sizes="(max-width: 197px) 100vw, 197px" /></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/NWga6ES5znU" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/NWga6ES5znU" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/NWga6ES5znU" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 9th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/language-lessons-2021-natalie-morales-mark-duplass/" title="LANGUAGE LESSONS (2021) Natalie Morales, Mark Duplass">LANGUAGE LESSONS (2021) Natalie Morales, Mark Duplass</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/JBgbQtJns0A" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/JBgbQtJns0A" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/JBgbQtJns0A" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 8th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/stowaway-2022-ruby-rose-frank-grillo-patrick-schwarzenegger/" title="STOWAWAY (2022) Ruby Rose, Frank Grillo, Patrick Schwarzenegger">STOWAWAY (2022) Ruby Rose, Frank Grillo, Patrick Schwarzenegger</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/BcXiy7vyt8M" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/BcXiy7vyt8M" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/BcXiy7vyt8M" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 7th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/emily-the-criminal-2022-aubrey-plaza/" title="EMILY THE CRIMINAL (2022) Aubrey Plaza">EMILY THE CRIMINAL (2022) Aubrey Plaza</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/Oyvr3rL5lL4" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/Oyvr3rL5lL4" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/Oyvr3rL5lL4" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 6th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/breaking-2022-john-boyega-nicole-beharie/" title="BREAKING (2022) John Boyega, Nicole Beharie">BREAKING (2022) John Boyega, Nicole Beharie</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/m48-PCgZZwg" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/m48-PCgZZwg" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/m48-PCgZZwg" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 5th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/reboot-2022-judy-greer-keegan-michael-key/" title="REBOOT (2022) Judy Greer, Keegan-Michael Key">REBOOT (2022) Judy Greer, Keegan-Michael Key</a></div></li></ul></div></div></div>
 <script id='advanced-ads-layer-footer-js-js-extra' type="litespeed/javascript">var advanced_ads_layer_settings={"layer_class":"bajan-layer","placements":["replace-super-popup"]}</script> <script id='advanced-ads-responsive-js-extra' type="litespeed/javascript">var advanced_ads_responsive={"reload_on_resize":"0"}</script> <script id='advadsTrackingScript-js-extra' type="litespeed/javascript">var advadsTracking={"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"bajan-target","blogId":"1","frontendPrefix":"bajan-"}</script> <script id='advadsTrackingGAFront-js-extra' type="litespeed/javascript">var advadsGALocale={"Impressions":"Impressions","Clicks":"Clicks"}</script> <script type="litespeed/javascript">window.advads_admin_bar_items=[{"title":"Telegram Group (Main Banner 728x90)","type":"ad"},{"title":"Front Page Leaderboard","type":"group"},{"title":"Instagram Follow 468x80 - Leaderboard 1","type":"ad"},{"title":"Comments - 468 x 150","type":"group"},{"title":"My Barbados Lottery (Hot 5, 2022)","type":"ad"},{"title":"Single article 336x280 (block 1)","type":"group"},{"title":"Chef Richelle - WhatsApp Link","type":"ad"},{"title":"Single article 336x280 (block 2)","type":"group"},{"title":"Trident - Trusted Identity (Lower 336x280)","type":"ad"},{"title":"Single article 336x280 (block 3)","type":"group"},{"title":"Bajan Reporter (Inside 120x600)","type":"ad"},{"title":"Single article 120x600","type":"group"}]</script><script type="litespeed/javascript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script id="bajan-tracking" type="litespeed/javascript">var advads_tracking_ads={"1":[98786,98781,98782,98784,98783,98775]};var advads_tracking_urls={"1":"https:\/\/www.bajanreporter.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods={"1":"onrequest"};var advads_tracking_parallel={"1":!0};var advads_tracking_linkbases={"1":"https:\/\/www.bajanreporter.com\/linkout\/"};var advads_gatracking_uids={"1":"UA-82821259-1"};var advads_gatracking_allads={"1":{"102775":{"title":"Samuel Jackman Prescod - Apply Online","target":"http:\/\/bit.ly\/sjpi2021br","impression":!0,"click":!0},"98786":{"title":"Telegram Group (Main Banner 728x90)","target":"https:\/\/t.me\/joinchat\/UjriEOR3KsjETTOW","impression":!0,"click":!0},"98785":{"title":"Instagram News 468x80 - Leaderboard 2","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":!0,"click":!0},"98784":{"title":"Chef Richelle - WhatsApp Link","target":"https:\/\/wa.me\/12462525472","impression":!0,"click":!0},"98783":{"title":"Trident - Trusted Identity (Lower 336x280)","target":"https:\/\/www.facebook.com\/mytridentbb","impression":!0,"click":!0},"98782":{"title":"My Barbados Lottery (Hot 5, 2022)","target":"https:\/\/www.mybarbadoslottery.com\/","impression":!0,"click":!0},"98781":{"title":"Instagram Follow 468x80 - Leaderboard 1","target":"https:\/\/www.instagram.com\/bajanreporter\/","impression":!0,"click":!0},"98780":{"title":"Sarabande (336x280) - Front Page, Lower","target":"https:\/\/amzn.to\/2J6PjKK","impression":!0,"click":!0},"98779":{"title":"Advertising 2022 - 250x250 Front Page","target":"https:\/\/wa.me\/12462853586\/","impression":!0,"click":!0},"98778":{"title":"Crsytal Care Nursing 246 (250x250) Valentine's 2023","target":"https:\/\/www.instagram.com\/crystalcare_246\/","impression":!0,"click":!0},"98777":{"title":"N'Spire Communications (February 2023) 250x250","target":"https:\/\/wa.me\/12462827054","impression":!0,"click":!0},"98776":{"title":"Animated Arts Learning Institute 250x250 Trekvoy URL","target":"https:\/\/is.gd\/Baj_Trekvoy2022","impression":!0,"click":!0},"98775":{"title":"Bajan Reporter (Inside 120x600)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0},"98774":{"title":"Bajan Reporter 120x600 Front Page (In-House)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0}}};var advads_gatracking_anonym=!1;var advads_gatracking_transmitpageqs={}</script> <script type="litespeed/javascript">if(typeof window.advadsGATracking==='undefined'){window.advadsGATracking={}}
advadsGATracking.postContext={"postID":107525,"postSlug":"tron-becomes-the-national-blockchain-of-dominica-as-the-first-of-its-kind","cats":"breaking-news,business-new,featured"}</script> <footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div>
<input type="submit" value="Go" />
<input type="text" name="s" id="s" size="15" />
<label for="s">Search:</label></div></form></div><p> &copy; 2022 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>
 <script type="litespeed/javascript" data-src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>  <script type="litespeed/javascript">$(window).load(function(){$('.flexslider').flexslider();$('#chyrons').cycle({fx:'fade'})})</script> <script data-no-optimize="1" defer>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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script data-optimized="1" type="litespeed/javascript" data-src="https://www.bajanreporter.com/wp-content/litespeed/js/217ce1e0d7a5f93f1ce29b9afe452f2e.js?ver=8e48a"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":595,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!-- Page optimized by LiteSpeed Cache @2022-10-12 10:51:01 -->
<!-- Page generated by LiteSpeed Cache 5.2.1 on 2022-10-12 10:51:01 -->
<!-- Guest Mode -->