<!doctype html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script> <title>The Bajan Reporter | Radical Caribbean Cup returns to T&#038;T and Wallerfield | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script><link data-optimized="2" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/litespeed/css/be1cdf4bded8152a2d138b48d1370622.css?ver=20da2" /><!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]--><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /> <script data-cfasync="false" data-pagespeed-no-defer>var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];</script> <meta name="description" content="The third round of the 2022 Radical Caribbean Cup (RCC), originally scheduled for Bushy Park Barbados, will now take place at the Frankie Boodram Wallerfield&#8230;" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2017/04/Bushy-Park-MSI.jpg" /><meta property="og:image:width" content="314" /><meta property="og:image:height" content="214" /><meta property="og:image:alt" content="Bushy Park MSI" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Radical Caribbean Cup returns to T&#038;T and Wallerfield | The Bajan Reporter" /><meta property="og:description" content="The third round of the 2022 Radical Caribbean Cup (RCC), originally scheduled for Bushy Park Barbados, will now take place at the Frankie Boodram Wallerfield International Raceway in Trinidad &amp; Tobago." /><meta property="og:url" content="https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="og:updated_time" content="2022-09-19" /><meta property="article:author" content="https://www.facebook.com/bajanreporteronline" /><meta property="article:published_time" content="2022-09-19" /><meta property="article:modified_time" content="2022-09-19" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:creator" content="@bajanreporter" /><meta name="twitter:title" content="Radical Caribbean Cup returns to T&#038;T and Wallerfield | The Bajan Reporter" /><meta name="twitter:description" content="The third round of the 2022 Radical Caribbean Cup (RCC), originally scheduled for Bushy Park Barbados, will now take place at the Frankie Boodram Wallerfield International Raceway in Trinidad &amp; Tobago." /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2017/04/Bushy-Park-MSI.jpg" /><meta name="twitter:image:width" content="314" /><meta name="twitter:image:height" content="214" /><meta name="twitter:image:alt" content="Bushy Park MSI" /><link rel="canonical" href="https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/sports/","name":"Sports"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/sports/automobiles/","name":"Rally"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/","name":"Radical Caribbean Cup returns to T&#038;T and Wallerfield"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/amp/" /><meta name="generator" content="AMP for WP 1.0.77.51"/><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Radical Caribbean Cup returns to T&#038;T and Wallerfield Comments Feed" href="https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/feed/" /> <script type="litespeed/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLiteSpeedLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings)</script> <script id="bajan-ready" type="litespeed/javascript">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[]</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style> <script type="litespeed/javascript" data-src='https://www.bajanreporter.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script id='responsive-lightbox-js-extra' type="litespeed/javascript">var rlArgs={"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"d236e11154","preview":"false","postId":"107351","scriptExtension":""}</script> <script id='advanced-ads-advanced-js-js-extra' type="litespeed/javascript">var advads_options={"blog_id":"1","privacy":{"enabled":!1,"state":"not_needed"}}</script> <script id='smp-script-js-extra' type="litespeed/javascript">var smp_vars={"cookie_id":"1663011988726","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"640","popup_height":"480","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}</script> <link rel="https://api.w.org/" href="https://www.bajanreporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bajanreporter.com/wp-json/wp/v2/posts/107351" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2022%2F09%2Fradical-caribbean-cup-returns-to-tt-and-wallerfield%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2022%2F09%2Fradical-caribbean-cup-returns-to-tt-and-wallerfield%2F&#038;format=xml" /> <script type="litespeed/javascript">advads_items={conditions:{},display_callbacks:{},display_effect_callbacks:{},hide_callbacks:{},backgrounds:{},effect_durations:{},close_functions:{},showed:[]}</script><style type="text/css" id="bajan-layer-custom-css"></style>
 <script data-cfasync="false" data-pagespeed-no-defer>var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["automobiles"],"pageAttributes":["automotive","rally","speeding","traffic","trinidad"],"pagePostAuthor":"AirBourne"};
	dataLayer.push( dataLayer_content );</script> <script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');</script> 
<script type="litespeed/javascript">var advadsCfpQueue=[];var advadsCfpAd=function(adID){if('undefined'==typeof advadsProCfp){advadsCfpQueue.push(adID)}else{advadsProCfp.addElement(adID)}}</script> <script type="litespeed/javascript">if(typeof advadsGATracking==='undefined'){window.advadsGATracking={delayedAds:{},deferedAds:{}}}</script> </head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2022/09/bridgetown-us-embassy-resumes-processing-of-routine-in-person-appointments-in-all-nonimmigrant-visa-categories/" title="Bridgetown US Embassy Resumes Processing of Routine In-person Appointments in All Nonimmigrant Visa Categories">Bridgetown US Embassy Resumes Processing of Routine In-person Appointments in All Nonimmigrant Visa Categories</a></li><li><a href="https://www.bajanreporter.com/2022/09/five-smooth-stones-battle-continues-with-canadian-energy-conglomerate-notice-of-motion-for-the-fair-trading-commission-to-order-blpc-ltd-to-amend-its-application/" title="Five Smooth Stones? Battle Continues with Canadian Energy Conglomerate: NOTICE OF MOTION FOR THE FAIR TRADING COMMISSION TO ORDER BLPC LTD TO AMEND ITS APPLICATION">Five Smooth Stones? Battle Continues with Canadian Energy Conglomerate: NOTICE OF MOTION FOR THE FAIR TRADING COMMISSION TO O&hellip;</a></li><li><a href="https://www.bajanreporter.com/2022/09/bwa-stations-in-the-north-offline/" title="(UPDATED) BWA Stations in the North Back Online">(UPDATED) BWA Stations in the North Back Online</a></li><li><a href="https://www.bajanreporter.com/2022/09/the-queen-has-died-long-live-her-legacy-by-sir-ronald-sanders/" title="&#8220;The Queen has died: Long live her legacy&#8221; by Sir Ronald Sanders">&#8220;The Queen has died: Long live her legacy&#8221; by Sir Ronald Sanders</a></li><li><a href="https://www.bajanreporter.com/2022/09/single-electronic-window-introduced-at-small-business-week-launch-2022/" title="Single Electronic Window introduced at Small Business Week Launch 2022">Single Electronic Window introduced at Small Business Week Launch 2022</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI1MDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgNTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="500" height="100" data-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></a> <span id="edition-date"><strong>Today</strong> Monday, September 19th, 2022</span></div><div class="sevencol last"><div data-bajan-trackid="98786" data-bajan-trackbid="1" class="bajan-target" id="bajan-586091131"><a href="http://www.genac.com/bb" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI3MjgiIGhlaWdodD0iOTAiIHZpZXdCb3g9IjAgMCA3MjggOTAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/GenacBB-Web-Ads-728-x-90.gif" alt="GenacBB Web Ads 728 x 90"  width="728" height="90"   /></a></div></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-107351" class="post-107351 post type-post status-publish format-standard has-post-thumbnail hentry category-automobiles tag-automotive tag-rally tag-speeding tag-traffic tag-trinidad"><h1>Radical Caribbean Cup returns to T&#038;T and Wallerfield</h1><p class="post-meta">by  AirBourne / September 19th, 2022</p><div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_preferred_1"></a>
<a class="addthis_button_preferred_2"></a>
<a class="addthis_button_preferred_3"></a>
<a class="addthis_button_preferred_4"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a></div> <script type="litespeed/javascript" data-src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <p>The third round of the 2022 Radical Caribbean Cup (<strong>RCC</strong>), originally scheduled for Bushy Park Barbados, will now take place at the Frankie Boodram Wallerfield International Raceway in Trinidad &amp; Tobago. To be run over the weekend of October 8/9, it will be organised by the T&amp;T Automobile Sports Association (<strong>TTASA</strong>), after which the cars will be shipped on to Guyana for the final at South Dakota on November 12/13.</p><blockquote><p><strong>Championship co-ordinator Kurt Seabra said:</strong> &#8220;We had confirmed that a round of the RCC would be held in T&amp;T in 2023 but were blown away by the invitation to take the series back this year through a collaboration between Fast Parts Caribbean and TTASA. <strong>Fast Parts have been huge supporters of the RCC so of course we jumped on board.</strong> We are very excited at the chance to showcase the Radical SR3s for the very supportive Trinidadian motor sport spectators and to have Round 3 of the competitive RCC as the feature class at the Fast Parts Caribbean Circuit Racing Invitational.&#8221;</p></blockquote><p>With four wins in the six races so far run in Barbados in July and August, Guyana&#8217;s Kristian Jeffrey leads the standings with 125 points, while six podium finishes keep T&amp;T&#8217;s Kristian Boodoosingh in the hunt for the title at the half-way stage of the season with 100 points. Jamaica&#8217;s Senna Summerbell is third (56pts) with Sean Maloney the highest-placed Barbadian in fourth (51pts), having won once last month. There are smaller margins in the Nations Cup, although Guyana also leads on 130 points, ahead of Barbados (110pts), T&amp;T (105pts) and Jamaica (63pts).</p><p>The first and so far only round of the RCC to be run at Wallerfield was the curtain-raiser in June 2018, when the former Suzuki Challenge Series SR3 Cup was first upgraded to a regional championship. Stuart Maloney, who went on to become the inaugural RCC Champion, won the first two races, while hometown teenage sensation Isa Deen claimed an impressive SR3 debut victory in the third. Fifteen-year-old Deen also established the Radical Lap Record for the 1.4-kilometre circuit, while Maloney&#8217;s brother Mark, familiar with the venue from his previous CMRC visits in his Mazda RX-3, had earlier established the Qualifying Record.</p><p>While the series has not visited the country since then, T&amp;T has been well-presented by strong performances from its drivers on tour. Deen went on to finish third at year-end, after a second race win at Bushy Park Barbados, when he was the highest points-scorer of the day, and a further six podium finishes; only a poor run of luck at the final at South Dakota in Guyana prevented him finishing runner-up to Stuart Maloney.</p><p>Despite missing the Wallerfield opener, Boodoosingh finished fourth in 2018, with two race wins in Barbados and a second place in Guyana his best results, then went on to finish third the following year. After missing two of the three races in the first round at Bushy Park, he won once and finished second five times before year-end to finish behind new champion, Jamaica&#8217;s William Myers and Stuart Maloney. Luke Bhola also competed for part of each season, failing to score points in only one of 18 races, with a second-place finish in Guyana behind Zane Maloney his best result, while double T&amp;T rally champion Stuart Johnson made a one-off appearance at Bushy Park in 2019.</p><p>This is the third full season of the RCC, as only one round was run in 2020, which did not constitute a championship, and there were no races last year because of the pandemic. In the previous two seasons, there had been eight different winners in 24 races, with 2018 Champion Maloney the most successful over the two years, claiming seven victories and a further six podium finishes. Despite failing to win a race in his debut season, Myers beat the Reigning Champion to the 2019 crown by seven points after an impressively consistent performance netted him nine podium finishes.</p></article><div id="article-ad"><div class="ads468x60"><div data-bajan-trackid="98781" data-bajan-trackbid="1" class="bajan-target" id="bajan-863675472"><a href="https://www.instagram.com/bajanreporter/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0NjgiIGhlaWdodD0iODAiIHZpZXdCb3g9IjAgMCA0NjggODAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" alt="Follow on Instagram"  width="468" height="80"   /></a></div></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post">
<a rel="nofollow" id="cancel-comment-reply-link" href="/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p>
<input type="text" name="author" id="author" value="" size="22" tabindex="2" />
<label for="author">Name <em>(required)</em></label></p><p>
<input type="text" name="email" id="email" value="" size="22" tabindex="3" />
<label for="email">Email <em>(required, but never shared)</em></label></p><p>
<input type="text" name="url" id="url" value="" size="22" tabindex="4" />
<label title="Your website address" for="url">Web</label></p><p>
<input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" />
or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2022/09/radical-caribbean-cup-returns-to-tt-and-wallerfield/trackback/">trackback</a>.</p>
<input type='hidden' name='comment_post_ID' value='107351' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="022df56297" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="32"/><script type="litespeed/javascript">document.getElementById("ak_js_1").setAttribute("value",(new Date()).getTime())</script></p></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2022/09/royals-win-again-to-qualify-for-the-playoffs/" rel="prev">ROYALS WIN AGAIN TO QUALIFY FOR THE PLAYOFFS</a></span></li><li><span class="next">Next: <a href="https://www.bajanreporter.com/2022/09/food-insecurity-in-the-caribbean-continues-on-upward-trajectory-caricom-wfp-survey-finds/" rel="next">FOOD INSECURITY IN THE CARIBBEAN CONTINUES ON UPWARD TRAJECTORY, CARICOM-WFP SURVEY FINDS</a> &raquo;</span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><div data-bajan-trackid="98782" data-bajan-trackbid="1" class="bajan-target" id="bajan-1732900739"><a href="https://www.mybarbadoslottery.com/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/1-IMG-20220525-WA0014.jpg" alt="1 IMG 20220525 WA0014"  width="336" height="280"   /></a></div></li><li><div data-bajan-trackid="98784" data-bajan-trackbid="1" data-bajan-redirect="1" class="bajan-target" id="bajan-1792531889"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/GenacBB-Web-Ads-336-x-280.gif" alt="GenacBB Web Ads 336 x 280"  width="336" height="280"   /></a></div></li><li><div data-bajan-trackid="98783" data-bajan-trackbid="1" class="bajan-target" id="bajan-296625570"><a href="https://wa.me/12466239927/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/TSSG-Report-Workshop.jpg" alt="TSSG Report Workshop"  width="336" height="280"   /></a></div></li></ul><ul class="ad ads120x600 cf"><li><div data-bajan-trackid="98775" data-bajan-trackbid="1" data-bajan-redirect="1" class="bajan-target" id="bajan-429975431"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAiIGhlaWdodD0iNjAwIiB2aWV3Qm94PSIwIDAgMTIwIDYwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/BR2-If-you-saw-this-then-you-came-to-the-best-place-to-get-seen.png" alt="BR2 If you saw this then you came to the best place to get seen"  width="120" height="600"   /></a></div></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/care-of-the-elderly-in-a-rapidly-ageing-society-21st-sept-2022-at-700-pm/" title="&#8220;Care of the Elderly in a Rapidly Ageing Society&#8221; &#8211; 21st Sept. 2022 at 7:00 pm">
&#8220;Care of the Elderly in a Rapidly Ageing Society&#8221; &#8211; 21st Sept. 2022 at 7:00 pm            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxOTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTk3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="197" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Through this public education webinar, some of these challenges will be explored and discussions on how to manage throughout your older years and even how to take care of elderly loved ones. On the panel of expert discussants will be Gerontologist, Dr. Ambrose Ramsay, President of the Alzheimer&#039;s Association, Ms. Pamelia Brereton, Ms Colleen Walcott - Director of the National Assistance Board (NAB), Gerontology Researcher, Ms. Trudy Rowe-Weeks and Special Advisor to the Government on Elder Affairs Ms. Cynthia Forde J.P., M.P." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a.jpg 940w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a-300x251.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a-768x644.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Care-of-the-Elderly-in-a-Rapidly-Ageing-Society-4a-400x335.jpg 400w" data-sizes="(max-width: 197px) 100vw, 197px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/come-join-the-discussion-on-disabilities-policy-legislative-proposals-at-the-following-town-hall-meetings/" title="Come, join the Discussion on Disabilities Policy &#038; Legislative Proposals at the following Town Hall Meetings">
Come, join the Discussion on Disabilities Policy &#038; Legislative Proposals at the following Town Hall Meetings            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxOTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTk3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="197" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/Townhall-Meetings-Disabilities-Policy-Legislative-Proposals-8.png" class="attachment-213x165 size-213x165 wp-post-image" alt="Local residents are invited to either attend in person or join the Barbadian Diaspora virtually." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/Townhall-Meetings-Disabilities-Policy-Legislative-Proposals-8.png 940w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Townhall-Meetings-Disabilities-Policy-Legislative-Proposals-8-300x251.png 300w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Townhall-Meetings-Disabilities-Policy-Legislative-Proposals-8-768x644.png 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/Townhall-Meetings-Disabilities-Policy-Legislative-Proposals-8-400x335.png 400w" data-sizes="(max-width: 197px) 100vw, 197px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/small-business-association-of-barbados-collabirates-with-pinelands-creative-workshop-mind-the-dates/" title="Small Business Association of Barbados collabirates with Pinelands Creative Workshop, mind the dates!">
Small Business Association of Barbados collabirates with Pinelands Creative Workshop, mind the dates!            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzIiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTMyIDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="132" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/09/1-Pineland-Youth-Workshop.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Pinelands Creative Workshop and sba 2022 Small Biz Week" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/09/1-Pineland-Youth-Workshop.jpg 820w, https://www.bajanreporter.com/wp-content/uploads/2022/09/1-Pineland-Youth-Workshop-240x300.jpg 240w, https://www.bajanreporter.com/wp-content/uploads/2022/09/1-Pineland-Youth-Workshop-768x959.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/09/1-Pineland-Youth-Workshop-400x500.jpg 400w" data-sizes="(max-width: 132px) 100vw, 132px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/laureates-of-the-caribbean-the-rum-bar-lime/" title="&#8220;LAUREATES OF THE CARIBBEAN &#8211; THE RUM BAR LIME&#8221;">
&#8220;LAUREATES OF THE CARIBBEAN &#8211; THE RUM BAR LIME&#8221;            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzIiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTMyIDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="132" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/08/LAUREATES-OF-THE-CARIBBEAN-THE-RUM-BAR-LIME.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="This year, as we emerge on the other side of a universally traumatic experience, even as we mourn the loss of many of our beloved; as we wrestle with a type of survivors&#039; guilt that says &#039;there-but-for-the-grace-of-God-go-I&#039;, we the people turn to you, our poets, to usher us into a celebratory ergo cautious return the the worlds that wait outside. Bring us your poetry that speaks of love, of triumph and of joy and we will give you our all." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/08/LAUREATES-OF-THE-CARIBBEAN-THE-RUM-BAR-LIME.jpg 640w, https://www.bajanreporter.com/wp-content/uploads/2022/08/LAUREATES-OF-THE-CARIBBEAN-THE-RUM-BAR-LIME-240x300.jpg 240w, https://www.bajanreporter.com/wp-content/uploads/2022/08/LAUREATES-OF-THE-CARIBBEAN-THE-RUM-BAR-LIME-400x500.jpg 400w" data-sizes="(max-width: 132px) 100vw, 132px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/09/black-powerful-how-one-trinidadian-man-changed-the-landscape-of-language-forever/" title="&#8220;BLACK POWERFUL &#8211; HOW ONE TRINIDADIAN MAN CHANGED THE LANDSCAPE OF LANGUAGE FOREVER&#8221;">
&#8220;BLACK POWERFUL &#8211; HOW ONE TRINIDADIAN MAN CHANGED THE LANDSCAPE OF LANGUAGE FOREVER&#8221;            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzIiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTMyIDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="132" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/08/BLACK-POWERFUL-HOW-ONE-TRINIDADIAN-MAN-CHANGED-THE-LANDSCAPE-OF-LANGUAGE-FOREVER.png" class="attachment-213x165 size-213x165 wp-post-image" alt="In this panel, artists and writers who have inhabited the Caribbean, the United States, elsewhere, and in-between, discuss the importance of showing the Caribbean as the source of social movements, language, and ideas of self-reclamation that continue to change the course of the world." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/08/BLACK-POWERFUL-HOW-ONE-TRINIDADIAN-MAN-CHANGED-THE-LANDSCAPE-OF-LANGUAGE-FOREVER.png 696w, https://www.bajanreporter.com/wp-content/uploads/2022/08/BLACK-POWERFUL-HOW-ONE-TRINIDADIAN-MAN-CHANGED-THE-LANDSCAPE-OF-LANGUAGE-FOREVER-240x300.png 240w, https://www.bajanreporter.com/wp-content/uploads/2022/08/BLACK-POWERFUL-HOW-ONE-TRINIDADIAN-MAN-CHANGED-THE-LANDSCAPE-OF-LANGUAGE-FOREVER-400x500.png 400w" data-sizes="(max-width: 132px) 100vw, 132px" /></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/NWga6ES5znU" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/NWga6ES5znU" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/NWga6ES5znU" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 9th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/language-lessons-2021-natalie-morales-mark-duplass/" title="LANGUAGE LESSONS (2021) Natalie Morales, Mark Duplass">LANGUAGE LESSONS (2021) Natalie Morales, Mark Duplass</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/JBgbQtJns0A" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/JBgbQtJns0A" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/JBgbQtJns0A" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 8th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/stowaway-2022-ruby-rose-frank-grillo-patrick-schwarzenegger/" title="STOWAWAY (2022) Ruby Rose, Frank Grillo, Patrick Schwarzenegger">STOWAWAY (2022) Ruby Rose, Frank Grillo, Patrick Schwarzenegger</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/BcXiy7vyt8M" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/BcXiy7vyt8M" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/BcXiy7vyt8M" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 7th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/emily-the-criminal-2022-aubrey-plaza/" title="EMILY THE CRIMINAL (2022) Aubrey Plaza">EMILY THE CRIMINAL (2022) Aubrey Plaza</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/Oyvr3rL5lL4" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/Oyvr3rL5lL4" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/Oyvr3rL5lL4" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 6th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/breaking-2022-john-boyega-nicole-beharie/" title="BREAKING (2022) John Boyega, Nicole Beharie">BREAKING (2022) John Boyega, Nicole Beharie</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/m48-PCgZZwg" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/m48-PCgZZwg" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/m48-PCgZZwg" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 5th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/09/reboot-2022-judy-greer-keegan-michael-key/" title="REBOOT (2022) Judy Greer, Keegan-Michael Key">REBOOT (2022) Judy Greer, Keegan-Michael Key</a></div></li></ul></div></div></div>
 <script id='advanced-ads-layer-footer-js-js-extra' type="litespeed/javascript">var advanced_ads_layer_settings={"layer_class":"bajan-layer","placements":["replace-super-popup"]}</script> <script id='advanced-ads-responsive-js-extra' type="litespeed/javascript">var advanced_ads_responsive={"reload_on_resize":"0"}</script> <script id='advadsTrackingScript-js-extra' type="litespeed/javascript">var advadsTracking={"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"bajan-target","blogId":"1","frontendPrefix":"bajan-"}</script> <script id='advadsTrackingGAFront-js-extra' type="litespeed/javascript">var advadsGALocale={"Impressions":"Impressions","Clicks":"Clicks"}</script> <script type="litespeed/javascript">window.advads_admin_bar_items=[{"title":"General Accident (Main Banner 728x90) 30 Sept. 2022","type":"ad"},{"title":"Front Page Leaderboard","type":"group"},{"title":"Instagram Follow 468x80 - Leaderboard 1","type":"ad"},{"title":"Comments - 468 x 150","type":"group"},{"title":"My Barbados Lottery (Hot 5, 2022)","type":"ad"},{"title":"Single article 336x280 (block 1)","type":"group"},{"title":"General Accident - 30 Sept. 2022","type":"ad"},{"title":"Single article 336x280 (block 2)","type":"group"},{"title":"TSSG Security (Lower 336x280)","type":"ad"},{"title":"Single article 336x280 (block 3)","type":"group"},{"title":"Bajan Reporter (Inside 120x600)","type":"ad"},{"title":"Single article 120x600","type":"group"}]</script><script type="litespeed/javascript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script id="bajan-tracking" type="litespeed/javascript">var advads_tracking_ads={"1":[98786,98781,98782,98784,98783,98775]};var advads_tracking_urls={"1":"https:\/\/www.bajanreporter.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods={"1":"onrequest"};var advads_tracking_parallel={"1":!0};var advads_tracking_linkbases={"1":"https:\/\/www.bajanreporter.com\/linkout\/"};var advads_gatracking_uids={"1":"UA-82821259-1"};var advads_gatracking_allads={"1":{"102775":{"title":"Samuel Jackman Prescod - Apply Online","target":"http:\/\/bit.ly\/sjpi2021br","impression":!0,"click":!0},"98786":{"title":"General Accident (Main Banner 728x90) 30 Sept. 2022","target":"http:\/\/www.genac.com\/bb","impression":!0,"click":!0},"98785":{"title":"Instagram News 468x80 - Leaderboard 2","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":!0,"click":!0},"98784":{"title":"General Accident - 30 Sept. 2022","target":"http:\/\/www.genac.com\/bb","impression":!0,"click":!0},"98783":{"title":"TSSG Security (Lower 336x280)","target":"https:\/\/wa.me\/12466239927\/","impression":!0,"click":!0},"98782":{"title":"My Barbados Lottery (Hot 5, 2022)","target":"https:\/\/www.mybarbadoslottery.com\/","impression":!0,"click":!0},"98781":{"title":"Instagram Follow 468x80 - Leaderboard 1","target":"https:\/\/www.instagram.com\/bajanreporter\/","impression":!0,"click":!0},"98780":{"title":"Sarabande (336x280) - Front Page, Lower","target":"https:\/\/amzn.to\/2J6PjKK","impression":!0,"click":!0},"98779":{"title":"Advertising 2022 - 250x250 Front Page","target":"https:\/\/wa.me\/12462853586\/","impression":!0,"click":!0},"98778":{"title":"Google Feedburner Subscription (250x250)","target":"http:\/\/bit.ly\/JuwP4h","impression":!0,"click":!0},"98777":{"title":"Sarabande - Poetry 250x250","target":"https:\/\/amzn.to\/2J6PjKK","impression":!0,"click":!0},"98776":{"title":"Animated Arts Learning Institute 250x250 Trekvoy URL","target":"https:\/\/is.gd\/Baj_Trekvoy2022","impression":!0,"click":!0},"98775":{"title":"Bajan Reporter (Inside 120x600)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0},"98774":{"title":"Bajan Reporter 120x600 Front Page (In-House)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0}}};var advads_gatracking_anonym=!1;var advads_gatracking_transmitpageqs={}</script> <script type="litespeed/javascript">if(typeof window.advadsGATracking==='undefined'){window.advadsGATracking={}}
advadsGATracking.postContext={"postID":107351,"postSlug":"radical-caribbean-cup-returns-to-tt-and-wallerfield","cats":"automobiles"}</script> <footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div>
<input type="submit" value="Go" />
<input type="text" name="s" id="s" size="15" />
<label for="s">Search:</label></div></form></div><p> &copy; 2022 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>
 <script type="litespeed/javascript" data-src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>  <script type="litespeed/javascript">$(window).load(function(){$('.flexslider').flexslider();$('#chyrons').cycle({fx:'fade'})})</script> <script data-no-optimize="1" defer>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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script data-optimized="1" type="litespeed/javascript" data-src="https://www.bajanreporter.com/wp-content/litespeed/js/9f90341382e79e4bf56779a7fada5183.js?ver=20da2"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":518,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!-- Page optimized by LiteSpeed Cache @2022-09-19 07:38:46 -->
<!-- Page generated by LiteSpeed Cache 5.2.1 on 2022-09-19 07:38:46 -->
<!-- Guest Mode -->