<!doctype html><html lang="en-US"><head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script> <title>The Bajan Reporter | Missing Person now Suspected Suicide, body found and Identified | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script><link data-optimized="2" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/litespeed/css/f074a6aa245ef2aa5b79c0e7cc20951e.css?ver=a7f05" /><!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]--><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /> <script data-cfasync="false" data-pagespeed-no-defer>var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];</script> <meta name="description" content="Personnel at the Oistins Police Station received a report on Sunday June 19th 2022 around 07:20 am from an anonymous caller who stated that there was a body in&#8230;" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1.jpg" /><meta property="og:image:width" content="480" /><meta property="og:image:height" content="640" /><meta property="og:image:alt" content="The deceased has been identified as Rahim Camacho 24 years of Mount Standfast, St. James who was the subject of a Missing Persons Bulletin on June 18th 2022." /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Missing Person now Suspected Suicide, body found and Identified | The Bajan Reporter" /><meta property="og:description" content="Personnel at the Oistins Police Station received a report on Sunday June 19th 2022 around 07:20 am from an anonymous caller who stated that there was a body in the area of Landsdown, Enterprise&#8230;" /><meta property="og:url" content="https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="og:updated_time" content="2022-06-21" /><meta property="article:published_time" content="2022-06-20" /><meta property="article:modified_time" content="2022-06-21" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:title" content="Missing Person now Suspected Suicide, body found and Identified | The Bajan Reporter" /><meta name="twitter:description" content="Personnel at the Oistins Police Station received a report on Sunday June 19th 2022 around 07:20 am from an anonymous caller who stated that there was a body in the area of Landsdown, Enterprise&#8230;" /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1.jpg" /><meta name="twitter:image:width" content="480" /><meta name="twitter:image:height" content="640" /><meta name="twitter:image:alt" content="The deceased has been identified as Rahim Camacho 24 years of Mount Standfast, St. James who was the subject of a Missing Persons Bulletin on June 18th 2022." /><link rel="canonical" href="https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/gossip/","name":"Gossip"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/gossip/controversy/","name":"Controversy"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/","name":"Missing Person now Suspected Suicide, body found and Identified"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/amp/" /><meta name="generator" content="AMP for WP 1.0.77.45"/><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Missing Person now Suspected Suicide, body found and Identified Comments Feed" href="https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/feed/" /> <script type="litespeed/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLiteSpeedLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings)</script> <script id="bajan-ready" type="litespeed/javascript">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[]</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style> <script type="litespeed/javascript" data-src='https://www.bajanreporter.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script id='responsive-lightbox-js-extra' type="litespeed/javascript">var rlArgs={"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"fd267d3416","preview":"false","postId":"106616","scriptExtension":""}</script> <script id='advanced-ads-advanced-js-js-extra' type="litespeed/javascript">var advads_options={"blog_id":"1","privacy":{"enabled":!1,"state":"not_needed"}}</script> <script id='smp-script-js-extra' type="litespeed/javascript">var smp_vars={"cookie_id":"1651529247597","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"640","popup_height":"480","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}</script> <link rel="https://api.w.org/" href="https://www.bajanreporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bajanreporter.com/wp-json/wp/v2/posts/106616" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2022%2F06%2Fmissing-person-now-suspected-suicide-body-found-and-identified%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2022%2F06%2Fmissing-person-now-suspected-suicide-body-found-and-identified%2F&#038;format=xml" /> <script type="litespeed/javascript">function nxsPostToFav(obj){obj.preventDefault;var k=obj.target.split("-");var nt=k[0];var ii=k[1];var pid=k[2];var data={action:'nxs_snap_aj',nxsact:'manPost',nt:nt,id:pid,nid:ii,et_load_builder_modules:1,_wpnonce:'37483ed1d5'};jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>');jQuery('#nxsFavNotice').modal({fadeDuration:50});jQuery.post('https://www.bajanreporter.com/wp-admin/admin-ajax.php',data,function(response){if(response=='')response='Message Posted';jQuery('#nxsFavNoticeCnt').html('<p> '+response+'</p>'+'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />')})}</script><script type="litespeed/javascript">advads_items={conditions:{},display_callbacks:{},display_effect_callbacks:{},hide_callbacks:{},backgrounds:{},effect_durations:{},close_functions:{},showed:[]}</script><style type="text/css" id="bajan-layer-custom-css"></style>
 <script data-cfasync="false" data-pagespeed-no-defer>var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["controversy","featured"],"pageAttributes":["christ-church","forensic","identify","oistins","police","suicide"],"pagePostAuthor":"Bajan Reporter"};
	dataLayer.push( dataLayer_content );</script> <script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');</script> 
<script type="litespeed/javascript">var advadsCfpQueue=[];var advadsCfpAd=function(adID){if('undefined'==typeof advadsProCfp){advadsCfpQueue.push(adID)}else{advadsProCfp.addElement(adID)}}</script> <script type="litespeed/javascript">if(typeof advadsGATracking==='undefined'){window.advadsGATracking={delayedAds:{},deferedAds:{}}}</script> </head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2022/06/prime-minister-of-barbados-now-in-isolation-after-positive-results/" title="PRIME MINISTER OF BARBADOS NOW IN ISOLATION AFTER POSITIVE RESULTS">PRIME MINISTER OF BARBADOS NOW IN ISOLATION AFTER POSITIVE RESULTS</a></li><li><a href="https://www.bajanreporter.com/2022/06/nevlec-adjusts-fuel-surcharge-for-june-2022/" title="NEVLEC adjusts fuel surcharge for June 2022">NEVLEC adjusts fuel surcharge for June 2022</a></li><li><a href="https://www.bajanreporter.com/2022/06/st-george-resident-downed-by-hail-of-bullets/" title="St George Resident downed by hail of Bullets">St George Resident downed by hail of Bullets</a></li><li><a href="https://www.bajanreporter.com/2022/06/caribbean-leaders-meet-with-biden-and-harris-to-tackle-climate-economy-and-food-security-challenges/" title="Caribbean Leaders Meet with Biden and Harris to Tackle Climate, Economy, and Food Security Challenges">Caribbean Leaders Meet with Biden and Harris to Tackle Climate, Economy, and Food Security Challenges</a></li><li><a href="https://www.bajanreporter.com/2022/06/wanted-men-caught-once-again/" title="Wanted men caught once again">Wanted men caught once again</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI1MDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgNTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="500" height="100" data-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></a> <span id="edition-date"><strong>Today</strong> Tuesday, June 21st, 2022</span></div><div class="sevencol last"><div data-advadstrackid="98786" data-advadstrackbid="1" class="bajan-target" id="bajan-919131712"><a href="http://www.genac.com/bb" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI3MjgiIGhlaWdodD0iOTAiIHZpZXdCb3g9IjAgMCA3MjggOTAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/GenacBB-gif-728x-90.gif" alt="GenacBB gif 728x 90"  width="728" height="90"   /></a></div></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-106616" class="post-106616 post type-post status-publish format-standard has-post-thumbnail hentry category-controversy category-featured tag-christ-church tag-forensic tag-identify tag-oistins tag-police tag-suicide"><h1>Missing Person now Suspected Suicide, body found and Identified</h1><p class="post-meta">by  Bajan Reporter / June 20th, 2022</p><div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_preferred_1"></a>
<a class="addthis_button_preferred_2"></a>
<a class="addthis_button_preferred_3"></a>
<a class="addthis_button_preferred_4"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a></div> <script type="litespeed/javascript" data-src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <p>Personnel at the Oistins Police Station received a report on <strong>Sunday June 19<sup>th</sup> 2022</strong> around 07:20 am from an anonymous caller who stated that there was a body in the area of Landsdown, Enterprise, Christ Church hanging from a tree.</p><p style="text-align: center;"><em>CIRCUMSTANCES:</em></p><blockquote><p>Officers responded and on arrival at 07:50 am they were directed to a wooded area near the sea where the body of a male was found hanging from a tree. <strong>The body was dressed in a black long jeans, black long sleeve shirt and wearing black slippers and was in a state of decomposition</strong>. A Medical Doctor pronounced death at the scene.</p></blockquote><div id="attachment_106617" style="width: 235px" class="wp-caption aligncenter"><a href="https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1.jpg" data-rel="lightbox-gallery-8M2ZnRcO" data-rl_title="" data-rl_caption=""><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMjUiIGhlaWdodD0iMzAwIiB2aWV3Qm94PSIwIDAgMjI1IDMwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" aria-describedby="caption-attachment-106617" class="size-medium wp-image-106617" title="" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1-225x300.jpg" alt="The deceased has been identified as &lt;strong&gt;Rahim Camacho&lt;/strong&gt; 24 years of Mount Standfast, St. James who was the subject of a Missing Persons Bulletin on June 18th 2022. " width="225" height="300" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1-400x533.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2022/06/Raheem-Yusef-Camacho-1.jpg 480w" data-sizes="(max-width: 225px) 100vw, 225px" /></a><p id="caption-attachment-106617" class="wp-caption-text">The deceased has been identified as <strong>Rahim Camacho</strong> 24 years of Mount Standfast, St. James who was the subject of a Missing Persons Bulletin on June 18th 2022.</p></div><p>Anyone with information about this discovery, is asked to contact Police emergency at <strong>211</strong>, Crime Stoppers at <strong>1-800-TIPS (8477)</strong>, Oistins Police Station at <strong>418-2612</strong> or your nearest Police Station.</p><ul><li><strong>Michael Blackman – St. Sgt.</strong><br />
Public Relations Officer (<em>Ag</em>)</li></ul></article><div id="article-ad"><div class="ads468x60"><div data-advadstrackid="98781" data-advadstrackbid="1" class="bajan-target" id="bajan-18887493"><a href="https://www.instagram.com/bajanreporter/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0NjgiIGhlaWdodD0iODAiIHZpZXdCb3g9IjAgMCA0NjggODAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" alt="Follow on Instagram"  width="468" height="80"   /></a></div></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post">
<a rel="nofollow" id="cancel-comment-reply-link" href="/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p>
<input type="text" name="author" id="author" value="" size="22" tabindex="2" />
<label for="author">Name <em>(required)</em></label></p><p>
<input type="text" name="email" id="email" value="" size="22" tabindex="3" />
<label for="email">Email <em>(required, but never shared)</em></label></p><p>
<input type="text" name="url" id="url" value="" size="22" tabindex="4" />
<label title="Your website address" for="url">Web</label></p><p>
<input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" />
or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2022/06/missing-person-now-suspected-suicide-body-found-and-identified/trackback/">trackback</a>.</p>
<input type='hidden' name='comment_post_ID' value='106616' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a41031b60a" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="204"/><script type="litespeed/javascript">document.getElementById("ak_js_1").setAttribute("value",(new Date()).getTime())</script></p></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2022/06/prime-minister-of-barbados-now-in-isolation-after-positive-results/" rel="prev">PRIME MINISTER OF BARBADOS NOW IN ISOLATION AFTER POSITIVE RESULTS</a></span></li><li><span class="next">Next: <a href="https://www.bajanreporter.com/2022/06/corrective-measures-2022-bruce-willis-michael-rooker/" rel="next">CORRECTIVE MEASURES (2022) Bruce Willis &#038; Michael Rooker</a> &raquo;</span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><div data-advadstrackid="98782" data-advadstrackbid="1" class="bajan-target" id="bajan-149696122"><a href="https://www.mybarbadoslottery.com/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Cash-Bash-2022-May.jpg" alt="Cash Bash 2022 May"  width="336" height="280"   /></a></div></li><li><div data-advadstrackid="98784" data-advadstrackbid="1" data-advadsredirect="1" class="bajan-target" id="bajan-1821772801"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/GenacBB-gif-336x280-1.gif" alt="GenacBB gif 336x280 1"  width="336" height="280"   /></a></div></li><li><div data-advadstrackid="98783" data-advadstrackbid="1" class="bajan-target" id="bajan-1659662719"><a href="https://wa.me/12466239927/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/TSSG-Report-Workshop.jpg" alt="TSSG Report Workshop"  width="336" height="280"   /></a></div></li></ul><ul class="ad ads120x600 cf"><li><div data-advadstrackid="98775" data-advadstrackbid="1" data-advadsredirect="1" class="bajan-target" id="bajan-867447815"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAiIGhlaWdodD0iNjAwIiB2aWV3Qm94PSIwIDAgMTIwIDYwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/BR2-If-you-saw-this-then-you-came-to-the-best-place-to-get-seen.png" alt="BR2 If you saw this then you came to the best place to get seen"  width="120" height="600"   /></a></div></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/06/ncfs-call-for-visual-arts-submissions/" title="NCF&#8217;s CALL FOR VISUAL ARTS SUBMISSIONS">
NCF&#8217;s CALL FOR VISUAL ARTS SUBMISSIONS            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTE3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="117" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/06/2-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-2.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/06/2-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-2.jpg 724w, https://www.bajanreporter.com/wp-content/uploads/2022/06/2-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-2-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2022/06/2-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-2-400x566.jpg 400w" data-sizes="(max-width: 117px) 100vw, 117px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/06/call-for-submissions-and-competition-registration-by-the-ncf/" title="CALL FOR SUBMISSIONS AND COMPETITION REGISTRATION BY THE NCF">
CALL FOR SUBMISSIONS AND COMPETITION REGISTRATION BY THE NCF            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTE3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="117" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/06/1-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-1.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/06/1-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-1.jpg 724w, https://www.bajanreporter.com/wp-content/uploads/2022/06/1-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-1-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2022/06/1-CALL-FOR-VISUAL-ARTS-SUBMISSIONS-1-400x566.jpg 400w" data-sizes="(max-width: 117px) 100vw, 117px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/06/upcoming-hurricane-preparedness-seminar/" title="Upcoming Hurricane Preparedness Seminar">
Upcoming Hurricane Preparedness Seminar            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzIiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTMyIDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="132" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/06/Church-Hurricane-Prep-Seminar-LDS-1.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/06/Church-Hurricane-Prep-Seminar-LDS-1.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2022/06/Church-Hurricane-Prep-Seminar-LDS-1-240x300.jpg 240w, https://www.bajanreporter.com/wp-content/uploads/2022/06/Church-Hurricane-Prep-Seminar-LDS-1-819x1024.jpg 819w, https://www.bajanreporter.com/wp-content/uploads/2022/06/Church-Hurricane-Prep-Seminar-LDS-1-768x960.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/06/Church-Hurricane-Prep-Seminar-LDS-1-400x500.jpg 400w" data-sizes="(max-width: 132px) 100vw, 132px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/06/disabled-community-and-entrepreneurs-join-forces-later-this-month/" title="Disabled Community and Entrepreneurs join forces later this month&#8230;">
Disabled Community and Entrepreneurs join forces later this month&#8230;            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjkiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTI5IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="129" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/06/2b316704f3a44aac97bc468ea9ec997b.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/06/2b316704f3a44aac97bc468ea9ec997b.jpg 998w, https://www.bajanreporter.com/wp-content/uploads/2022/06/2b316704f3a44aac97bc468ea9ec997b-234x300.jpg 234w, https://www.bajanreporter.com/wp-content/uploads/2022/06/2b316704f3a44aac97bc468ea9ec997b-798x1024.jpg 798w, https://www.bajanreporter.com/wp-content/uploads/2022/06/2b316704f3a44aac97bc468ea9ec997b-768x985.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/06/2b316704f3a44aac97bc468ea9ec997b-400x513.jpg 400w" data-sizes="(max-width: 129px) 100vw, 129px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2022/05/u-s-assistant-secretary-nichols-in-barbados-may-24-27/" title="U.S. Assistant Secretary Nichols in Barbados May 24-27">
U.S. Assistant Secretary Nichols in Barbados May 24-27            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMzIiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTMyIDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="132" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2022/05/Brian-A-Nichols.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="The Assistant Secretary will meet with Prime Minister Mia Amor Mottley and hold a roundtable discussion with representatives of seven countries of the Eastern Caribbean." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2022/05/Brian-A-Nichols.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2022/05/Brian-A-Nichols-240x300.jpg 240w, https://www.bajanreporter.com/wp-content/uploads/2022/05/Brian-A-Nichols-400x500.jpg 400w" data-sizes="(max-width: 132px) 100vw, 132px" /></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/zt0XYdy3sqU" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/zt0XYdy3sqU" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/zt0XYdy3sqU" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">June 21st, 2022 <br /> <a href="https://www.bajanreporter.com/2022/06/prizefighter-2022-russell-crowe/" title="PRIZEFIGHTER (2022) Russell Crowe">PRIZEFIGHTER (2022) Russell Crowe</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/4_J1stiQHb8" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/4_J1stiQHb8" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/4_J1stiQHb8" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">June 20th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/06/corrective-measures-2022-bruce-willis-michael-rooker/" title="CORRECTIVE MEASURES (2022) Bruce Willis &#038; Michael Rooker">CORRECTIVE MEASURES (2022) Bruce Willis &#038; Michael Rooker</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/R0x02fMrct0" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/R0x02fMrct0" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/R0x02fMrct0" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">June 15th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/06/the-man-from-toronto-2022-kevin-hart-woody-harrelson-kaley-cuoco/" title="THE MAN FROM TORONTO (2022) Kevin Hart, Woody Harrelson &#038; Kaley Cuoco">THE MAN FROM TORONTO (2022) Kevin Hart, Woody Harrelson &#038; Kaley Cuoco</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/xQBSydkSPU8" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/xQBSydkSPU8" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/xQBSydkSPU8" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">June 14th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/06/black-bird-2022-taron-egerton-ray-liotta-action-series/" title="BLACK BIRD (2022) Taron Egerton, Ray Liotta: Action Series">BLACK BIRD (2022) Taron Egerton, Ray Liotta: Action Series</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/n-d6U1IwiSg" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/n-d6U1IwiSg" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/n-d6U1IwiSg" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">June 13th, 2022 <br /> <a href="https://www.bajanreporter.com/2022/06/press-conference-on-the-conclusion-of-the-ix-summit-of-the-americas/" title="Press Conference on the conclusion of the IX Summit of the Americas">Press Conference on the conclusion of the IX Summit of the Americas</a></div></li></ul></div></div></div><div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div> <script id='advanced-ads-layer-footer-js-js-extra' type="litespeed/javascript">var advanced_ads_layer_settings={"layer_class":"bajan-layer","placements":["replace-super-popup"]}</script> <script id='advanced-ads-responsive-js-extra' type="litespeed/javascript">var advanced_ads_responsive={"reload_on_resize":"0"}</script> <script id='advadsTrackingScript-js-extra' type="litespeed/javascript">var advadsTracking={"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"bajan-target","blogId":"1"}</script> <script id='advadsTrackingGAFront-js-extra' type="litespeed/javascript">var advadsGALocale={"Impressions":"Impressions","Clicks":"Clicks"}</script> <script type="litespeed/javascript">window.advads_admin_bar_items=[{"title":"General Accident (Main Banner 728x90) 30 Sept. 2022","type":"ad"},{"title":"Front Page Leaderboard","type":"group"},{"title":"Instagram Follow 468x80 - Leaderboard 1","type":"ad"},{"title":"Comments - 468 x 150","type":"group"},{"title":"My Barbados Lottery (Cash Bash, 2022)","type":"ad"},{"title":"Single article 336x280 (block 1)","type":"group"},{"title":"General Accident - 30 Sept. 2022","type":"ad"},{"title":"Single article 336x280 (block 2)","type":"group"},{"title":"TSSG Security (Lower 336x280)","type":"ad"},{"title":"Single article 336x280 (block 3)","type":"group"},{"title":"Bajan Reporter (Inside 120x600)","type":"ad"},{"title":"Single article 120x600","type":"group"}]</script><script type="litespeed/javascript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script id="bajan-tracking" type="litespeed/javascript">var advads_tracking_ads={"1":[98786,98781,98782,98784,98783,98775]};var advads_tracking_urls={"1":"https:\/\/www.bajanreporter.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods={"1":"onrequest"};var advads_tracking_parallel={"1":!0};var advads_tracking_linkbases={"1":"https:\/\/www.bajanreporter.com\/linkout\/"};var advads_gatracking_uids={"1":"UA-82821259-1"};var advads_gatracking_allads={"1":{"102775":{"title":"Samuel Jackman Prescod - Apply Online","target":"http:\/\/bit.ly\/sjpi2021br","impression":!0,"click":!0},"98786":{"title":"General Accident (Main Banner 728x90) 30 Sept. 2022","target":"http:\/\/www.genac.com\/bb","impression":!0,"click":!0},"98785":{"title":"Instagram News 468x80 - Leaderboard 2","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":!0,"click":!0},"98784":{"title":"General Accident - 30 Sept. 2022","target":"http:\/\/www.genac.com\/bb","impression":!0,"click":!0},"98783":{"title":"TSSG Security (Lower 336x280)","target":"https:\/\/wa.me\/12466239927\/","impression":!0,"click":!0},"98782":{"title":"My Barbados Lottery (Cash Bash, 2022)","target":"https:\/\/www.mybarbadoslottery.com\/","impression":!0,"click":!0},"98781":{"title":"Instagram Follow 468x80 - Leaderboard 1","target":"https:\/\/www.instagram.com\/bajanreporter\/","impression":!0,"click":!0},"98780":{"title":"Sarabande (336x280) - Front Page, Lower","target":"https:\/\/amzn.to\/2J6PjKK","impression":!0,"click":!0},"98779":{"title":"Advertising 2022 - 250x250 Front Page","target":"https:\/\/wa.me\/12462853586\/","impression":!0,"click":!0},"98778":{"title":"Google Feedburner Subscription (250x250)","target":"http:\/\/bit.ly\/JuwP4h","impression":!0,"click":!0},"98777":{"title":"Sarabande - Poetry 250x250","target":"https:\/\/amzn.to\/2J6PjKK","impression":!0,"click":!0},"98776":{"title":"Bajan Reporter Irregulars 250x250 Telegram URL","target":"https:\/\/t.me\/joinchat\/UjriEOR3KsjETTOW","impression":!0,"click":!0},"98775":{"title":"Bajan Reporter (Inside 120x600)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0},"98774":{"title":"Bajan Reporter 120x600 Front Page (In-House)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0}}};var advads_gatracking_anonym=!1;var advads_gatracking_transmitpageqs={}</script> <script type="litespeed/javascript">if(typeof window.advadsGATracking==='undefined'){window.advadsGATracking={}}
advadsGATracking.postContext={"postID":106616,"postSlug":"missing-person-now-suspected-suicide-body-found-and-identified","cats":"controversy,featured"}</script> <footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div>
<input type="submit" value="Go" />
<input type="text" name="s" id="s" size="15" />
<label for="s">Search:</label></div></form></div><p> &copy; 2022 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>
 <script type="litespeed/javascript" data-src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>  <script type="litespeed/javascript">$(window).load(function(){$('.flexslider').flexslider();$('#chyrons').cycle({fx:'fade'})})</script> <script data-no-optimize="1" defer>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</script><script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script data-optimized="1" type="litespeed/javascript" data-src="https://www.bajanreporter.com/wp-content/litespeed/js/b2e17a9663644889581027a7538e9e84.js?ver=a7f05"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_force(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(e=>{window.removeEventListener(e,litespeed_load_delayed_js_force,{passive:!0})}),document.querySelectorAll("iframe[data-litespeed-src]").forEach(e=>{e.setAttribute("src",e.getAttribute("data-litespeed-src"))}),"loading"==document.readyState?window.addEventListener("DOMContentLoaded",litespeed_load_delayed_js):litespeed_load_delayed_js()}litespeed_ui_events.forEach(e=>{window.addEventListener(e,litespeed_load_delayed_js_force,{passive:!0})});async function litespeed_load_delayed_js(){let t=[];for(var d in document.querySelectorAll('script[type="litespeed/javascript"]').forEach(e=>{t.push(e)}),t)await new Promise(e=>litespeed_load_one(t[d],e));document.dispatchEvent(new Event("DOMContentLiteSpeedLoaded")),window.dispatchEvent(new Event("DOMContentLiteSpeedLoaded"))}function litespeed_load_one(t,e){console.log("[LiteSpeed] Load ",t);var d=document.createElement("script");d.addEventListener("load",e),d.addEventListener("error",e),t.getAttributeNames().forEach(e=>{"type"!=e&&d.setAttribute("data-src"==e?"src":e,t.getAttribute(e))});let a=!(d.type="text/javascript");!d.src&&t.textContent&&(d.src=litespeed_inline2src(t.textContent),a=!0),t.after(d),t.remove(),a&&e()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":511,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!-- Page optimized by LiteSpeed Cache @2022-06-21 13:13:11 -->
<!-- Page generated by LiteSpeed Cache 4.6 on 2022-06-21 09:13:11 -->
<!-- Guest Mode -->