<!doctype html><html lang="en-US"><head><title>The Bajan Reporter | Barbados Police seek Wanted Man: Jamal Renaldo Bartlett | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script><link data-optimized="2" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/litespeed/css/be1cdf4bded8152a2d138b48d1370622.css?ver=c60a5" /><!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]--><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /> <script data-cfasync="false" data-pagespeed-no-defer type="litespeed/javascript" data-i="1">var gtm4wp_datalayer_name="dataLayer";var dataLayer=dataLayer||[]</script> <meta name="description" content="The Royal Barbados Police Force are urging Barbadians to help locate a Wanted Man, this is Jamal Renaldo Bartlett, whose last known address was Lower Burney&#8230;" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett..jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="833" /><meta property="og:image:alt" content="Jamal Renaldo Bartlett is approximately five (5) feet eight (8) inches tall, has a brown complexion, and a slim build. He has an oval-shaped face, a broad nose, and thick lips." /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Barbados Police seek Wanted Man: Jamal Renaldo Bartlett | The Bajan Reporter" /><meta property="og:description" content="The Royal Barbados Police Force are urging Barbadians to help locate a Wanted Man, this is Jamal Renaldo Bartlett, whose last known address was Lower Burney, Mapp Hill, St. Michael. He is wanted in&#8230;" /><meta property="og:url" content="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="og:updated_time" content="2021-09-28" /><meta property="article:published_time" content="2021-09-28" /><meta property="article:modified_time" content="2021-09-28" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:title" content="Barbados Police seek Wanted Man: Jamal Renaldo Bartlett | The Bajan Reporter" /><meta name="twitter:description" content="The Royal Barbados Police Force are urging Barbadians to help locate a Wanted Man, this is Jamal Renaldo Bartlett, whose last known address was Lower Burney, Mapp Hill, St. Michael. He is wanted in&#8230;" /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett..jpg" /><meta name="twitter:image:width" content="1024" /><meta name="twitter:image:height" content="833" /><meta name="twitter:image:alt" content="Jamal Renaldo Bartlett is approximately five (5) feet eight (8) inches tall, has a brown complexion, and a slim build. He has an oval-shaped face, a broad nose, and thick lips." /><link rel="canonical" href="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/new/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/new/crime-new/","name":"Crime"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/","name":"Barbados Police seek Wanted Man: Jamal Renaldo Bartlett"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/amp/" /><meta name="generator" content="AMP for WP 1.0.77.24"/><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Barbados Police seek Wanted Man: Jamal Renaldo Bartlett Comments Feed" href="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/feed/" /> <script type="litespeed/javascript" data-i="2">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings)</script> <script id="bajan-ready" type="litespeed/javascript" data-i="3">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[]</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style> <script type="litespeed/javascript" data-i="4" data-src='https://www.bajanreporter.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script id='responsive-lightbox-js-extra' type="litespeed/javascript" data-i="5">var rlArgs={"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"fd61c95bfb"}</script> <script id='advanced-ads-advanced-js-js-extra' type="litespeed/javascript" data-i="6">var advads_options={"blog_id":"1","privacy":{"enabled":!1,"state":"not_needed"}}</script> <script id='smp-script-js-extra' type="litespeed/javascript" data-i="7">var smp_vars={"cookie_id":"1626525457638","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"835","popup_height":"835","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}</script> <link rel="https://api.w.org/" href="https://www.bajanreporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bajanreporter.com/wp-json/wp/v2/posts/104592" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2021%2F09%2Fbarbados-police-seek-wanted-man-jamal-renaldo-bartlett%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2021%2F09%2Fbarbados-police-seek-wanted-man-jamal-renaldo-bartlett%2F&#038;format=xml" /> <script type="litespeed/javascript" data-i="8">advads_items={conditions:{},display_callbacks:{},display_effect_callbacks:{},hide_callbacks:{},backgrounds:{},effect_durations:{},close_functions:{},showed:[]}</script><style type="text/css" id="bajan-layer-custom-css"></style> <script data-cfasync="false" data-pagespeed-no-defer type="litespeed/javascript" data-i="9">var dataLayer_content={"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["breaking-news","crime-new","featured"],"pageAttributes":["arrests","deacons","manhunt","police","st-michael","wanted"],"pagePostAuthor":"DevilsAdvocate"};dataLayer.push(dataLayer_content)</script> <script data-cfasync="false" type="litespeed/javascript" data-i="10">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=!0;j.src='//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f)})(window,document,'script','dataLayer','GTM-KJ9N7NW')</script> 
<script type="litespeed/javascript" data-i="11">var advadsCfpQueue=[];var advadsCfpAd=function(adID){if('undefined'==typeof advadsProCfp){advadsCfpQueue.push(adID)}else{advadsProCfp.addElement(adID)}}</script> <script type="litespeed/javascript" data-i="12">if(typeof advadsGATracking==='undefined'){window.advadsGATracking={delayedAds:{},deferedAds:{}}}</script> </head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/" title="Barbados Police seek Wanted Man: Jamal Renaldo Bartlett">Barbados Police seek Wanted Man: Jamal Renaldo Bartlett</a></li><li><a href="https://www.bajanreporter.com/2021/09/2-men-charged-with-murder-of-shae-hackett-set-for-magistrates-appearance/" title="2 men charged with murder of Shae Hackett, set for Magistrate&#8217;s appearance">2 men charged with murder of Shae Hackett, set for Magistrate&#8217;s appearance</a></li><li><a href="https://www.bajanreporter.com/2021/09/bridgetown-u-s-embassy-to-host-facebook-live-vaccine-discussion-with-cdc-caribbean-regional-office-director/" title="Bridgetown U.S. Embassy to host Facebook Live Vaccine Discussion with CDC Caribbean Regional Office Director">Bridgetown U.S. Embassy to host Facebook Live Vaccine Discussion with CDC Caribbean Regional Office Director</a></li><li><a href="https://www.bajanreporter.com/2021/09/dominican-republics-medical-community-open-to-vaccinating-children-under-12-years-of-age/" title="Dominican Republic&#8217;s medical community open to vaccinating children under 12 years of age">Dominican Republic&#8217;s medical community open to vaccinating children under 12 years of age</a></li><li><a href="https://www.bajanreporter.com/2021/09/barbados-police-on-look-out-for-73-year-old-from-ruby-st-philip-have-you-seen-him/" title="Barbados Police on look out for 73 year old from Ruby, St Philip &#8211; have you seen him?">Barbados Police on look out for 73 year old from Ruby, St Philip &#8211; have you seen him?</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI1MDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgNTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="500" height="100" data-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></a> <span id="edition-date"><strong>Today</strong> Tuesday, September 28th, 2021</span></div><div class="sevencol last"><div data-advadstrackid="98786" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-2032184688"><a href="http://bit.ly/BR_2021FuCntr" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI3MjgiIGhlaWdodD0iOTAiIHZpZXdCb3g9IjAgMCA3MjggOTAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/strip.gif" alt="strip"  width="728" height="90"   /></a></div></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-104592" class="post-104592 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-crime-new category-featured tag-arrests tag-deacons tag-manhunt tag-police tag-st-michael tag-wanted"><h1>Barbados Police seek Wanted Man: Jamal Renaldo Bartlett</h1><p class="post-meta">by  DevilsAdvocate / September 28th, 2021</p><div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_preferred_1"></a>
<a class="addthis_button_preferred_2"></a>
<a class="addthis_button_preferred_3"></a>
<a class="addthis_button_preferred_4"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a></div> <script type="litespeed/javascript" data-i="13" data-src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <p>The Royal Barbados Police Force are urging Barbadians to help locate a Wanted Man, this is <strong>Jamal Renaldo Bartlett</strong>, whose last known address was Lower Burney, Mapp Hill, St. Michael. He is wanted in connection with several serious criminal matters.</p><p style="text-align: center;"><em>Description:</em></p><div id="attachment_104593" style="width: 310px" class="wp-caption aligncenter"><a href="https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett..jpg" data-rel="lightbox-gallery-FuzN2JZ3" data-rl_title="" data-rl_caption="" title=""><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMDAiIGhlaWdodD0iMjQ0IiB2aWV3Qm94PSIwIDAgMzAwIDI0NCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" aria-describedby="caption-attachment-104593" loading="lazy" class="size-medium wp-image-104593" title="Wanted Man Jamal Renaldo Bartlett." data-src="https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett.-300x244.jpg" alt="&lt;strong&gt;Jamal Renaldo Bartlett&lt;/strong&gt; is approximately five (5) feet eight (8) inches tall, has a brown complexion, and a slim build. He has an oval-shaped face, a broad nose, and thick lips." width="300" height="244" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett.-300x244.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett.-768x625.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett.-400x325.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Wanted-Man-Jamal-Renaldo-Bartlett..jpg 1024w" data-sizes="(max-width: 300px) 100vw, 300px" /></a><p id="caption-attachment-104593" class="wp-caption-text"><strong>Jamal Renaldo Bartlett</strong> is approximately five (5) feet eight (8) inches tall, has a brown complexion, and a slim build. He has an oval-shaped face, a broad nose, and thick lips.</p></div><p><strong>Jamal Renaldo Bartlett</strong> is advised that he can present himself to the Criminal Investigation Department at the District &#8216;A&#8217; Police Station accompanied by an Attorney-At-Law of his choice.</p><p>Anybody knowing the whereabouts of <em>Jamal Renaldo Bartlett</em> is asked to contact the Criminal Investigation Department at the District &#8220;A&#8221; Police Station at telephone number<strong> 430-7295</strong>, Police Hotline at <strong>211</strong>, Crime Stoppers at <strong>1-800-TIPS (8477)</strong>, or the nearest police station.</p><p>Barbadians are also reminded it&#8217;s a serious offence to harbour or assist Wanted Persons; any person caught committing this offence can and has been prosecuted.</p><ul><li><strong>Rodney Inniss &#8211; Insp. (Ag);</strong><br />
Public Relations Officer</li></ul></article><div id="article-ad"><div class="ads468x60"><div data-advadstrackid="98781" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-1390622532"><a href="https://www.instagram.com/bajanreporteronline/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0NjgiIGhlaWdodD0iODAiIHZpZXdCb3g9IjAgMCA0NjggODAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" alt="Follow on Instagram"  width="468" height="80"   /></a></div></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post">
<a rel="nofollow" id="cancel-comment-reply-link" href="/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p>
<input type="text" name="author" id="author" value="" size="22" tabindex="2" />
<label for="author">Name <em>(required)</em></label></p><p>
<input type="text" name="email" id="email" value="" size="22" tabindex="3" />
<label for="email">Email <em>(required, but never shared)</em></label></p><p>
<input type="text" name="url" id="url" value="" size="22" tabindex="4" />
<label title="Your website address" for="url">Web</label></p><p>
<input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" />
or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2021/09/barbados-police-seek-wanted-man-jamal-renaldo-bartlett/trackback/">trackback</a>.</p>
<input type='hidden' name='comment_post_ID' value='104592' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="27d0888712" /></p><input type="hidden" id="ak_js" name="ak_js" value="149"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2021/09/youth-to-represent-export-barbados-bidc-at-the-dubai-expo-2020/" rel="prev">Youth to represent Export Barbados (BIDC) at the Dubai Expo 2020</a></span></li><li><span class="next">Next: <a href="https://www.bajanreporter.com/2021/09/all-about-the-booth-virgin-atlantic-designs-unique-social-space-for-its-leisure-customers/" rel="next">ALL ABOUT THE BOOTH: VIRGIN ATLANTIC DESIGNS UNIQUE SOCIAL SPACE FOR ITS LEISURE CUSTOMERS</a> &raquo;</span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><div data-advadstrackid="98782" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-2081556135"><a href="https://www.mybarbadoslottery.com/" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/My-Bdos-Lottery-Top-Up-20201.jpg" alt="My Bdos Lottery Top Up 20201"  width="336" height="280"   /></a></div></li><li><div data-advadstrackid="98784" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-602201129"><a href="https://wa.me/12468232068" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Cloud-Vision-Academy-2022-Sept-336x280-1.jpg" alt="Cloud Vision Academy 2022 Sept 336x280 1"  width="336" height="280"   /></a></div></li><li><div data-advadstrackid="98783" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-40298293"><a href="http://bit.ly/Baj_248" rel="noopener" class="adv-link" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMzYiIGhlaWdodD0iMjgwIiB2aWV3Qm94PSIwIDAgMzM2IDI4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/SG-Coop-Ad-Gift-Vouchers-336-x-280.jpg" alt="SG Coop Ad Gift Vouchers 336 x 280"  width="336" height="280"   /></a></div></li></ul><ul class="ad ads120x600 cf"><li><div data-advadstrackid="98775" data-advadstrackbid="1" data-advadsredirect="1" class="bajan-target" id="bajan-1033072395"><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775" rel="noopener" class="notrack" target="_blank"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAiIGhlaWdodD0iNjAwIiB2aWV3Qm94PSIwIDAgMTIwIDYwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/120x600-GEL-100th-Anniversary-Comp.jpg" alt="120x600 GEL 100th Anniversary Comp"  width="120" height="600"   /></a></div></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2021/09/2nd-session-of-writers-clinic-2021-2022-mastering-your-manuscript-with-robert-e-sandiford/" title="2nd session of Writers&#8217; Clinic 2021/2022: &#8216;Mastering Your Manuscript&#8217; with Robert E. Sandiford">
2nd session of Writers&#8217; Clinic 2021/2022: &#8216;Mastering Your Manuscript&#8217; with Robert E. Sandiford            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMTgiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTE4IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="118" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2021/09/5078038571520207368_120.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Join us on Saturday October 9th, 2021 from 11 AM - 1 PM for Mastering Your Manuscript with Robert E. Sandiford. (CLICK FOR BIGGER)" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2021/09/5078038571520207368_120.jpg 514w, https://www.bajanreporter.com/wp-content/uploads/2021/09/5078038571520207368_120-214x300.jpg 214w, https://www.bajanreporter.com/wp-content/uploads/2021/09/5078038571520207368_120-400x560.jpg 400w" data-sizes="(max-width: 118px) 100vw, 118px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2021/09/prepare-better-for-2022-with-successful-tutoring-new-online-special/" title="Prepare better for 2022 with Successful Tutoring: New Online Special">
Prepare better for 2022 with Successful Tutoring: New Online Special            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTE3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="117" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2021/09/No-2-Successful-Tutoring-Special-2021.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2021/09/No-2-Successful-Tutoring-Special-2021.jpg 724w, https://www.bajanreporter.com/wp-content/uploads/2021/09/No-2-Successful-Tutoring-Special-2021-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2021/09/No-2-Successful-Tutoring-Special-2021-400x566.jpg 400w" data-sizes="(max-width: 117px) 100vw, 117px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2021/09/barbados-port-incorporated-boosts-their-cctv-network/" title="Barbados Port Incorporated boosts their CCTV Network">
Barbados Port Incorporated boosts their CCTV Network            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNjUiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTY1IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="165" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288-1024x1024.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288-768x768.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/09/IMG_20210921_173855_288-400x400.jpg 400w" data-sizes="(max-width: 165px) 100vw, 165px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2021/09/get-ready-for-oliver-oriole-adventures-book-series/" title="Get ready for &#8220;Oliver Oriole Adventures&#8221; Book Series">
Get ready for &#8220;Oliver Oriole Adventures&#8221; Book Series            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMTMiIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMjEzIDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="213" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2021/09/Oliver-Oriole-300x232.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Get ready for what is about to be one of the most exciting new characters in children’s education." loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2021/09/Oliver-Oriole-300x232.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Oliver-Oriole-1024x791.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Oliver-Oriole-768x593.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Oliver-Oriole-400x309.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Oliver-Oriole.jpg 1200w" data-sizes="(max-width: 213px) 100vw, 213px" /></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2021/09/online-school-is-here-ready-or-not-let-your-children-be-guided-by-successful-tutoring/" title="Online School is here, Ready or Not? Let your children be guided by Successful Tutoring!">
Online School is here, Ready or Not? Let your children be guided by Successful Tutoring!            </a></div>
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMTciIGhlaWdodD0iMTY1IiB2aWV3Qm94PSIwIDAgMTE3IDE2NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="117" height="165" data-src="https://www.bajanreporter.com/wp-content/uploads/2021/09/Successful-Tutoring-2022-Infants-2.0.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="(CLICK FOR BIGGER) Registration is free and closes on the 25th of September" loading="lazy" data-srcset="https://www.bajanreporter.com/wp-content/uploads/2021/09/Successful-Tutoring-2022-Infants-2.0.jpg 724w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Successful-Tutoring-2022-Infants-2.0-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2021/09/Successful-Tutoring-2022-Infants-2.0-400x566.jpg 400w" data-sizes="(max-width: 117px) 100vw, 117px" /></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/pLIu3ahDiy8" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/pLIu3ahDiy8" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/pLIu3ahDiy8" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 28th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/09/guess-whos-back-rod-stewart-one-more-time/" title="Guess who&#8217;s back? Rod Stewart &#8211; One More Time">Guess who&#8217;s back? Rod Stewart &#8211; One More Time</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/RYlUsUBqf_s" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/RYlUsUBqf_s" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/RYlUsUBqf_s" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 23rd, 2021 <br /> <a href="https://www.bajanreporter.com/2021/09/hawkeye-jeremy-renner-florence-pugh-hailee-steinfeld/" title="HAWKEYE: Jeremy Renner, Florence Pugh &#038; Hailee Steinfeld">HAWKEYE: Jeremy Renner, Florence Pugh &#038; Hailee Steinfeld</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/23gsH06MukQ" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/23gsH06MukQ" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/23gsH06MukQ" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 22nd, 2021 <br /> <a href="https://www.bajanreporter.com/2021/09/finch-tom-hanks-lora-martinez-cunningham-caleb-landry-jones/" title="FINCH: Tom Hanks, Lora Martinez-Cunningham &#038; Caleb Landry Jones">FINCH: Tom Hanks, Lora Martinez-Cunningham &#038; Caleb Landry Jones</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/gzEGBAG8x5U" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/gzEGBAG8x5U" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/gzEGBAG8x5U" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 11th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/09/the-matrix-resurrections-2021-keanu-reeves-neil-patrick-harris-carrie-anne-moss/" title="The Matrix Resurrections (2021) &#8211; Keanu Reeves, Neil Patrick Harris &#038; Carrie-Anne Moss">The Matrix Resurrections (2021) &#8211; Keanu Reeves, Neil Patrick Harris &#038; Carrie-Anne Moss</a></div></li><li>
<object style="height: 150px; width: 213px" data="https://youtube.com/v/bEZ5hNd7hsw" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/bEZ5hNd7hsw" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" />
<embed src="https://youtube.com/v/bEZ5hNd7hsw" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
</object><div class="video-details">September 11th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/09/injustice-2021-anson-mount-justin-hartley-kevin-pollak/" title="Injustice (2021) &#8211; Anson Mount, Justin Hartley &#038; Kevin Pollak">Injustice (2021) &#8211; Anson Mount, Justin Hartley &#038; Kevin Pollak</a></div></li></ul></div></div></div>
 <script id='advanced-ads-layer-footer-js-js-extra' type="litespeed/javascript" data-i="14">var advanced_ads_layer_settings={"layer_class":"bajan-layer","placements":["replace-super-popup"]}</script> <script id='advanced-ads-responsive-js-extra' type="litespeed/javascript" data-i="15">var advanced_ads_responsive={"reload_on_resize":"0"}</script> <script id='advadsTrackingScript-js-extra' type="litespeed/javascript" data-i="16">var advadsTracking={"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"bajan-target","blogId":"1"}</script> <script id='advadsTrackingGAFront-js-extra' type="litespeed/javascript" data-i="17">var advadsGALocale={"Impressions":"Impressions","Clicks":"Clicks"}</script> <script type="litespeed/javascript" data-i="18">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script id="bajan-tracking" type="litespeed/javascript" data-i="19">var advads_tracking_ads={"1":[98786,98781,98782,98784,98783,98775]};var advads_tracking_urls={"1":"https:\/\/www.bajanreporter.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods={"1":"onrequest"};var advads_tracking_parallel={"1":!0};var advads_tracking_linkbases={"1":"https:\/\/www.bajanreporter.com\/linkout\/"};var advads_gatracking_uids={"1":"UA-82821259-1"};var advads_gatracking_allads={"1":{"102775":{"title":"Samuel Jackman Prescod - Apply Online","target":"http:\/\/bit.ly\/sjpi2021br","impression":!0,"click":!0},"98786":{"title":"Future Centre (FB Page) 2021","target":"http:\/\/bit.ly\/BR_2021FuCntr","impression":!0,"click":!0},"98785":{"title":"First for the Future - FCIB 2","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":!0,"click":!0},"98784":{"title":"Cloud Vision Academy - September, 2022 Semester","target":"https:\/\/wa.me\/12468232068","impression":!0,"click":!0},"98783":{"title":"Southpaw Grafix 2021 (Inside 336x280)","target":"http:\/\/bit.ly\/Baj_248","impression":!0,"click":!0},"98782":{"title":"My Barbados Lottery (Top Up, 2022)","target":"https:\/\/www.mybarbadoslottery.com\/","impression":!0,"click":!0},"98781":{"title":"First for the Future - FCIB 1","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":!0,"click":!0},"98780":{"title":"C6 Mart: Online Shopping (336x280) - Front Page, Lower","target":"https:\/\/www.c6mart.com\/","impression":!0,"click":!0},"98779":{"title":"RS Electronics - 250x250 January 2022","target":"https:\/\/wa.me\/12462432442","impression":!0,"click":!0},"98778":{"title":"Barbados Accreditation Council (250x250)","target":"https:\/\/bac.gov.bb\/recognition-of-qualification\/","impression":!0,"click":!0},"98777":{"title":"Sandy Pitt 250x250 - 01 January 2022","target":"https:\/\/wa.me\/12462687555","impression":!0,"click":!0},"98776":{"title":"BRA (250x250 Upper Right Quadrangle) Land Tax","target":"https:\/\/is.gd\/BRA2021LT","impression":!0,"click":!0},"98775":{"title":"Goddards Enterprises Ltd - 100th Anniversary (Inside 120x600)","target":"https:\/\/www.goddardenterprisesltd.com\/","impression":!0,"click":!0},"98774":{"title":"Bajan Reporter 120x600 Front Page (In-House)","target":"https:\/\/www.bajanreporter.com\/advertise-with-us\/","impression":!0,"click":!0}}};var advads_gatracking_anonym=!1;var advads_gatracking_transmitpageqs={}</script> <script type="litespeed/javascript" data-i="20">if(typeof window.advadsGATracking==='undefined'){window.advadsGATracking={}}
advadsGATracking.postContext={"postID":104592,"postSlug":"barbados-police-seek-wanted-man-jamal-renaldo-bartlett","cats":"breaking-news,crime-new,featured"}</script> <footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div>
<input type="submit" value="Go" />
<input type="text" name="s" id="s" size="15" />
<label for="s">Search:</label></div></form></div><p> &copy; 2021 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>
 <script type="litespeed/javascript" data-i="21" data-src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>  <script type="litespeed/javascript" data-i="22">$(window).load(function(){$('.flexslider').flexslider();$('#chyrons').cycle({fx:'fade'})})</script> <script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"$1");litespeed_vary||fetch("https://www.bajanreporter.com/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&window.location.reload(!0)});</script><script data-optimized="1" type="litespeed/javascript" data-i="23" data-src="https://www.bajanreporter.com/wp-content/litespeed/js/601723508d205ad5fc590b404454cee6.js?ver=c60a5"></script><script>const litespeed_ui_events=["mouseover","click","keydown","wheel","touchmove","touchstart"];var litespeed_delay_i=0,urlCreator=window.URL||window.webkitURL;function litespeed_load_delayed_js_forced(){console.log("[LiteSpeed] Start Load JS Delayed"),litespeed_ui_events.forEach(function(e){window.removeEventListener(e,litespeed_load_delayed_js_forced,{passive:!0})}),litespeed_load_delayed_js(!0),document.querySelectorAll("iframe[data-litespeed-src]").forEach(function(e){e.setAttribute("src",e.getAttribute("data-litespeed-src"))})}function litespeed_load_delayed_js(e){e&&console.log("[LiteSpeed] Force running delayed JS"),litespeed_load_one()}function litespeed_inline2src(t){try{var d=urlCreator.createObjectURL(new Blob([t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1")],{type:"text/javascript"}))}catch(e){d="data:text/javascript;base64,"+btoa(t.replace(/^(?:<!--)?(.*?)(?:-->)?$/gm,"$1"))}return d}function litespeed_load_one(){litespeed_delay_i++;var t,d=document.querySelector('script[type="litespeed/javascript"][data-i="'+litespeed_delay_i+'"]');d?(console.log("[LiteSpeed] Load i="+d.getAttribute("data-i"),"-----",d),(t=document.createElement("script")).addEventListener("load",function(){console.log("[LiteSpeed] loaded --- "+t.getAttribute("data-i")),litespeed_load_one()},{passive:!0}),t.addEventListener("error",function(){console.log("[LiteSpeed] loaded error! --- "+t.getAttribute("data-i")),litespeed_load_one()},{passive:!0}),d.getAttributeNames().forEach(function(e){"type"!=e&&t.setAttribute("data-src"==e?"src":e,d.getAttribute(e))}),t.type="text/javascript",!t.src&&d.textContent&&(t.src=litespeed_inline2src(d.textContent)),d.after(t),d.remove()):console.log("[LiteSpeed] All loaded!")}litespeed_ui_events.forEach(function(e){window.addEventListener(e,litespeed_load_delayed_js_forced,{passive:!0})});</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":584,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body></html>
<!-- Page optimized by LiteSpeed Cache @2021-09-28 14:14:00 -->
<!-- Page generated by LiteSpeed Cache 4.4.2 on 2021-09-28 10:14:00 -->
<!-- Guest Mode -->