<!doctype html>
<html lang="en-US">
<head>
<title>The Bajan Reporter | Prime Minister Mia Amor Mottley remembers the late Clairmonte Taitt | The Bajan Reporter</title>
<meta charset="UTF-8" /><script type="text/javascript">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</script>

<!-- 1140px Grid styles for IE -->
<!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" />
<link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" />
<link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" />


<!-- The 1140px Grid - http://cssgrid.net/ -->
<link rel="stylesheet" type="text/css" media="screen" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/1140.css" />

<!-- BR styles -->
<link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/bajanreporter.css" type="text/css"  />
<link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/flexslider.css" type="text/css" />

<!--css3-mediaqueries-js - http://code.google.com/p/css3-mediaqueries-js/ - Enables media queries in some unsupported browsers-->
<script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/css3-mediaqueries.js"></script>
<meta name='robots' content='max-image-preview:large' />

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="Every so often, some shining light in our midst flickers out, and it is only then that we pause long enough to recognize the extent to which he or she&#8230;" />
<meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="681" />
<meta property="og:image:alt" content="The product of a Guyanese mother and Barbadian father, Clairmonte (at left with Drew McKenzie) established an unbreakable bond with Barbados well over a half-century ago, visiting with some frequency to take part in theatre productions, in the process building a life-long relationship with the legendary Earl Warner and eventually settling here." />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Prime Minister Mia Amor Mottley remembers the late Clairmonte Taitt | The Bajan Reporter" />
<meta property="og:description" content="Every so often, some shining light in our midst flickers out, and it is only then that we pause long enough to recognize the extent to which he or she illuminated the path we walked. Today&#8230;" />
<meta property="og:url" content="https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/" />
<meta property="og:site_name" content="The Bajan Reporter" />
<meta property="article:published_time" content="2021-06-10" />
<meta property="article:modified_time" content="2021-06-10" />
<meta property="og:updated_time" content="2021-06-10" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bajanreporter" />
<meta name="twitter:title" content="Prime Minister Mia Amor Mottley remembers the late Clairmonte Taitt | The Bajan Reporter" />
<meta name="twitter:description" content="Every so often, some shining light in our midst flickers out, and it is only then that we pause long enough to recognize the extent to which he or she illuminated the path we walked. Today&#8230;" />
<meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest.jpg" />
<meta name="twitter:image:width" content="1024" />
<meta name="twitter:image:height" content="681" />
<meta name="twitter:image:alt" content="The product of a Guyanese mother and Barbadian father, Clairmonte (at left with Drew McKenzie) established an unbreakable bond with Barbados well over a half-century ago, visiting with some frequency to take part in theatre productions, in the process building a life-long relationship with the legendary Earl Warner and eventually settling here." />
<link rel="canonical" href="https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/entertainment/","name":"Entertainment"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/entertainment/culture-entertainment/","name":"Culture"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/","name":"Prime Minister Mia Amor Mottley remembers the late Clairmonte Taitt"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 13.27ms meta | 14.38ms boot -->

<link rel="amphtml" href="https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/amp/" /><meta name="generator" content="AMP for WP 1.0.77.5"/><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Prime Minister Mia Amor Mottley remembers the late Clairmonte Taitt Comments Feed" href="https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- bajanreporter.com is managing ads with Advanced Ads --><script>
			advanced_ads_ready=function(){var e,t=[],n="object"==typeof document&&document,d=n&&n.documentElement.doScroll,o="DOMContentLoaded",a=n&&(d?/^loaded|^c/:/^loaded|^i|^c/).test(n.readyState);return!a&&n&&(e=function(){for(n.removeEventListener(o,e),window.removeEventListener("load",e),a=1;e=t.shift();)e()},n.addEventListener(o,e),window.addEventListener("load",e)),function(e){a?setTimeout(e,0):t.push(e)}}();		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='unslider-css-css'  href='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/css/unslider.css?ver=1.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='slider-css-css'  href='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/css/slider.css?ver=1.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-lightbox-prettyphoto-css'  href='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='smp_style-css'  href='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//colorbox.css?ver=924957335' type='text/css' media='all' />
<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/unslider.min.js?ver=1.4.6' id='unslider-js-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.move.js?ver=1.4.6' id='unslider-move-js-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.swipe.js?ver=1.4.6' id='unslider-swipe-js-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.3.2' id='responsive-lightbox-prettyphoto-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.7.2' id='responsive-lightbox-infinite-scroll-js'></script>
<script type='text/javascript' id='responsive-lightbox-js-extra'>
/* <![CDATA[ */
var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"2e48fc3508"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.3.2' id='responsive-lightbox-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.25.0' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.1' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.12.0' id='advanced-ds-pro/front-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.colorbox-min.js?ver=404246935' id='smp_colorbox-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.utils-min.js?ver=89416658' id='smp_cookie-js'></script>
<script type='text/javascript' id='smp-script-js-extra'>
/* <![CDATA[ */
var smp_vars = {"cookie_id":"1623328383849","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"835","popup_height":"835","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//wp-super-popup.js?ver=1886064820' id='smp-script-js'></script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-14400"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.12.0' id='advanced-ads-pro/cache_busting-js'></script>
<link rel="https://api.w.org/" href="https://www.bajanreporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bajanreporter.com/wp-json/wp/v2/posts/103574" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2021%2F06%2Fprime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2021%2F06%2Fprime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt%2F&#038;format=xml" />
<script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="bajan-layer-custom-css"></style>
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["culture-entertainment","featured"],"pageAttributes":["barbados","classics","death","drama","government","radio","theatre","tribute"],"pagePostAuthor":"Bajan Reporter"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
				<script type="text/javascript">
			if ( typeof advadsGATracking === 'undefined' ) {
				window.advadsGATracking = {
					delayedAds: {},
					deferedAds: {}
				};
			}
		</script>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
</head>

<body>
<div id="header" class="container"> 

<!-- Get 5 breaking news items -->	  
    <div id="breakingnews" class="row">
    <div class="threecol">
      <p><strong>BREAKING NEWS</strong></p>
    </div>
    <div class="ninecol last">
      <ul id="chyrons" class="cf">
		        <li><a href="https://www.bajanreporter.com/2021/06/the-students-of-the-caribbean-say-no-way-cxc/" title="The Students of the Caribbean Say &#8220;No Way, CXC&#8221;">The Students of the Caribbean Say &#8220;No Way, CXC&#8221;</a></li>
                <li><a href="https://www.bajanreporter.com/2021/06/barbados-creates-history-by-planting-corals-at-carlisle-bay/" title="BARBADOS CREATES HISTORY BY PLANTING CORALS AT CARLISLE BAY">BARBADOS CREATES HISTORY BY PLANTING CORALS AT CARLISLE BAY</a></li>
                <li><a href="https://www.bajanreporter.com/2021/06/destination-barbados-tv-not-affiliated-with-btmis-destination-barbados/" title="Destination Barbados TV not affiliated with BTMI&#8217;s &#8216;Destination Barbados&#8217;">Destination Barbados TV not affiliated with BTMI&#8217;s &#8216;Destination Barbados&#8217;</a></li>
                <li><a href="https://www.bajanreporter.com/2021/06/play-win-multiply-with-the-barbados-lotterys-all-new-multiplier-suite-of-games/" title="Play, Win &#038; Multiply with The Barbados Lottery’s all new Multiplier Suite of Games">Play, Win &#038; Multiply with The Barbados Lottery’s all new Multiplier Suite of Games</a></li>
                <li><a href="https://www.bajanreporter.com/2021/06/wisconsins-mantra-forward-make-that-backward/" title="Wisconsin&#8217;s mantra, &#8220;Forward&#8221;? Make that &#8220;Backward&#8221;">Wisconsin&#8217;s mantra, &#8220;Forward&#8221;? Make that &#8220;Backward&#8221;</a></li>
                        </ul>
    </div>
  </div>
  <!-- end breaking news -->
  </div>
<!-- end header --> 

<div id="masthead" class="row">
  <div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></a> <span id="edition-date"><strong>Today</strong> Thursday, June 10th, 2021</span> </div>
  <div class="sevencol last">
<div data-advadstrackid="98786" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-1455945167"><a href="http://bit.ly/BR_2021FuCntr" class="adv-link" target="_blank"><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/strip.gif" alt="strip"  width="728" height="90"   /></a></div>  </div>
</div>
<nav class="row cf">
  <div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li>
<li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a>
<ul class="sub-menu">
	<li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li>
	<li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li>
	<li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li>
	<li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li>
	<li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li>
	<li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li>
	<li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li>
	<li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li>
	<li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li>
</ul>
</li>
<li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a>
<ul class="sub-menu">
	<li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li>
	<li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li>
	<li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li>
</ul>
</li>
<li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li>
<li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li>
	<li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li>
	<li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li>
	<li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li>
	<li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li>
</ul>
</li>
<li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li>
<li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a>
<ul class="sub-menu">
	<li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li>
	<li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li>
	<li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li>
	<li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li>
</ul>
</li>
<li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li>
<li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li>
<li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li>
	<li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li>
	<li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li>
	<li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li>
	<li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li>
	<li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li>
	<li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li>
	<li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li>
	<li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li>
</ul>
</li>
</ul></div></nav>

<!-- end #masthead -->
<div id="main" class="container" role="main">
  <div class="row">
    <section id="single-article" class="sevencol">
    	        <article id="post-103574" class="post-103574 post type-post status-publish format-standard has-post-thumbnail hentry category-culture-entertainment category-featured tag-barbados tag-classics tag-death tag-drama tag-government tag-radio tag-theatre tag-tribute">
        <h1>Prime Minister Mia Amor Mottley remembers the late Clairmonte Taitt</h1>
        <p class="post-meta">by  Bajan Reporter / June 10th, 2021</p> 
        
              <!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_preferred_1"></a>
<a class="addthis_button_preferred_2"></a>
<a class="addthis_button_preferred_3"></a>
<a class="addthis_button_preferred_4"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a>
</div>
<script src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script>
<!-- AddThis Button END -->
        
	     <p>Every so often, some shining light in our midst flickers out, and it is only then that we pause long enough to recognize the extent to which he or she illuminated the path we walked.</p>
<p>Today, as I pause to pay tribute to Clairmonte Taitt at his passing, I cannot help but reflect on his quiet but outstanding contribution to life in Barbados &#8212; to the performing arts and to broadcasting &#8212; and to bridging the waters between us and Guyana, where he was born.</p>
<div id="attachment_103575" style="width: 310px" class="wp-caption aligncenter"><a href="https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest.jpg" data-rel="lightbox-gallery-gwoNq5e4" data-rl_title="" data-rl_caption="" title=""><img aria-describedby="caption-attachment-103575" loading="lazy" class="size-medium wp-image-103575" title="Cast member Drew McKenzie with gala guest" src="https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest-300x200.jpg" alt="The product of a Guyanese mother and Barbadian father, &lt;strong&gt;Clairmonte&lt;/strong&gt; (&lt;em&gt;at left with Drew McKenzie&lt;/em&gt;) established an unbreakable bond with Barbados well over a half-century ago, visiting with some frequency to take part in theatre productions, in the process building a life-long relationship with the legendary Earl Warner and eventually settling here." width="300" height="200" srcset="https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest-300x200.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest-768x511.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest-400x266.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Cast-member-Drew-McKenzie-with-gala-guest.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><p id="caption-attachment-103575" class="wp-caption-text">The product of a Guyanese mother and Barbadian father, <strong>Clairmonte</strong> (<em>at left with Drew McKenzie</em>) established an unbreakable bond with Barbados well over a half-century ago, visiting with some frequency to take part in theatre productions, in the process building a life-long relationship with the legendary Earl Warner and eventually settling here.</p></div>
<p>Clairmonte&#8217;s life can serve as an inspiration for Caribbean people today, but only if we are able to throw away that impaired vision that too often compels us to view the Caribbean Sea as an obstacle rather than a pathway to endless promise and possibilities.</p>
<blockquote><p>I salute you, Clairmonte &#8212; <strong>actor, director, vocalist, violinist</strong> and<strong> broadcaster</strong>. As you soar with the angels, we will not dishonour the legacy you have left for the people of the Caribbean after 88 years in our midst.</p></blockquote>
<p>On behalf of the Government and people of Barbados, I extend sincere condolences to his family, friends and the performing arts community of Barbados, who will no doubt miss his pronounced tenor voice on and off the stage.</p>
<p>May his soul rest in peace.</p>
		
        
        </article>
         <!-- end #post-103574 -->
        <div id="article-ad">
            <div class="ads468x60">
<div data-advadstrackid="98781" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-6609613"><a href="https://www.instagram.com/bajanreporteronline/" class="adv-link" target="_blank"><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" alt="Follow on Instagram"  width="468" height="80"   /></a></div>            </div>
        </div>
        
        
        
<h2 id="comments"></h2>

<p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p>

<div id="respond">
<h3 class="comments-heading">Comments</h3>
<h4>add a comment</h4>
<form action="https://www.bajanreporter.com/wp-comments-post.php" method="post">
	<!--<label for="comment">Post a comment</label>-->
	<a rel="nofollow" id="cancel-comment-reply-link" href="/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/#respond" style="display:none;">Click here to cancel reply.</a>	<p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p>
	<textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea>
	<p>
		<input type="text" name="author" id="author" value="" size="22" tabindex="2" />
		<label for="author">Name <em>(required)</em></label>
	</p>
	<p>
		<input type="text" name="email" id="email" value="" size="22" tabindex="3" />
		<label for="email">Email <em>(required, but never shared)</em></label>
	</p>
	<p>
		<input type="text" name="url" id="url" value="" size="22" tabindex="4" />
		<label title="Your website address" for="url">Web</label>
	</p>
	<p>
		<input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" />
		or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2021/06/prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt/trackback/">trackback</a>.	</p>
<input type='hidden' name='comment_post_ID' value='103574' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="97d5a7ff13" /></p><input type="hidden" id="ak_js" name="ak_js" value="30"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>
</div>
        
        <!-- end comments -->
                
        
        
<div class="pagination_single">
	<ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2021/06/the-students-of-the-caribbean-say-no-way-cxc/" rel="prev">The Students of the Caribbean Say &#8220;No Way, CXC&#8221;</a></span></li>
	<li><span class="next">Next: </span></li></ul>
</div>
        
    </section>
    <!-- end single-article section -->
    
    <div id="post-aside" class="fivecol last">
       
    	 <ul class="ad ads336x280 cf">
        	<li><div data-advadstrackid="98782" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-1261432551"><a href="https://www.mybarbadoslottery.com/" class="adv-link" target="_blank"><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/My-Bdos-Lottery-Top-Up-20201.jpg" alt="My Bdos Lottery Top Up 20201"  width="336" height="280"   /></a></div></li>
          <li><div data-advadstrackid="98784" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-1804512802"><a href="https://wa.me/12462323093" class="adv-link" target="_blank"><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/All-Terrain-2021-May-336x280-1.jpg" alt="All Terrain 2021 May 336x280 1"  width="336" height="280"   /></a></div></li>
          <li><div data-advadstrackid="98783" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-126217776"><a href="http://bit.ly/Baj_248" class="adv-link" target="_blank"><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/SG-Creative-Right-Brain-Ad-336x280-01-1.jpg" alt="SG Creative Right Brain Ad 336x280 01 1"  width="336" height="280"   /></a></div></li>
        </ul>
        
        <ul class="ad ads120x600 cf">
        	<li><div data-advadstrackid="98775" data-advadstrackbid="1" data-advadsredirect="" class="bajan-target" id="bajan-518578663"><a href="http://bit.ly/CG_TLC" class="adv-link" target="_blank"><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Poster7_120x600.jpg" alt="Poster7 120x600"  width="150" height="600"   /></a></div></li>
        </ul>
        
      
    </div>
    <!-- end #auxillary -->
  </div>
</div>
<!-- end #main -->

<div id="multimedia" class="container">
    <div id="photo-gallery" class="row">
    <div class="twelvecol">
      <h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2>
      <ul id="images-reel" class="cf">
                        <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2021/06/wi-squad-announced-for-1st-betway-test-vs-south-africa/" title="WI Squad announced for 1st Betway Test vs South Africa">
            WI Squad announced for 1st Betway Test vs South Africa            </a></div>
          <img width="165" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER" loading="lazy" srcset="https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad.jpg 1200w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad-1024x1024.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad-768x768.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Windies-Squad-400x400.jpg 400w" sizes="(max-width: 165px) 100vw, 165px" />        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2021/06/pandemic-restrictions-lighten-once-more-horse-racing-and-shopping-on-sundays-gradually-allowed/" title="Pandemic Restrictions lighten once more; Horse-Racing and Shopping on Sundays gradually allowed">
            Pandemic Restrictions lighten once more; Horse-Racing and Shopping on Sundays gradually allowed            </a></div>
          <img width="165" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.29.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="In the latest COVID-19 management update on Saturday evening, Minister of Home Affairs Wilfred Abrahams announced a new directive (NO. 11) would go into effect on Tuesday until June 29." loading="lazy" srcset="https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.29.jpg 720w, https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.29-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.29-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.29-400x400.jpg 400w" sizes="(max-width: 165px) 100vw, 165px" />        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2021/06/directive-no-11-effective-tues-8th-june-2021-icymi-ataglance-pandemicresponse-noretreatnosurrender/" title="Directive No. 11 effective Tues 8th June 2021 #ICYMI #ataglance #pandemicresponse #noretreatnosurrender">
            Directive No. 11 effective Tues 8th June 2021 #ICYMI #ataglance #pandemicresponse #noretreatnosurrender            </a></div>
          <img width="165" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.57.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Lt Col Jeffrey Bostic" loading="lazy" srcset="https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.57.jpg 720w, https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.57-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.57-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2021/06/2021-06-05-16.53.57-400x400.jpg 400w" sizes="(max-width: 165px) 100vw, 165px" />        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2021/06/tuesday-8th-june-is-george-lammings-94th-birthday-prof-richard-drayton-helps-bajans-celebrate/" title="Tuesday 8th June is George Lamming&#8217;s 94th Birthday! Prof Richard Drayton helps Bajans celebrate&#8230;">
            Tuesday 8th June is George Lamming&#8217;s 94th Birthday! Prof Richard Drayton helps Bajans celebrate&#8230;            </a></div>
          <img width="117" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Prof Richard Drayton lecture - Virtual (EBCCI)" loading="lazy" srcset="https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1.jpg 1414w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1-724x1024.jpg 724w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1-768x1086.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1-1086x1536.jpg 1086w, https://www.bajanreporter.com/wp-content/uploads/2021/06/Lamming-Draft-2-1-400x566.jpg 400w" sizes="(max-width: 117px) 100vw, 117px" />        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2021/06/st-george-pic-entrepreneurship-community-expo-june-2021/" title="St George PIC Entrepreneurship &#038; Community Expo &#8211; June 2021">
            St George PIC Entrepreneurship &#038; Community Expo &#8211; June 2021            </a></div>
          <img width="165" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2021/06/St.-George-PIC-IG-Expo-June-2021-01.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="CLICK FOR BIGGER (St. George PIC Entrepreneurship &amp; Community Expo - June 2021)" loading="lazy" srcset="https://www.bajanreporter.com/wp-content/uploads/2021/06/St.-George-PIC-IG-Expo-June-2021-01.jpg 900w, https://www.bajanreporter.com/wp-content/uploads/2021/06/St.-George-PIC-IG-Expo-June-2021-01-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2021/06/St.-George-PIC-IG-Expo-June-2021-01-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2021/06/St.-George-PIC-IG-Expo-June-2021-01-768x768.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2021/06/St.-George-PIC-IG-Expo-June-2021-01-400x400.jpg 400w" sizes="(max-width: 165px) 100vw, 165px" />        </li>
                      </ul>
    </div>
          </div>
  <!-- end #photo-gallery -->
  
    <div id="video-gallery" class="row">
    <div class="twelvecol">
      <h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2>
      <ul id="video-playlist" class="cf">
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/3jZ0MBXWMso" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/3jZ0MBXWMso" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/3jZ0MBXWMso" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">June 9th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/06/brandon-camphor-and-oneways-a-cappella-rendition-of-lift-every-voice-is-the-soundtrack-for-black-music-month/" title="BRANDON CAMPHOR AND ONEWAY&#8217;S A CAPPELLA RENDITION OF &#8220;LIFT EVERY VOICE&#8221; IS THE SOUNDTRACK FOR BLACK MUSIC MONTH">BRANDON CAMPHOR AND ONEWAY&#8217;S A CAPPELLA RENDITION OF &#8220;LIFT EVERY VOICE&#8221; IS THE SOUNDTRACK FOR BLACK MUSIC MONTH</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/zto5B7cYM6Y" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/zto5B7cYM6Y" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/zto5B7cYM6Y" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">June 6th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/06/infinite-2021-chiwetel-ejiofor-dylan-obrien/" title="INFINITE (2021) Chiwetel Ejiofor &#038; Dylan O&#8217;Brien">INFINITE (2021) Chiwetel Ejiofor &#038; Dylan O&#8217;Brien</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/l09T87hEstI" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/l09T87hEstI" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/l09T87hEstI" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">June 6th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/06/riders-of-justice-2021-mads-mikkelsen/" title="Riders of Justice (2021) Mads Mikkelsen">Riders of Justice (2021) Mads Mikkelsen</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.cpm/v/Qr5NixKgrz8" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.cpm/v/Qr5NixKgrz8" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.cpm/v/Qr5NixKgrz8" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">June 6th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/06/around-town-dexter-showtime/" title="&#8216;Around Town&#8217; Dexter &#8211; SHOWTIME">&#8216;Around Town&#8217; Dexter &#8211; SHOWTIME</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/2dmAtXyp3zI" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/2dmAtXyp3zI" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/2dmAtXyp3zI" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">June 5th, 2021 <br /> <a href="https://www.bajanreporter.com/2021/06/technology-portal-brings-revolutionary-approach-to-marine-management/" title="Technology Portal Brings Revolutionary Approach to Marine Management">Technology Portal Brings Revolutionary Approach to Marine Management</a></div>
        </li>
              </ul>
    </div>
  </div>
  <!-- end #video-gallery -->
    </div>
<!-- end #multimedia -->

<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' id='advanced-ads-layer-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"bajan-layer","placements":["replace-super-popup"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.7.2' id='advanced-ads-layer-footer-js-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"bajan-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.0.1' id='advadsTrackingScript-js'></script>
<script type='text/javascript' id='advadsTrackingGAFront-js-extra'>
/* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/ga-tracking.min.js?ver=2.0.1' id='advadsTrackingGAFront-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/delayed.min.js?ver=2.0.1' id='advadsTrackingDelayed-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script>window.advads_has_ads = [["98786","ad",null],["98781","ad",null],["98782","ad",null],["98784","ad",null],["98783","ad",null],["98775","ad",null]];
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><script>var advads_tracking_ads = {"1":[98786,98781,98782,98784,98783,98775]};var advads_tracking_urls = {"1":"https:\/\/www.bajanreporter.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"onrequest"};var advads_tracking_parallel = {"1":true};var advads_tracking_linkbases = {"1":"https:\/\/www.bajanreporter.com\/linkout\/"};var advads_gatracking_uids = {"1":"UA-82821259-1"};var advads_gatracking_allads = {"1":{"102775":{"title":"Samuel Jackman Prescod - Apply Online","target":"http:\/\/bit.ly\/sjpi2021br","impression":true,"click":true},"98836":{"title":"HARRIS Christmas 2019_640x720","target":"https:\/\/www.facebook.com\/championsofcolour\/","impression":true,"click":true},"98786":{"title":"Future Centre (FB Page) 2021","target":"http:\/\/bit.ly\/BR_2021FuCntr","impression":true,"click":true},"98785":{"title":"First for the Future - FCIB 2","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":true,"click":true},"98784":{"title":"FCIB - First for the Future, 19 May 2021","target":"https:\/\/wa.me\/12462323093","impression":true,"click":true},"98783":{"title":"Southpaw Grafix 2021 (Inside 336x280)","target":"http:\/\/bit.ly\/Baj_248","impression":true,"click":true},"98782":{"title":"My Barbados Lottery (Top Up Again, etc.)","target":"https:\/\/www.mybarbadoslottery.com\/","impression":true,"click":true},"98781":{"title":"First for the Future - FCIB 1","target":"https:\/\/www.instagram.com\/bajanreporteronline\/","impression":true,"click":true},"98780":{"title":"BiBS 2021 Tax Season (336x280) - Front Pg, Lower","target":"https:\/\/wa.me\/12462340979","impression":true,"click":true},"98779":{"title":"Ocean Fisheries - 250x250 Free Delivery","target":"http:\/\/bit.ly\/Teleg_BR","impression":true,"click":true},"98778":{"title":"Entrypass - Instagram URL (250x250)","target":"http:\/\/bit.ly\/Baj_295","impression":true,"click":true},"98777":{"title":"Ansel General Construction 250x250 - 01 July 2021","target":"http:\/\/bit.ly\/Ans3l_GC","impression":true,"click":true},"98776":{"title":"Chevon Graham (250x250 Upper Right Quadrangle) Guardian","target":"http:\/\/bit.ly\/Bsc_CG","impression":true,"click":true},"98775":{"title":"Chevon Graham - Guardian Tower (Inside 120x600)","target":"http:\/\/bit.ly\/CG_TLC","impression":true,"click":true},"98774":{"title":"My Guardian Group 120x600 Front Page (David Cave)","target":"mailto:David.Cave@myguardiangroup.com","impression":true,"click":true}}};var advads_gatracking_anonym = false;var advads_gatracking_transmitpageqs = {};</script>			<script type="text/javascript">
				if ( typeof window.advadsGATracking === 'undefined' ) {
					window.advadsGATracking = {};
				}
								advadsGATracking.postContext = {"postID":103574,"postSlug":"prime-minister-mia-amor-mottley-remembers-the-late-clairmonte-taitt","cats":"culture-entertainment,featured"};
							</script>
			<footer class="container">
  <div class="row">
    <div id="col1" class="threecol">
      <div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li>
<li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li>
<li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li>
<li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li>
<li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li>
</ul></div>    </div>
    <div id="col2" class="threecol">
      <ul>
        <li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li>
        <li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li>
      </ul>
    </div>
    <div id="copyright" class="sixcol last">
    <div id="search" class="cf">
    	
        <form id="searchform" method="get" action="https://www.bajanreporter.com">
          <div>
          	<input type="submit" value="Go" />
             <input type="text" name="s" id="s" size="15" />
              <label for="s">Search:</label>
          </div>
            
         </form>
    </div>
    
    
   <p> &copy; 2021 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p>
      <p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div>
  </div>
</footer>
<!-- JS -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>
<script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.flexslider-min.js"></script>
<script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.cycle.all.latest.js"></script>

<!-- Place in the <head>, after the three links -->
<script>
  $(window).load(function() {
    $('.flexslider').flexslider();
	
	 $('#chyrons').cycle({
		fx: 'fade' // choose your transition type, ex: fade, scrollUp, shuffle, etc...
	});	
  });
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":556,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>


</html>
<!-- Page generated by LiteSpeed Cache 3.6.4 on 2021-06-10 13:44:16 -->