<!doctype html>
<html lang="en-US">
<head>
<title>The Bajan Reporter | Second&#x2d;Half Income Tax Payment Due by Month End | The Bajan Reporter</title>
<meta charset="UTF-8" /><script type="text/javascript">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</script>

<!-- 1140px Grid styles for IE -->
<!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" />
<link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" />
<link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" />


<!-- The 1140px Grid - http://cssgrid.net/ -->
<link data-minify="1" rel="stylesheet" type="text/css" media="screen" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/1140-e59178f18ac882b84700352b77d0138a.css" />

<!-- BR styles -->
<link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/bajanreporter-8413fae567e90b36a08b5002f507b398.css" type="text/css"  />
<link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/flexslider-ca447e174439696f96a4564d297f3a7a.css" type="text/css" />

<!--css3-mediaqueries-js - http://code.google.com/p/css3-mediaqueries-js/ - Enables media queries in some unsupported browsers-->
<script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/css3-mediaqueries.js"></script>

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="The Barbados Revenue Authority is reminding employees and pensioners to complete the second-half payment for their 2019 Personal Income Tax by Wednesday&#8230;" />
<meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/09/20190504_133210.jpg" />
<meta property="og:image:width" content="768" />
<meta property="og:image:height" content="1024" />
<meta property="og:image:alt" content="20190504 133210" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Second&#x2d;Half Income Tax Payment Due by Month End | The Bajan Reporter" />
<meta property="og:description" content="The Barbados Revenue Authority is reminding employees and pensioners to complete the second-half payment for their 2019 Personal Income Tax by Wednesday, September 30, 2020. The first-half was due by&#8230;" />
<meta property="og:url" content="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/" />
<meta property="og:site_name" content="The Bajan Reporter" />
<meta property="article:published_time" content="2020-09-30" />
<meta property="article:modified_time" content="2020-09-30" />
<meta property="og:updated_time" content="2020-09-30" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bajanreporter" />
<meta name="twitter:title" content="Second&#x2d;Half Income Tax Payment Due by Month End | The Bajan Reporter" />
<meta name="twitter:description" content="The Barbados Revenue Authority is reminding employees and pensioners to complete the second-half payment for their 2019 Personal Income Tax by Wednesday, September 30, 2020. The first-half was due by&#8230;" />
<meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/09/20190504_133210.jpg" />
<meta name="twitter:image:width" content="768" />
<meta name="twitter:image:height" content="1024" />
<meta name="twitter:image:alt" content="20190504 133210" />
<link rel="canonical" href="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/new/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/new/business-new/","name":"Business"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/","name":"Second-Half Income Tax Payment Due by Month End"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 20.24ms meta | 24.94ms boot -->

<link rel="amphtml" href="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/amp/" /><meta name="generator" content="AMP for WP 1.0.63"/><link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Second-Half Income Tax Payment Due by Month End Comments Feed" href="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- bajanreporter.com is managing ads with Advanced Ads --><!--noptimize--><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<!--/noptimize--><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link data-minify="1" rel='stylesheet' id='unslider-css-css'  href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/unslider-468a32c089a5781d815ec685581d6abf.css' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='slider-css-css'  href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/slider-3a20a17ea79aeacf589b560b9b8da379.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-lightbox-prettyphoto-css'  href='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.2.3' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='smp_style-css'  href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/wp-super-popup/colorbox-1ae9bc0a351cd0e8af84984ea515a357.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/unslider.min.js?ver=1.4.6' id='unslider-js-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.move.js?ver=1.4.6' id='unslider-move-js-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.swipe.js?ver=1.4.6' id='unslider-swipe-js-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.2.3' id='responsive-lightbox-prettyphoto-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.5.1' id='responsive-lightbox-infinite-scroll-js'></script>
<script type='text/javascript' id='responsive-lightbox-js-extra'>
/* <![CDATA[ */
var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"d947a166f4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.3' id='responsive-lightbox-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.20.1' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.9.2' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.10.0' id='advanced-ds-pro/front-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.colorbox-min.js?ver=1188319649' id='smp_colorbox-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.utils-min.js?ver=1692858249' id='smp_cookie-js'></script>
<script type='text/javascript' id='smp-script-js-extra'>
/* <![CDATA[ */
var smp_vars = {"cookie_id":"1596465255186","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"640","popup_height":"480","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//wp-super-popup.js?ver=485320209' id='smp-script-js'></script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.10.0' id='advanced-ads-pro/cache_busting-js'></script>
<link rel="https://api.w.org/" href="https://www.bajanreporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.bajanreporter.com/wp-json/wp/v2/posts/100865" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F09%2Fsecond-half-income-tax-payment-due-by-month-end%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F09%2Fsecond-half-income-tax-payment-due-by-month-end%2F&#038;format=xml" />
<script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="bajan-layer-custom-css"></style>
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["breaking-news","business-new","featured"],"pagePostAuthor":"Bajan Reporter"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<script type="text/javascript">
			if ( 'undefined' == typeof advadsGATracking ) window.advadsGATracking = {};
		</script>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>

<body>
<div id="header" class="container"> 

<!-- Get 5 breaking news items -->	  
    <div id="breakingnews" class="row">
    <div class="threecol">
      <p><strong>BREAKING NEWS</strong></p>
    </div>
    <div class="ninecol last">
      <ul id="chyrons" class="cf">
		        <li><a href="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/" title="Second-Half Income Tax Payment Due by Month End">Second-Half Income Tax Payment Due by Month End</a></li>
                <li><a href="https://www.bajanreporter.com/2020/09/courtesy-garage-to-launch-an-electrical-suv-by-december/" title="COURTESY GARAGE TO LAUNCH AN ELECTRICAL SUV BY DECEMBER">COURTESY GARAGE TO LAUNCH AN ELECTRICAL SUV BY DECEMBER</a></li>
                <li><a href="https://www.bajanreporter.com/2020/09/solutions-barbados-st-george-north-manifesto/" title="Solutions Barbados &#8211; St George North Manifesto">Solutions Barbados &#8211; St George North Manifesto</a></li>
                <li><a href="https://www.bajanreporter.com/2020/09/ensure-banking-details-in-tamis-are-up-to-date/" title="Ensure Banking Details in TAMIS Are Up-to-Date">Ensure Banking Details in TAMIS Are Up-to-Date</a></li>
                <li><a href="https://www.bajanreporter.com/2020/09/solutions-barbados-what-happens-if-we-replace-our-governor-general-with-a-president/" title="Solutions Barbados &#8211; What Happens if we replace our Governor General with a President?">Solutions Barbados &#8211; What Happens if we replace our Governor General with a President?</a></li>
                        </ul>
    </div>
  </div>
  <!-- end breaking news -->
  </div>
<!-- end header --> 

<div id="masthead" class="row">
  <div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Bajan Reporter" data-lazy-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" /><noscript><img src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></noscript></a> <span id="edition-date"><strong>Today</strong> Thursday, October 1st, 2020</span> </div>
  <div class="sevencol last">
<a data-bid="1" href="https://www.bajanreporter.com/linkout/98786" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" alt="ArtsEtc Barbados 2019 IndyList"  width="728" height="90"   data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/ArtsEtc-Barbados-2019-IndyList.png" /><noscript><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/ArtsEtc-Barbados-2019-IndyList.png" alt="ArtsEtc Barbados 2019 IndyList"  width="728" height="90"   /></noscript></a>  </div>
</div>
<nav class="row cf">
  <div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li>
<li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a>
<ul class="sub-menu">
	<li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li>
	<li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li>
	<li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li>
	<li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li>
	<li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li>
	<li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li>
	<li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li>
	<li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li>
	<li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li>
</ul>
</li>
<li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a>
<ul class="sub-menu">
	<li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li>
	<li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li>
	<li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li>
</ul>
</li>
<li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li>
<li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li>
	<li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li>
	<li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li>
	<li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li>
	<li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li>
</ul>
</li>
<li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li>
<li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a>
<ul class="sub-menu">
	<li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li>
	<li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li>
	<li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li>
	<li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li>
</ul>
</li>
<li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li>
<li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li>
<li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li>
	<li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li>
	<li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li>
	<li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li>
	<li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li>
	<li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li>
	<li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li>
	<li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li>
	<li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li>
</ul>
</li>
</ul></div></nav>

<!-- end #masthead -->
<div id="main" class="container" role="main">
  <div class="row">
    <section id="single-article" class="sevencol">
    	        <article id="post-100865" class="post-100865 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-business-new category-featured">
        <h1>Second-Half Income Tax Payment Due by Month End</h1>
        <p class="post-meta">by  Bajan Reporter / September 30th, 2020</p> 
        
              <!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_preferred_1"></a>
<a class="addthis_button_preferred_2"></a>
<a class="addthis_button_preferred_3"></a>
<a class="addthis_button_preferred_4"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a>
</div>
<script src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script>
<!-- AddThis Button END -->
        
	     <p>The Barbados Revenue Authority is reminding employees and pensioners to complete the second-half payment for their 2019 Personal Income Tax by Wednesday, September 30, 2020.</p>
<p>The first-half was due by the extended June 30, 2020 filing deadline. Taxpayers who are yet to pay the first-half, should ensure they pay the total amount by Wednesday&#8217;s deadline.</p>
<p>Persons are advised to create their electronic payment advice in TAMIS before making in-person payments or drop box cheque submissions at any BRA location except the Pine. Payments can also be made online using the bank transfer option, the details of which are on the Authority&#8217;s website at bra.gov.bb.</p>
<p>A penalty of 5 percent or $10, whichever is greater, as well as interest at the rate of 1 percent per month, will be applied to any unpaid balance.</p>
		
        
        </article>
         <!-- end #post-100865 -->
        <div id="article-ad">
            <div class="ads468x60">
<a data-bid="1" href="https://www.bajanreporter.com/linkout/98781" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20468%20150'%3E%3C/svg%3E" alt="EMERA SOLAR FUH WE FB PINNED POST 1200x628 FINAL"  width="468" height="150"   data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/EMERA_SOLAR-FUH-WE_FB_PINNED-POST_1200x628_FINAL.jpg" /><noscript><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/EMERA_SOLAR-FUH-WE_FB_PINNED-POST_1200x628_FINAL.jpg" alt="EMERA SOLAR FUH WE FB PINNED POST 1200x628 FINAL"  width="468" height="150"   /></noscript></a>            </div>
        </div>
        
        
        
<h2 id="comments"></h2>

<p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p>

<div id="respond">
<h3 class="comments-heading">Comments</h3>
<h4>add a comment</h4>
<form action="https://www.bajanreporter.com/wp-comments-post.php" method="post">
	<!--<label for="comment">Post a comment</label>-->
	<a rel="nofollow" id="cancel-comment-reply-link" href="/2020/09/second-half-income-tax-payment-due-by-month-end/#respond" style="display:none;">Click here to cancel reply.</a>	<p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p>
	<textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea>
	<p>
		<input type="text" name="author" id="author" value="" size="22" tabindex="2" />
		<label for="author">Name <em>(required)</em></label>
	</p>
	<p>
		<input type="text" name="email" id="email" value="" size="22" tabindex="3" />
		<label for="email">Email <em>(required, but never shared)</em></label>
	</p>
	<p>
		<input type="text" name="url" id="url" value="" size="22" tabindex="4" />
		<label title="Your website address" for="url">Web</label>
	</p>
	<p>
		<input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" />
		or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2020/09/second-half-income-tax-payment-due-by-month-end/trackback/">trackback</a>.	</p>
<input type='hidden' name='comment_post_ID' value='100865' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="81a5caaac7" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="171"/></p></form>
</div>
        
        <!-- end comments -->
                
        
        
<div class="pagination_single">
	<ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2020/09/hinds-and-manning-win-chefette-summer-safari/" rel="prev">HINDS AND MANNING WIN CHEFETTE SUMMER SAFARI</a></span></li>
	<li><span class="next">Next: </span></li></ul>
</div>
        
    </section>
    <!-- end single-article section -->
    
    <div id="post-aside" class="fivecol last">
       
    	 <ul class="ad ads336x280 cf">
        	<li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98782" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt="Triple Cash 26 July 2020"  width="336" height="280"   data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Triple-Cash-26-July-2020.jpg" /><noscript><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Triple-Cash-26-July-2020.jpg" alt="Triple Cash 26 July 2020"  width="336" height="280"   /></noscript></a></li>
          <li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt="IMG 20200702 WA0005"  width="336" height="280"   data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/IMG-20200702-WA0005.jpg" /><noscript><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/IMG-20200702-WA0005.jpg" alt="IMG 20200702 WA0005"  width="336" height="280"   /></noscript></a></li>
          <li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98783" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt="Breakfast Cutter Happy Days"  width="336" height="280"   data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Breakfast-Cutter-Happy-Days.jpg" /><noscript><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Breakfast-Cutter-Happy-Days.jpg" alt="Breakfast Cutter Happy Days"  width="336" height="280"   /></noscript></a></li>
        </ul>
        
        <ul class="ad ads120x600 cf">
        	<li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20600'%3E%3C/svg%3E" alt="Julie 07"  width="120" height="600"   data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Julie-07.png" /><noscript><img src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Julie-07.png" alt="Julie 07"  width="120" height="600"   /></noscript></a></li>
        </ul>
        
      
    </div>
    <!-- end #auxillary -->
  </div>
</div>
<!-- end #main -->

<div id="multimedia" class="container">
    <div id="photo-gallery" class="row">
    <div class="twelvecol">
      <h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2>
      <ul id="images-reel" class="cf">
                        <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2020/09/your-cure-for-the-quarantine-blues-the-big-fall-nick-seven-book-7/" title="Your Cure for the Quarantine Blues &#8211; &#8220;The Big Fall&#8221; (Nick Seven Book 7)">
            Your Cure for the Quarantine Blues &#8211; &#8220;The Big Fall&#8221; (Nick Seven Book 7)            </a></div>
          <img width="110" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20110%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="Just in time to beat the pandemic blues, here&#039;s my new mystery/thriller, &quot;The Big Fall&quot; (Nick Seven Book 7). It&#039;s available on Amazon in Kindle AND paperback." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/The-Big-Fall-Marc-Smith.jpg 340w, https://www.bajanreporter.com/wp-content/uploads/2020/09/The-Big-Fall-Marc-Smith-200x300.jpg 200w" data-lazy-sizes="(max-width: 110px) 100vw, 110px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/09/The-Big-Fall-Marc-Smith.jpg" /><noscript><img width="110" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/09/The-Big-Fall-Marc-Smith.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Just in time to beat the pandemic blues, here&#039;s my new mystery/thriller, &quot;The Big Fall&quot; (Nick Seven Book 7). It&#039;s available on Amazon in Kindle AND paperback." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/The-Big-Fall-Marc-Smith.jpg 340w, https://www.bajanreporter.com/wp-content/uploads/2020/09/The-Big-Fall-Marc-Smith-200x300.jpg 200w" sizes="(max-width: 110px) 100vw, 110px" /></noscript>        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2020/09/help-brian-marshall-roots-rock-recovery-at-club-copacabana-3rd-oct-2020/" title="Help Brian Marshall: &#8220;Roots, Rock, Recovery&#8221; at Club Copacabana, 3rd Oct. 2020">
            Help Brian Marshall: &#8220;Roots, Rock, Recovery&#8221; at Club Copacabana, 3rd Oct. 2020            </a></div>
          <img width="165" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20165%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="Brian Marshall - laid low by Haemorrhagic Stroke" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158.jpg 720w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158-400x400.jpg 400w" data-lazy-sizes="(max-width: 165px) 100vw, 165px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158.jpg" /><noscript><img width="165" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Brian Marshall - laid low by Haemorrhagic Stroke" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158.jpg 720w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_160302_158-400x400.jpg 400w" sizes="(max-width: 165px) 100vw, 165px" /></noscript>        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2020/09/will-deputy-speaker-have-big-news-for-sunday-st-george-secondary-at-430pm/" title="Will Deputy Speaker have Big News for Sunday? St George Secondary at 4:30pm">
            Will Deputy Speaker have Big News for Sunday? St George Secondary at 4:30pm            </a></div>
          <img width="132" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20132%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20200919 095337 987" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987.jpg 808w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987-240x300.jpg 240w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987-768x960.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987-400x500.jpg 400w" data-lazy-sizes="(max-width: 132px) 100vw, 132px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987.jpg" /><noscript><img width="132" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20200919 095337 987" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987.jpg 808w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987-240x300.jpg 240w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987-768x960.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200919_095337_987-400x500.jpg 400w" sizes="(max-width: 132px) 100vw, 132px" /></noscript>        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2020/09/hands-to-share-hearts-to-care-zoomathon/" title="&#8220;Hands to Share, Hearts to Care&#8221; ZOOMATHON">
            &#8220;Hands to Share, Hearts to Care&#8221; ZOOMATHON            </a></div>
          <img width="165" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20165%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="Please help us to help others by sharing this with the link to your contacts at home and abroad." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-1024x1024.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-768x768.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-400x400.jpg 400w" data-lazy-sizes="(max-width: 165px) 100vw, 165px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425.jpg" /><noscript><img width="165" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Please help us to help others by sharing this with the link to your contacts at home and abroad." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-300x300.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-1024x1024.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-150x150.jpg 150w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-768x768.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/09/IMG_20200915_154130_425-400x400.jpg 400w" sizes="(max-width: 165px) 100vw, 165px" /></noscript>        </li>
                                <li>
          <div class="overlay"><a href="https://www.bajanreporter.com/2020/09/bring-on-the-heat-starts-september-7-2020/" title="Bring on the Heat! (Starts: September 7, 2020)">
            Bring on the Heat! (Starts: September 7, 2020)            </a></div>
          <img width="124" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20124%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="ILEE 252 BRING ON THE HEAT FRONT" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT-400x533.jpg 400w" data-lazy-sizes="(max-width: 124px) 100vw, 124px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT.jpg" /><noscript><img width="124" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="ILEE 252 BRING ON THE HEAT FRONT" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/08/ILEE-252-BRING-ON-THE-HEAT-FRONT-400x533.jpg 400w" sizes="(max-width: 124px) 100vw, 124px" /></noscript>        </li>
                      </ul>
    </div>
          </div>
  <!-- end #photo-gallery -->
  
    <div id="video-gallery" class="row">
    <div class="twelvecol">
      <h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2>
      <ul id="video-playlist" class="cf">
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/Ts2j8L7p2Fo" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/Ts2j8L7p2Fo" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/Ts2j8L7p2Fo" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">September 29th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/09/game-of-thrones-prequel-trailer-hbo-house-of-the-dragon/" title="Game of Thrones Prequel: Trailer (HBO) &#8211; House of the Dragon">Game of Thrones Prequel: Trailer (HBO) &#8211; House of the Dragon</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/jOjxizOFfN0" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/jOjxizOFfN0" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/jOjxizOFfN0" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">September 28th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/09/red-shoes-and-the-7-dwarfs-chloe-grace-moretz-sam-claflin-gina-gershon/" title="RED SHOES AND THE 7 DWARFS: Chloe Grace Moretz, Sam Claflin &#038; Gina Gershon">RED SHOES AND THE 7 DWARFS: Chloe Grace Moretz, Sam Claflin &#038; Gina Gershon</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/8ORA2lIbkjo" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/8ORA2lIbkjo" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/8ORA2lIbkjo" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">September 27th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/09/from-medieval-to-jurassic-tyrion-lannister-joins-the-croods-2/" title="From Medieval to Jurassic? &#8216;Tyrion Lannister&#8217; joins The Croods 2">From Medieval to Jurassic? &#8216;Tyrion Lannister&#8217; joins The Croods 2</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/6rvQUK62HFc" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/6rvQUK62HFc" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/6rvQUK62HFc" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">September 26th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/09/the-devil-all-the-time-donald-ray-pollock-bill-skarsgard-tom-holland-robert-pattinson/" title="THE DEVIL ALL THE TIME &#8211; Donald Ray Pollock, Bill Skarsgard, Tom Holland &#038; Robert Pattinson">THE DEVIL ALL THE TIME &#8211; Donald Ray Pollock, Bill Skarsgard, Tom Holland &#038; Robert Pattinson</a></div>
        </li>
                <li>
          <object style="height: 150px; width: 213px" data="https://youtube.com/v/EHRC4VkiQcI" type="application/x-shockwave-flash">
            <param name="movie" value="https://youtube.com/v/EHRC4VkiQcI" />
            <param name="allowFullScreen" value="true" />
            <param name="allowScriptAccess" value="always" />
            <embed src="https://youtube.com/v/EHRC4VkiQcI" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" />
          </object>
          <div class="video-details">September 23rd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/09/freaky-2020-kathryn-newton-vince-vaughn-horror-comedy/" title="FREAKY (2020) Kathryn Newton &#038; Vince Vaughn &#8211; Horror Comedy">FREAKY (2020) Kathryn Newton &#038; Vince Vaughn &#8211; Horror Comedy</a></div>
        </li>
              </ul>
    </div>
  </div>
  <!-- end #video-gallery -->
    </div>
<!-- end #multimedia -->

<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/comment-reply.min.js?ver=5.5.1' id='comment-reply-js'></script>
<script type='text/javascript' id='advanced-ads-layer-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"bajan-layer","placements":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.7.0' id='advanced-ads-layer-footer-js-js'></script>
<script type='text/javascript' id='advadsTrackingGAFront-js-extra'>
/* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/ga-tracking.js?ver=1.21.0' id='advadsTrackingGAFront-js'></script>
<script type='text/javascript' id='advadsTrackingHandle-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":"onrequest","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.21.0' id='advadsTrackingHandle-js'></script>
<script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<!--noptimize--><script>window.advads_has_ads = [["98786","ad",null],["98781","ad",null],["98782","ad",null],["98784","ad",null],["98783","ad",null],["98775","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><!--/noptimize--><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.bajanreporter.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = [];var advads_gatracking_uids = [];var advads_tracking_methods = [];var advads_tracking_parallel = [];var advads_tracking_linkbases = [];var advads_gatracking_allads = [];var advads_gatracking_anonym = true;</script><script type="text/javascript">
				if ( 'undefined' == typeof window.advadsGATracking ) window.advadsGATracking = {};
                				advadsGATracking.postContext = {"postID":100865,"postSlug":"second-half-income-tax-payment-due-by-month-end","cats":"breaking-news,business-new,featured"};
                			</script><footer class="container">
  <div class="row">
    <div id="col1" class="threecol">
      <div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li>
<li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li>
<li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li>
<li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li>
<li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li>
</ul></div>    </div>
    <div id="col2" class="threecol">
      <ul>
        <li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li>
        <li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li>
      </ul>
    </div>
    <div id="copyright" class="sixcol last">
    <div id="search" class="cf">
    	
        <form id="searchform" method="get" action="https://www.bajanreporter.com">
          <div>
          	<input type="submit" value="Go" />
             <input type="text" name="s" id="s" size="15" />
              <label for="s">Search:</label>
          </div>
            
         </form>
    </div>
    
    
   <p> &copy; 2020 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p>
      <p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div>
  </div>
</footer>
<!-- JS -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>
<script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.flexslider-min.js"></script>
<script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.cycle.all.latest.js"></script>

<!-- Place in the <head>, after the three links -->
<script>
  $(window).load(function() {
    $('.flexslider').flexslider();
	
	 $('#chyrons').cycle({
		fx: 'fade' // choose your transition type, ex: fade, scrollUp, shuffle, etc...
	});	
  });
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":962,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>


</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1601533697 -->