<!doctype html><html lang="en-US"><head><title>The Bajan Reporter | Solutions Barbados: &#8216;Shuffling&#8217; by Grenville Phillips II | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /><link data-minify="1" rel="stylesheet" type="text/css" media="screen" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/1140-e59178f18ac882b84700352b77d0138a.css" /><link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/bajanreporter-8413fae567e90b36a08b5002f507b398.css" type="text/css" /><link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/flexslider-ca447e174439696f96a4564d297f3a7a.css" type="text/css" />  <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/css3-mediaqueries.js"></script>  <script data-cfasync="false" data-pagespeed-no-defer>/* <![CDATA[ */ //<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]> /* ]]> */</script> <meta name="description" content="Prime Minister Mia Amor Mottley reshuffled her Cabinet. That is a good management practise. There are two appointments that are noteworthy. The first is William&#8230;" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/07/1-2020-07-22-10.48.19-1.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="768" /><meta property="og:image:alt" content="1 2020 07 22 10.48.19 1" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Solutions Barbados: &#8216;Shuffling&#8217; by Grenville Phillips II | The Bajan Reporter" /><meta property="og:description" content="Prime Minister Mia Amor Mottley reshuffled her Cabinet. That is a good management practise. There are two appointments that are noteworthy. The first is William Duguid. The decision to finally address&#8230;" /><meta property="og:url" content="https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="article:published_time" content="2020-07-26" /><meta property="article:modified_time" content="2020-07-25" /><meta property="og:updated_time" content="2020-07-25" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:title" content="Solutions Barbados: &#8216;Shuffling&#8217; by Grenville Phillips II | The Bajan Reporter" /><meta name="twitter:description" content="Prime Minister Mia Amor Mottley reshuffled her Cabinet. That is a good management practise. There are two appointments that are noteworthy. The first is William Duguid. The decision to finally address&#8230;" /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/07/1-2020-07-22-10.48.19-1.jpg" /><meta name="twitter:image:width" content="1024" /><meta name="twitter:image:height" content="768" /><meta name="twitter:image:alt" content="1 2020 07 22 10.48.19 1" /><link rel="canonical" href="https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/editorial/","name":"Editorial"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/","name":"Solutions Barbados: &#8216;Shuffling&#8217; by Grenville Phillips II"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/amp/" /><meta name="generator" content="AMP for WP 1.0.59"/><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//s7.addthis.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Solutions Barbados: &#8216;Shuffling&#8217; by Grenville Phillips II Comments Feed" href="https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link data-minify="1" rel='stylesheet' id='unslider-css-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/unslider-468a32c089a5781d815ec685581d6abf.css' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='slider-css-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/slider-3a20a17ea79aeacf589b560b9b8da379.css' type='text/css' media='all' /><link rel='stylesheet' id='responsive-lightbox-prettyphoto-css' href='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.2.3' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='smp_style-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/wp-super-popup/colorbox-e28dfbea77566dcf44298b6e5ae511f1.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/unslider.min.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.move.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.swipe.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.2.3'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.4.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"9b40590dd8"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.3'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.18.0'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_responsive = {"reload_on_resize":"0"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.9'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.8.2'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.colorbox-min.js?ver=1538352744'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.utils-min.js?ver=1572520480'></script> <script type='text/javascript'>/* <![CDATA[ */ var smp_vars = {"cookie_id":"1595716673451","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"640","popup_height":"480","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//wp-super-popup.js?ver=901869975'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.8.2'></script> <link rel='https://api.w.org/' href='https://www.bajanreporter.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F07%2Fsolutions-barbados-shuffling-by-grenville-phillips-ii%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F07%2Fsolutions-barbados-shuffling-by-grenville-phillips-ii%2F&#038;format=xml" /> <script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="bajan-layer-custom-css"></style> <script data-cfasync="false" data-pagespeed-no-defer>/* <![CDATA[ */ //<![CDATA[
	var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["editorial"],"pageAttributes":["administration","barbados","cabinet","governance","ministry"],"pagePostAuthor":"DevilsAdvocate"};
	dataLayer.push( dataLayer_content );//]]> /* ]]> */</script> <script data-cfasync="false">/* <![CDATA[ */ //<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');//]]> /* ]]> */</script>  <script type="text/javascript">var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};</script>  <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2020/07/tropical-storm-warning-discontinued-for-barbados/" title="Tropical Storm Warning Discontinued For Barbados">Tropical Storm Warning Discontinued For Barbados</a></li><li><a href="https://www.bajanreporter.com/2020/07/press-briefing-by-prime-minister-of-barbados-from-murphys-pasture-emmerton/" title="Press Briefing by Prime Minister of Barbados from Murphy’s Pasture, Emmerton">Press Briefing by Prime Minister of Barbados from Murphy’s Pasture, Emmerton</a></li><li><a href="https://www.bajanreporter.com/2020/07/urgent-attention-all-boat-owners-and-fishing-vessels/" title="URGENT ATTENTION, ALL BOAT OWNERS AND FISHING VESSELS">URGENT ATTENTION, ALL BOAT OWNERS AND FISHING VESSELS</a></li><li><a href="https://www.bajanreporter.com/2020/07/prime-minister-mottley-speaks-to-barbadians-22nd-july-2020-reshuffle/" title="Prime Minister Mottley speaks to Barbadians, 22nd July 2020 (RESHUFFLE)">Prime Minister Mottley speaks to Barbadians, 22nd July 2020 (RESHUFFLE)</a></li><li><a href="https://www.bajanreporter.com/2020/07/temporary-closure-of-berinda-cox-fish-market/" title="Temporary Closure of Berinda Cox Fish Market">Temporary Closure of Berinda Cox Fish Market</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Bajan Reporter" data-lazy-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" /><noscript><img src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></noscript></a> <span id="edition-date"><strong>Today</strong> Sunday, July 26th, 2020</span></div><div class="sevencol last"> <a data-bid="1" href="https://www.bajanreporter.com/linkout/98786" target="_blank"><img width="728" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" alt='ArtsEtc Barbados 2019 IndyList' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/ArtsEtc-Barbados-2019-IndyList.png" /><noscript><img width="728" height="90" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/ArtsEtc-Barbados-2019-IndyList.png' alt='ArtsEtc Barbados 2019 IndyList' /></noscript></a></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-100179" class="post-100179 post type-post status-publish format-standard has-post-thumbnail hentry category-editorial tag-administration tag-barbados tag-cabinet tag-governance tag-ministry"><h1>Solutions Barbados: &#8216;Shuffling&#8217; by Grenville Phillips II</h1><p class="post-meta">by DevilsAdvocate / July 26th, 2020</p><div class="addthis_toolbox addthis_default_style "> <a class="addthis_button_preferred_1"></a> <a class="addthis_button_preferred_2"></a> <a class="addthis_button_preferred_3"></a> <a class="addthis_button_preferred_4"></a> <a class="addthis_button_compact"></a> <a class="addthis_counter addthis_bubble_style"></a></div> <script src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <p>Prime Minister <strong><a href="https://bit.ly/Baj_147" target="_blank" rel="noopener noreferrer">Mia Amor Mottley</a></strong> reshuffled her Cabinet. That is a good management practise.</p><p>There are two appointments that are noteworthy. The first is <strong>William Duguid</strong>. The decision to finally address the traffic bottleneck at the Garfield Sobers Roundabout, is noteworthy. The solution was simple and effective, and it appears to be being implemented well.</p><p>We trust that the Minister will continue that <strong>ISO 9001</strong> management approach of identifying the main problems, and developing and implementing the most effective and economical solutions.</p><p>The next appointment is <strong><a href="https://bit.ly/Baj_147" target="_blank" rel="noopener noreferrer">Lisa Cummins</a></strong>. Her approach to her assignment at the Port was excellent. She identified the obvious problem at the Port as poor-management, and set about to formally implement the international management standard, ISO 9001. The only thing that can happen to the Port during that process, is that the Port would be better managed.</p><p>Because she approached her assignment with such basic common-sense, she deserved to have her pick of Ministerial portfolios, to show the others how to properly manage a public service. We trust that she will bring the same management standard to her new responsibilities.</p><div id="attachment_100181" style="width: 310px" class="wp-caption aligncenter"><a href="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19.jpg" data-rel="lightbox-gallery-lvMt3JwF" data-rl_title="" data-rl_caption="" title=""><img aria-describedby="caption-attachment-100181" class="wp-image-100181 size-medium" title="2020 03 12 21.36.19" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20225'%3E%3C/svg%3E" alt="Grenville Phillips II is a Chartered Structural Engineer and President of Solutions Barbados. He can be reached at NextParty246@gmail.com" width="300" height="225" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-400x300.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19.jpg 1024w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-300x225.jpg" /><noscript><img aria-describedby="caption-attachment-100181" class="wp-image-100181 size-medium" title="2020 03 12 21.36.19" src="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-300x225.jpg" alt="Grenville Phillips II is a Chartered Structural Engineer and President of Solutions Barbados. He can be reached at NextParty246@gmail.com" width="300" height="225" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19-400x300.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-03-12-21.36.19.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><p id="caption-attachment-100181" class="wp-caption-text">Grenville Phillips II is a Chartered Structural Engineer and President of Solutions Barbados. He can be reached at <i>NextParty246@gmail.com</i></p></div><p>To the other Ministers, please follow the examples of Duguid and Cummins. Whether you implement <strong>ISO 9001</strong> formally, as Lisa started to do, or informally, as William appeared to do, you will do things that can only benefit the residents of Barbados. Using your normal management methods has only caused us harm.</p></article><div id="article-ad"><div class="ads468x60"> <a data-bid="1" href="https://www.bajanreporter.com/linkout/98781" target="_blank"><img width="468" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20468%2080'%3E%3C/svg%3E" alt='Follow on Instagram' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" /><noscript><img width="468" height="80" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg' alt='Follow on Instagram' /></noscript></a></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p> <input type="text" name="author" id="author" value="" size="22" tabindex="2" /> <label for="author">Name <em>(required)</em></label></p><p> <input type="text" name="email" id="email" value="" size="22" tabindex="3" /> <label for="email">Email <em>(required, but never shared)</em></label></p><p> <input type="text" name="url" id="url" value="" size="22" tabindex="4" /> <label title="Your website address" for="url">Web</label></p><p> <input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" /> or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2020/07/solutions-barbados-shuffling-by-grenville-phillips-ii/trackback/">trackback</a>.</p> <input type='hidden' name='comment_post_ID' value='100179' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9b15425065" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="93"/></p></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2020/07/arts-drive-needed-for-bermuda/" rel="prev">Arts drive needed for Bermuda</a></span></li><li><span class="next">Next: </span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98782" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='My Bdos Lottery Top Up 20201' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/My-Bdos-Lottery-Top-Up-20201.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/My-Bdos-Lottery-Top-Up-20201.jpg' alt='My Bdos Lottery Top Up 20201' /></noscript></a></li><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='IMG 20200702 WA0005' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/IMG-20200702-WA0005.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/IMG-20200702-WA0005.jpg' alt='IMG 20200702 WA0005' /></noscript></a></li><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98783" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='aviary image 1595706854587' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/aviary-image-1595706854587.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/aviary-image-1595706854587.jpg' alt='aviary image 1595706854587' /></noscript></a></li></ul><ul class="ad ads120x600 cf"><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775"><img width="120" height="600" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20600'%3E%3C/svg%3E" alt='If you saw this then you came to the best place to get seen 1' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2018/12/If-you-saw-this-then-you-came-to-the-best-place-to-get-seen-1.png" /><noscript><img width="120" height="600" src='https://www.bajanreporter.com/wp-content/uploads/2018/12/If-you-saw-this-then-you-came-to-the-best-place-to-get-seen-1.png' alt='If you saw this then you came to the best place to get seen 1' /></noscript></a></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/07/tourism-to-be-the-focus-of-the-july-caribbean-economic-forum/" title="Tourism to be the Focus of the July Caribbean Economic Forum"> Tourism to be the Focus of the July Caribbean Economic Forum </a></div> <img width="211" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20211%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="That panel includes the Honourable Edmund Bartlett, Jamaica&#039;s Minister of Tourism; Patricia Affonso-Dass, President of the Caribbean Hotel and Tourism Association; Sue Springer, Director of Corporate and Government Relations at The Caribbean Council in the UK; and Professor Clive Landis, Chair of the University of the West Indies&#039; COVID-19 task force. Michelle Paige, President of the Florida-Caribbean Cruise Association and Geoffrey Roach, Chairman of the Barbados Hotel and Tourism Association will also weigh in on the discussion." data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/07/1-IMG-20200714-WA0012-576x450.jpg" /><noscript><img width="211" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/07/1-IMG-20200714-WA0012-576x450.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="That panel includes the Honourable Edmund Bartlett, Jamaica&#039;s Minister of Tourism; Patricia Affonso-Dass, President of the Caribbean Hotel and Tourism Association; Sue Springer, Director of Corporate and Government Relations at The Caribbean Council in the UK; and Professor Clive Landis, Chair of the University of the West Indies&#039; COVID-19 task force. Michelle Paige, President of the Florida-Caribbean Cruise Association and Geoffrey Roach, Chairman of the Barbados Hotel and Tourism Association will also weigh in on the discussion." /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/07/collins-limited-donates-to-the-royal-barbados-police-force/" title="Collins Limited donates to the Royal Barbados Police Force"> Collins Limited donates to the Royal Barbados Police Force </a></div> <img width="203" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20203%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="From left: Sgt. David Alleyne, Barry Muster Sales Supervisor at Collins Limited, Acting Inspector Rodney Inniss Police Public Relations Officer, and Michael King Executive Assistant at Collins Limited during the presentation." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1.jpg 694w, https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1-300x244.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1-400x326.jpg 400w" data-lazy-sizes="(max-width: 203px) 100vw, 203px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1.jpg" /><noscript><img width="203" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="From left: Sgt. David Alleyne, Barry Muster Sales Supervisor at Collins Limited, Acting Inspector Rodney Inniss Police Public Relations Officer, and Michael King Executive Assistant at Collins Limited during the presentation." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1.jpg 694w, https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1-300x244.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/07/Barry-Muster-Collins-1-400x326.jpg 400w" sizes="(max-width: 203px) 100vw, 203px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/07/st-george-pic-donates-tablet-to-the-lodge-school/" title="St. George PIC donates tablet to The Lodge School"> St. George PIC donates tablet to The Lodge School </a></div> <img width="105" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20105%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="St. George Parish Independence Ambassador Leah Bascombe, at left, giving the tablet to the Acting Principal of The Lodge School, Robin Douglas" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final.jpg 653w, https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final-191x300.jpg 191w, https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final-400x627.jpg 400w" data-lazy-sizes="(max-width: 105px) 100vw, 105px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final.jpg" /><noscript><img width="105" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="St. George Parish Independence Ambassador Leah Bascombe, at left, giving the tablet to the Acting Principal of The Lodge School, Robin Douglas" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final.jpg 653w, https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final-191x300.jpg 191w, https://www.bajanreporter.com/wp-content/uploads/2020/07/St.-George-PIC-Tablet-Donation-final-400x627.jpg 400w" sizes="(max-width: 105px) 100vw, 105px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/07/barvens-farmers-market-sat-4th-july-2020-happy-bday-chorus/" title="BARVEN&#8217;s Farmers&#8217; Market (Sat 4th July 2020) Happy B&#8217;day Chorus"> BARVEN&#8217;s Farmers&#8217; Market (Sat 4th July 2020) Happy B&#8217;day Chorus </a></div> <img width="213" height="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20160'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="(CLICK FOR BIGGER) Jr Finance Minister Marsha Caddle (2nd from Left) plus Maritime Affairs &amp; Blue Economy Minister Kirk Humphrey lead a lusty chorus of Happy Birthday for President of the Barbados&#039; Vendors and Entrepreneurs&#039; Association (BARVEN) Alistair Alexander" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04-400x300.jpg 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04.jpg" /><noscript><img width="213" height="160" src="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="(CLICK FOR BIGGER) Jr Finance Minister Marsha Caddle (2nd from Left) plus Maritime Affairs &amp; Blue Economy Minister Kirk Humphrey lead a lusty chorus of Happy Birthday for President of the Barbados&#039; Vendors and Entrepreneurs&#039; Association (BARVEN) Alistair Alexander" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-11.23.04-400x300.jpg 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/07/barvens-farmers-market-sat-4th-july-2020-talented-carving/" title="BARVEN&#8217;s Farmers&#8217; Market (Sat 4th July 2020) Talented Carving"> BARVEN&#8217;s Farmers&#8217; Market (Sat 4th July 2020) Talented Carving </a></div> <img width="124" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20124%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="(CLICK FOR BIGGER) Watermelon skin peeled to reveal the face of Barbados&#039; PM! Amazing skills..." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30-400x533.jpg 400w" data-lazy-sizes="(max-width: 124px) 100vw, 124px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30.jpg" /><noscript><img width="124" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="(CLICK FOR BIGGER) Watermelon skin peeled to reveal the face of Barbados&#039; PM! Amazing skills..." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/07/2020-07-04-10.09.30-400x533.jpg 400w" sizes="(max-width: 124px) 100vw, 124px" /></noscript></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/I_QH3SSwEYE" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/I_QH3SSwEYE" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/I_QH3SSwEYE" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">July 24th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/07/press-briefing-by-prime-minister-of-barbados-from-murphys-pasture-emmerton/" title="Press Briefing by Prime Minister of Barbados from Murphy’s Pasture, Emmerton">Press Briefing by Prime Minister of Barbados from Murphy’s Pasture, Emmerton</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/X5HQ6X6ez_I" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/X5HQ6X6ez_I" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/X5HQ6X6ez_I" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">July 23rd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/07/prime-minister-mottley-speaks-to-barbadians-22nd-july-2020-reshuffle/" title="Prime Minister Mottley speaks to Barbadians, 22nd July 2020 (RESHUFFLE)">Prime Minister Mottley speaks to Barbadians, 22nd July 2020 (RESHUFFLE)</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/RBcpnxa2KyA" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/RBcpnxa2KyA" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/RBcpnxa2KyA" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">July 16th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/07/pm-mottleys-thank-you-message-to-robyn-rihanna-fenty/" title="PM Mottley&#8217;s Thank You Message to Robyn Rihanna Fenty">PM Mottley&#8217;s Thank You Message to Robyn Rihanna Fenty</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/kahacldmc5U" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/kahacldmc5U" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/kahacldmc5U" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">July 2nd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/07/sir-everton-was-the-last-remaining-member-of-the-world-famous-three-ws/" title="Sir Everton was the last remaining member of the world-famous Three Ws">Sir Everton was the last remaining member of the world-famous Three Ws</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/ADT51R1x7QA" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/ADT51R1x7QA" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/ADT51R1x7QA" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">July 2nd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/07/patrick-hoyos-has-left-a-solid-legacy-for-those-who-remain-practitioners-of-the-fourth-estate/" title="Patrick Hoyos has left a solid legacy for those who remain practitioners of the Fourth Estate">Patrick Hoyos has left a solid legacy for those who remain practitioners of the Fourth Estate</a></div></li></ul></div></div></div>  <script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_layer_settings = {"layer_class":"bajan-layer"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.6.6'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"bajan-sticky"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1.7.11'></script> <script type='text/javascript'>/* <![CDATA[ */ var advadsTracking = {"ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":null,"blogId":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.20.3'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script> <script async="async" type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script> <script>window.advads_has_ads = [["98786","ad",null],["98781","ad",null],["98782","ad",null],["98784","ad",null],["98783","ad",null],["98775","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');} });</script><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.bajanreporter.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = [];var advads_gatracking_uids = [];var advads_tracking_methods = [];var advads_tracking_parallel = [];var advads_tracking_linkbases = [];var advads_gatracking_allads = [];var advads_gatracking_anonym = true;</script><footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div> <input type="submit" value="Go" /> <input type="text" name="s" id="s" size="15" /> <label for="s">Search:</label></div></form></div><p> &copy; 2020 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>  <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script> <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.flexslider-min.js"></script> <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.cycle.all.latest.js"></script>  <script>$(window).load(function() {
    $('.flexslider').flexslider();
	
	 $('#chyrons').cycle({
		fx: 'fade' // choose your transition type, ex: fade, scrollUp, shuffle, etc...
	});	
  });</script> <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":470,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1595756534 -->