<!doctype html><html lang="en-US"><head><title>The Bajan Reporter | Think Like a Dog &#x2d; Josh Duhamel, Megan Fox &#038; Gabriel Bateman | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script> <!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]--><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /><link data-minify="1" rel="stylesheet" type="text/css" media="screen" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/1140-e59178f18ac882b84700352b77d0138a.css" /><link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/bajanreporter-8413fae567e90b36a08b5002f507b398.css" type="text/css" /><link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/flexslider-ca447e174439696f96a4564d297f3a7a.css" type="text/css" />  <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/css3-mediaqueries.js"></script>  <script data-cfasync="false" data-pagespeed-no-defer>/* <![CDATA[ */ //<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]> /* ]]> */</script> <meta name="description" content="After an experiment goes disastrously awry, a twelve-year-old technological whizkid discovers that he&#8217;s developed an unexpected telepathic connection with his&#8230;" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster.jpg" /><meta property="og:image:width" content="800" /><meta property="og:image:height" content="1067" /><meta property="og:image:alt" content="Home Release Date: June 9, 2020 Starring: Josh Duhamel, Megan Fox, Gabriel Bateman Directed By: Gil Junger" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Think Like a Dog &#x2d; Josh Duhamel, Megan Fox &#038; Gabriel Bateman | The Bajan Reporter" /><meta property="og:description" content="After an experiment goes disastrously awry, a twelve-year-old technological whizkid discovers that he&#8217;s developed an unexpected telepathic connection with his dog." /><meta property="og:url" content="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="article:published_time" content="2020-06-03" /><meta property="article:modified_time" content="2020-06-01" /><meta property="og:updated_time" content="2020-06-01" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:title" content="Think Like a Dog &#x2d; Josh Duhamel, Megan Fox &#038; Gabriel Bateman | The Bajan Reporter" /><meta name="twitter:description" content="After an experiment goes disastrously awry, a twelve-year-old technological whizkid discovers that he&#8217;s developed an unexpected telepathic connection with his dog." /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster.jpg" /><meta name="twitter:image:width" content="800" /><meta name="twitter:image:height" content="1067" /><meta name="twitter:image:alt" content="Home Release Date: June 9, 2020 Starring: Josh Duhamel, Megan Fox, Gabriel Bateman Directed By: Gil Junger" /><link rel="canonical" href="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/gossip/","name":"Gossip"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/gossip/oddity-gossip/","name":"Oddity"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/","name":"Think Like a Dog &#8211; Josh Duhamel, Megan Fox &#038; Gabriel Bateman"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/amp/" /><meta name="generator" content="AMP for WP 1.0.52"/><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//s7.addthis.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; Think Like a Dog &#8211; Josh Duhamel, Megan Fox &#038; Gabriel Bateman Comments Feed" href="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link data-minify="1" rel='stylesheet' id='unslider-css-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/unslider-468a32c089a5781d815ec685581d6abf.css' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='slider-css-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/slider-3a20a17ea79aeacf589b560b9b8da379.css' type='text/css' media='all' /><link rel='stylesheet' id='responsive-lightbox-prettyphoto-css' href='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.2.3' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='smp_style-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/wp-super-popup/colorbox-0a28ad2b9db605539f65e8a8a1d7f554.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/unslider.min.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.move.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.swipe.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.2.3'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.4.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"0bb5c97817"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.3'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.17.12'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_responsive = {"reload_on_resize":"0"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.9'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.7.1'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.colorbox-min.js?ver=932993562'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.utils-min.js?ver=99390033'></script> <script type='text/javascript'>/* <![CDATA[ */ var smp_vars = {"cookie_id":"1587766308706","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"640","popup_height":"480","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//wp-super-popup.js?ver=1560738697'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.7.1'></script> <link rel='https://api.w.org/' href='https://www.bajanreporter.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F06%2Fthink-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F06%2Fthink-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman%2F&#038;format=xml" /> <script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="bajan-layer-custom-css"></style> <script data-cfasync="false" data-pagespeed-no-defer>/* <![CDATA[ */ //<![CDATA[
	var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["oddity-gossip","videos"],"pageAttributes":["b-movie","children","comedy","dogs","science-fiction","telepathy","usa"],"pagePostAuthor":"Bajan Reporter"};
	dataLayer.push( dataLayer_content );//]]> /* ]]> */</script> <script data-cfasync="false">/* <![CDATA[ */ //<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');//]]> /* ]]> */</script>  <script type="text/javascript">var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};</script> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2020/06/prime-minister-to-participate-in-meetings-on-b-o-s-s/" title="Prime Minister To Participate In Meetings On B.O.S.S.">Prime Minister To Participate In Meetings On B.O.S.S.</a></li><li><a href="https://www.bajanreporter.com/2020/05/tablets-for-our-children-initiative-donates-more-tablets-to-bajan-children/" title="&#8216;Tablets For Our Children&#8217; initiative donates more tablets to Bajan children">&#8216;Tablets For Our Children&#8217; initiative donates more tablets to Bajan children</a></li><li><a href="https://www.bajanreporter.com/2020/05/skn-prime-minister-appoints-brother-in-law-jermaine-lake-and-ex-campaign-manager-patrick-welcome-as-returning-officers/" title="SKN Prime Minister appoints brother in law Jermaine Lake and ex campaign manager Patrick Welcome as Returning Officers">SKN Prime Minister appoints brother in law Jermaine Lake and ex campaign manager Patrick Welcome as Returning Officers</a></li><li><a href="https://www.bajanreporter.com/2020/05/teenager-from-st-thomas-missing-since-friday-15th-may/" title="TEENAGER FROM ST THOMAS MISSING SINCE FRIDAY 15th May">TEENAGER FROM ST THOMAS MISSING SINCE FRIDAY 15th May</a></li><li><a href="https://www.bajanreporter.com/2020/05/16-year-old-guyanese-missing-since-tuesday/" title="16 YEAR OLD GUYANESE MISSING SINCE TUESDAY">16 YEAR OLD GUYANESE MISSING SINCE TUESDAY</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Bajan Reporter" data-lazy-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" /><noscript><img src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></noscript></a> <span id="edition-date"><strong>Today</strong> Wednesday, June 3rd, 2020</span></div><div class="sevencol last"> <a data-bid="1" href="https://www.bajanreporter.com/linkout/98786" target="_blank"><img width="728" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" alt='ArtsEtc Barbados 2019 IndyList' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/ArtsEtc-Barbados-2019-IndyList.png" /><noscript><img width="728" height="90" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/ArtsEtc-Barbados-2019-IndyList.png' alt='ArtsEtc Barbados 2019 IndyList' /></noscript></a></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-99836" class="post-99836 post type-post status-publish format-standard has-post-thumbnail hentry category-oddity-gossip category-videos tag-b-movie tag-children tag-comedy tag-dogs tag-science-fiction tag-telepathy tag-usa"><h1>Think Like a Dog &#8211; Josh Duhamel, Megan Fox &#038; Gabriel Bateman</h1><p class="post-meta">by Bajan Reporter / June 3rd, 2020</p><div class="addthis_toolbox addthis_default_style "> <a class="addthis_button_preferred_1"></a> <a class="addthis_button_preferred_2"></a> <a class="addthis_button_preferred_3"></a> <a class="addthis_button_preferred_4"></a> <a class="addthis_button_compact"></a> <a class="addthis_counter addthis_bubble_style"></a></div> <script src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <div id="attachment_99837" style="width: 235px" class="wp-caption aligncenter"><a href="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster.jpg" data-rel="lightbox-gallery-1BUdReqN" data-rl_title="" data-rl_caption="" title=""><img aria-describedby="caption-attachment-99837" class="size-medium wp-image-99837" title="Think Like A Dog Movie Poster" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20225%20300'%3E%3C/svg%3E" alt="Home Release Date: June 9, 2020 Starring: Josh Duhamel, Megan Fox, Gabriel Bateman Directed By: Gil Junger" width="225" height="300" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-768x1024.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-400x534.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster.jpg 800w" data-lazy-sizes="(max-width: 225px) 100vw, 225px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-225x300.jpg" /><noscript><img aria-describedby="caption-attachment-99837" class="size-medium wp-image-99837" title="Think Like A Dog Movie Poster" src="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-225x300.jpg" alt="Home Release Date: June 9, 2020 Starring: Josh Duhamel, Megan Fox, Gabriel Bateman Directed By: Gil Junger" width="225" height="300" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-768x1024.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster-400x534.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2020/05/Think-Like-A-Dog-Movie-Poster.jpg 800w" sizes="(max-width: 225px) 100vw, 225px" /></noscript></a><p id="caption-attachment-99837" class="wp-caption-text">Home Release Date: June 9, 2020<br />Starring: Josh Duhamel, Megan Fox, Gabriel Bateman<br />Directed By: Gil Junger</p></div><p>After an experiment goes disastrously awry, a <em><a href="https://youtu.be/V4h7R4GaPbk" data-rel="lightbox-video-0" target="_blank" rel="noopener noreferrer">twelve-year-old technological whizkid</a></em> discovers that he&#8217;s developed an unexpected telepathic connection with his dog.</p><p><iframe title="Think Like a Dog Trailer #1 (2020) | Movieclips Trailers" width="500" height="281" src="https://www.youtube.com/embed/V4h7R4GaPbk?feature=oembed&#038;enablejsapi=1&#038;origin=https://www.bajanreporter.com" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p></article><div id="article-ad"><div class="ads468x60"> <a data-bid="1" href="https://www.bajanreporter.com/linkout/98781" target="_blank"><img width="468" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20468%2080'%3E%3C/svg%3E" alt='Follow on Instagram' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg" /><noscript><img width="468" height="80" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/Follow-on-Instagram.jpg' alt='Follow on Instagram' /></noscript></a></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p> <input type="text" name="author" id="author" value="" size="22" tabindex="2" /> <label for="author">Name <em>(required)</em></label></p><p> <input type="text" name="email" id="email" value="" size="22" tabindex="3" /> <label for="email">Email <em>(required, but never shared)</em></label></p><p> <input type="text" name="url" id="url" value="" size="22" tabindex="4" /> <label title="Your website address" for="url">Web</label></p><p> <input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" /> or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/trackback/">trackback</a>.</p> <input type='hidden' name='comment_post_ID' value='99836' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c67942264c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="152"/></p></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2020/06/i-am-vengeance-2-retaliation-2020-stu-bennett-and-vinnie-jones/" rel="prev">I AM VENGEANCE 2: Retaliation (2020) Stu Bennett and Vinnie Jones</a></span></li><li><span class="next">Next: </span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98782" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='My Bdos Lottery Top Up 20201' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/My-Bdos-Lottery-Top-Up-20201.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/My-Bdos-Lottery-Top-Up-20201.jpg' alt='My Bdos Lottery Top Up 20201' /></noscript></a></li><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='BGIS 336x280' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2018/10/BGIS_336x280.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2018/10/BGIS_336x280.jpg' alt='BGIS 336x280' /></noscript></a></li><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98783" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='MMLakhi FINAL' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/MMLakhi-FINAL.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/MMLakhi-FINAL.jpg' alt='MMLakhi FINAL' /></noscript></a></li></ul><ul class="ad ads120x600 cf"><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775"><img width="120" height="600" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20600'%3E%3C/svg%3E" alt='If you saw this then you came to the best place to get seen 1' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2018/12/If-you-saw-this-then-you-came-to-the-best-place-to-get-seen-1.png" /><noscript><img width="120" height="600" src='https://www.bajanreporter.com/wp-content/uploads/2018/12/If-you-saw-this-then-you-came-to-the-best-place-to-get-seen-1.png' alt='If you saw this then you came to the best place to get seen 1' /></noscript></a></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/05/lds-charities-donate-to-the-barbados-salvation-army-hostel-and-feeding-centre/" title="LDS Charities donate to the Barbados Salvation Army Hostel and Feeding Centre"> LDS Charities donate to the Barbados Salvation Army Hostel and Feeding Centre </a></div> <img width="213" height="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20160'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="LDS Food Salvation Army 02" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02-400x300.jpg 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02.jpg" /><noscript><img width="213" height="160" src="https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="LDS Food Salvation Army 02" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/LDS-Food-Salvation-Army-02-400x300.jpg 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/05/barbados-covid19-update-two-women-test-positive/" title="BARBADOS&#8217; COVID19 UPDATE &#8211; TWO WOMEN TEST POSITIVE"> BARBADOS&#8217; COVID19 UPDATE &#8211; TWO WOMEN TEST POSITIVE </a></div> <img width="213" height="120" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20120'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="The Ministry of Health and Wellness said they completed the testing of 30 people whose names were supplied by the church as members. All of the others tested negative. It revealed that while the church had originally supplied a list of 28 members, that list was recently upgraded to add two others." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020.png 1280w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-300x169.png 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-1024x576.png 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-768x432.png 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-400x225.png 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020.png" /><noscript><img width="213" height="120" src="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020.png" class="attachment-213x165 size-213x165 wp-post-image" alt="The Ministry of Health and Wellness said they completed the testing of 30 people whose names were supplied by the church as members. All of the others tested negative. It revealed that while the church had originally supplied a list of 28 members, that list was recently upgraded to add two others." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020.png 1280w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-300x169.png 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-1024x576.png 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-768x432.png 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-23-2020-400x225.png 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/05/barbados-covid19-update-no-new-cases/" title="BARBADOS&#8217; COVID19 UPDATE – NO NEW CASES"> BARBADOS&#8217; COVID19 UPDATE – NO NEW CASES </a></div> <img width="213" height="120" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20120'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="The number of persons infected since March 16 remains at 90 – 47 females and 43 males. Seventy people have recovered and 13 remain in isolation." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020.png 1280w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-300x169.png 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-1024x576.png 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-768x432.png 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-400x225.png 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020.png" /><noscript><img width="213" height="120" src="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020.png" class="attachment-213x165 size-213x165 wp-post-image" alt="The number of persons infected since March 16 remains at 90 – 47 females and 43 males. Seventy people have recovered and 13 remain in isolation." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020.png 1280w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-300x169.png 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-1024x576.png 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-768x432.png 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/MHW-Barbados-COVID-19-Dashboard-May-21-2020-400x225.png 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/05/barbados-covid-19-update-confirmed-cases-now-86/" title="BARBADOS&#8217; COVID-19 UPDATE: CONFIRMED CASES NOW 86"> BARBADOS&#8217; COVID-19 UPDATE: CONFIRMED CASES NOW 86 </a></div> <img width="213" height="120" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20120'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="His was the only positive test out of 132 carried out by the Best-dos Santos Public Health Laboratory yesterday. Two people will be released from isolation today." data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019.jpg 480w, https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019-300x169.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019-400x225.jpg 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019.jpg" /><noscript><img width="213" height="120" src="https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="His was the only positive test out of 132 carried out by the Best-dos Santos Public Health Laboratory yesterday. Two people will be released from isolation today." srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019.jpg 480w, https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019-300x169.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/IMG-20200516-WA0019-400x225.jpg 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/05/barbadian-parents-in-need-of-reasonable-alternative-to-expensive-laptops-for-online-classes-head-for-gittens-rd-on-govt-hill/" title="Barbadian Parents in need of Reasonable Alternative to Expensive Laptops for Online Classes, Head for Gittens Rd on Gov&#8217;t Hill!"> Barbadian Parents in need of Reasonable Alternative to Expensive Laptops for Online Classes, Head for Gittens Rd on Gov&#8217;t Hill! </a></div> <img width="213" height="160" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20160'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="Head to Gittens Rd now, call (246) 286-2533 at Farah Trading/Mobile Express, not many left, so hurry!" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45-400x300.jpg 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45.jpg" /><noscript><img width="213" height="160" src="https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="Head to Gittens Rd now, call (246) 286-2533 at Farah Trading/Mobile Express, not many left, so hurry!" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45-300x225.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45-768x576.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/05/2020-05-10-10.59.45-400x300.jpg 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li> <object style="height: 150px; width: 213px" data="https://youtube,com/v/V4h7R4GaPbk" type="application/x-shockwave-flash"><param name="movie" value="https://youtube,com/v/V4h7R4GaPbk" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube,com/v/V4h7R4GaPbk" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">June 3rd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/06/think-like-a-dog-josh-duhamel-megan-fox-gabriel-bateman/" title="Think Like a Dog &#8211; Josh Duhamel, Megan Fox &#038; Gabriel Bateman">Think Like a Dog &#8211; Josh Duhamel, Megan Fox &#038; Gabriel Bateman</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/hWDWdUe2Dnk" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/hWDWdUe2Dnk" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/hWDWdUe2Dnk" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">June 2nd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/06/i-am-vengeance-2-retaliation-2020-stu-bennett-and-vinnie-jones/" title="I AM VENGEANCE 2: Retaliation (2020) Stu Bennett and Vinnie Jones">I AM VENGEANCE 2: Retaliation (2020) Stu Bennett and Vinnie Jones</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtu.be/0TuwZAs-0C8" type="application/x-shockwave-flash"><param name="movie" value="https://youtu.be/0TuwZAs-0C8" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtu.be/0TuwZAs-0C8" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">June 1st, 2020 <br /> <a href="https://www.bajanreporter.com/2020/06/prime-minister-to-participate-in-meetings-on-b-o-s-s/" title="Prime Minister To Participate In Meetings On B.O.S.S.">Prime Minister To Participate In Meetings On B.O.S.S.</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/axE2Odpjjio" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/axE2Odpjjio" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/axE2Odpjjio" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">June 1st, 2020 <br /> <a href="https://www.bajanreporter.com/2020/06/gundala-superhero-movie-2020-what-if-thor-flash-merged/" title="GUNDALA (Superhero Movie, 2020) What if Thor &#038; Flash merged?">GUNDALA (Superhero Movie, 2020) What if Thor &#038; Flash merged?</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/RrQdzVhk1bo" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/RrQdzVhk1bo" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/RrQdzVhk1bo" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">May 29th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/05/pm-mottley-criteria-must-reflect-countries-needs/" title="PM Mottley: Criteria Must Reflect Countries&#8217; Needs">PM Mottley: Criteria Must Reflect Countries&#8217; Needs</a></div></li></ul></div></div></div>  <script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_layer_settings = {"layer_class":"bajan-layer"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.6.5'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"bajan-sticky"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1.7.10'></script> <script type='text/javascript'>/* <![CDATA[ */ var advadsTracking = {"ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":null,"blogId":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.20.2'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script> <script async="async" type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script> <script>window.advads_has_ads = [["98786","ad",null],["98781","ad",null],["98782","ad",null],["98784","ad",null],["98783","ad",null],["98775","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');} });</script><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.bajanreporter.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script><script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = [];var advads_gatracking_uids = [];var advads_tracking_methods = [];var advads_tracking_parallel = [];var advads_tracking_linkbases = [];var advads_gatracking_allads = [];var advads_gatracking_anonym = true;</script><footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div> <input type="submit" value="Go" /> <input type="text" name="s" id="s" size="15" /> <label for="s">Search:</label></div></form></div><p> &copy; 2020 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>  <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script> <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.flexslider-min.js"></script> <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.cycle.all.latest.js"></script>  <script>$(window).load(function() {
    $('.flexslider').flexslider();
	
	 $('#chyrons').cycle({
		fx: 'fade' // choose your transition type, ex: fade, scrollUp, shuffle, etc...
	});	
  });</script> <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":384,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1591177738 -->