<!doctype html><html lang="en-US"><head><title>The Bajan Reporter | DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE | The Bajan Reporter</title><meta charset="UTF-8" /><script type="text/javascript">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</script> <!--[if lte IE 9]><link rel="stylesheet" href="https://www.bajanreporter.com/wp-content/themes/bajanreporter/css/ie.css" type="text/css" media="screen" /><![endif]--><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/feed/" title="The Bajan Reporter latest posts" /><link rel="alternate" type="application/rss+xml" href="https://www.bajanreporter.com/comments/feed/" title="The Bajan Reporter latest comments" /><link rel="pingback" href="https://www.bajanreporter.com/xmlrpc.php" /><link data-minify="1" rel="stylesheet" type="text/css" media="screen" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/1140-b306a7739723e10115e3ace10b31b597.css" /><link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/bajanreporter-c866dd893573c37542b73f90e229f539.css" type="text/css" /><link data-minify="1" rel="stylesheet" href="https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/themes/bajanreporter/css/flexslider-0da6ff5c288d07108d68dda66b52e5f4.css" type="text/css" />  <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/css3-mediaqueries.js"></script>  <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">/* <![CDATA[ */ //<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]> /* ]]> */</script> <meta name="description" content="Police from District C are now investigating a suspected case of suicide at Banyan Circle, Gooseberry Drive, Ruby St. Philip – officers got a report around 6:" /><meta property="og:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005.jpg" /><meta property="og:image:width" content="768" /><meta property="og:image:height" content="1024" /><meta property="og:image:alt" content="IMG 20200106 WA0005" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE | The Bajan Reporter" /><meta property="og:description" content="Police from District C are now investigating a suspected case of suicide at Banyan Circle, Gooseberry Drive, Ruby St. Philip – officers got a report around 6:20 am of a man hanging by the neck with a&#8230;" /><meta property="og:url" content="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/" /><meta property="og:site_name" content="The Bajan Reporter" /><meta property="article:published_time" content="2020-01-06" /><meta property="article:modified_time" content="2020-01-07" /><meta property="og:updated_time" content="2020-01-07" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@bajanreporter" /><meta name="twitter:title" content="DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE | The Bajan Reporter" /><meta name="twitter:description" content="Police from District C are now investigating a suspected case of suicide at Banyan Circle, Gooseberry Drive, Ruby St. Philip – officers got a report around 6:20 am of a man hanging by the neck with a&#8230;" /><meta name="twitter:image" content="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005.jpg" /><meta name="twitter:image:width" content="768" /><meta name="twitter:image:height" content="1024" /><meta name="twitter:image:alt" content="IMG 20200106 WA0005" /><link rel="canonical" href="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/" /> <script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.bajanreporter.com/","name":"The Bajan Reporter"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.bajanreporter.com/category/new/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.bajanreporter.com/category/new/crime-new/","name":"Crime"}},{"@type":"ListItem","position":4,"item":{"@id":"https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/","name":"DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE"}}]}</script> <link rel="amphtml" href="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/amp/" /><meta name="generator" content="AMP for WP 1.0.8"/><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//s7.addthis.com' /><link rel="alternate" type="application/rss+xml" title="The Bajan Reporter &raquo; DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE Comments Feed" href="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bajanreporter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script>  <script>//@formatter:off
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link data-minify="1" rel='stylesheet' id='unslider-css-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/unslider-0b369fbd539997cf9a0bb61c69679431.css' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='slider-css-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-slider/public/assets/css/slider-124d6d86e71458fa069d602cdc52af3d.css' type='text/css' media='all' /><link rel='stylesheet' id='responsive-lightbox-prettyphoto-css' href='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.2.2' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='smp_style-css' href='https://www.bajanreporter.com/wp-content/cache/min/1/wp-content/plugins/wp-super-popup/colorbox-ceb55c59e3115103f397ca9f20df7bd2.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-3.4.1.min.js?ver=3.4.1'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/unslider.min.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.move.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.swipe.js?ver=1.4.6'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.0.0.min.js?ver=3.0.0'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.2.2'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.3.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"1","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.00","showTitle":"0","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"facebook","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","nonce":"d5d999e52b"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.2'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.16.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_responsive = {"reload_on_resize":"0"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.8.9'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.6.2'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.colorbox-min.js?ver=1788008050'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//jquery.utils-min.js?ver=829875022'></script> <script type='text/javascript'>/* <![CDATA[ */ var smp_vars = {"cookie_id":"1577899962291","cookie_num_visits":"15","show_mode":"2","popup_url":"https:\/\/www.bajanreporter.com\/wp-content\/uploads\/smp_popup.html","load_mode":"2","page_content_id":"","popup_width":"720","popup_height":"640","popup_opacity":"0.5","popup_speed":"700","overlay_close":"true","popup_delay":"2000","cookie_duration":"30","ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/wp-super-popup//wp-super-popup.js?ver=141745942'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.6.2'></script> <link rel='https://api.w.org/' href='https://www.bajanreporter.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bajanreporter.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bajanreporter.com/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F01%2Fdistrict-c-officers-probe-suspected-suicide-of-former-colleague%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.bajanreporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bajanreporter.com%2F2020%2F01%2Fdistrict-c-officers-probe-suspected-suicide-of-former-colleague%2F&#038;format=xml" /> <style type="text/css" media="screen">.g{margin:0;padding:0;overflow:hidden;line-height:1;zoom:1}.g img{height:auto}.g-col{position:relative;float:left}.g-col:first-child{margin-left:0}.g-col:last-child{margin-right:0}.g-17{min-width:0;max-width:336px}.b-17{margin:0 0 0 0}@media only screen and (max-width:480px){.g-col,.g-dyn,.g-single{width:100%;margin-left:0;margin-right:0}}</style> <script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="bajan-layer-custom-css"></style> <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">/* <![CDATA[ */ //<![CDATA[
	var dataLayer_content = {"visitorLoginState":"logged-out","visitorType":"visitor-logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["breaking-news","crime-new","featured"],"pageAttributes":["barbados","police","suicide"],"pagePostAuthor":"Bajan Reporter"};
	dataLayer.push( dataLayer_content );//]]> /* ]]> */</script> <script data-cfasync="false">/* <![CDATA[ */ //<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KJ9N7NW');//]]> /* ]]> */</script>  <script type="text/javascript">var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};</script> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body><div id="header" class="container"><div id="breakingnews" class="row"><div class="threecol"><p><strong>BREAKING NEWS</strong></p></div><div class="ninecol last"><ul id="chyrons" class="cf"><li><a href="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/" title="DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE">DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE</a></li><li><a href="https://www.bajanreporter.com/2020/01/police-make-major-seizure-at-marl-hole-gun-ammo-ski-masks-and-drugs/" title="Police make major seizure at Marl Hole – gun, ammo, ski masks and drugs">Police make major seizure at Marl Hole – gun, ammo, ski masks and drugs</a></li><li><a href="https://www.bajanreporter.com/2020/01/police-asking-bajans-to-help-locate-missing-teen-ramalio-straker/" title="Police Asking Bajans to Help Locate Missing Teen &#8211; Ramalio Straker">Police Asking Bajans to Help Locate Missing Teen &#8211; Ramalio Straker</a></li><li><a href="https://www.bajanreporter.com/2019/12/stabbing-near-chefette-rockley/" title="STABBING NEAR CHEFETTE ROCKLEY">STABBING NEAR CHEFETTE ROCKLEY</a></li><li><a href="https://www.bajanreporter.com/2019/12/young-man-shot-in-his-face-at-reed-st/" title="Young man shot in his face at Reed St">Young man shot in his face at Reed St</a></li></ul></div></div></div><div id="masthead" class="row"><div class="fourcol" id="bajan-reporter-logo"> <a href="https://www.bajanreporter.com" title="Web&#8217;s Eye View of Barbados in the Caribbean"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Bajan Reporter" data-lazy-src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" /><noscript><img src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/img/br_logo.png" alt="Bajan Reporter" /></noscript></a> <span id="edition-date"><strong>Today</strong> Tuesday, January 7th, 2020</span></div><div class="sevencol last"> <a data-bid="1" href="https://www.bajanreporter.com/linkout/98786" target="_blank"><img width="728" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" alt='marcusthompsoninc2020' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/marcusthompsoninc2020.jpg" /><noscript><img width="728" height="90" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/marcusthompsoninc2020.jpg' alt='marcusthompsoninc2020' /></noscript></a></div></div><nav class="row cf"><div class="menu-primary-nav-container"><ul id="menu-primary-nav" class="menu"><li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37039"><a href="https://www.bajanreporter.com/">Home</a></li><li id="menu-item-37113" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-37113"><a href="https://www.bajanreporter.com/category/new/">News</a><ul class="sub-menu"><li id="menu-item-37117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37117"><a href="https://www.bajanreporter.com/category/arts/cuisine-arts/">Agriculture</a></li><li id="menu-item-37121" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37121"><a href="https://www.bajanreporter.com/category/breaking-news/">Breaking News</a></li><li id="menu-item-37047" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37047"><a href="https://www.bajanreporter.com/category/new/crime-new/">Crime</a></li><li id="menu-item-37046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37046"><a href="https://www.bajanreporter.com/category/new/business-new/">Business</a></li><li id="menu-item-37122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37122"><a href="https://www.bajanreporter.com/category/new/disaster-new/">Nature</a></li><li id="menu-item-37123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37123"><a href="https://www.bajanreporter.com/category/new/education-new/">Education</a></li><li id="menu-item-37048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37048"><a href="https://www.bajanreporter.com/category/new/medical-new/">Health</a></li><li id="menu-item-37049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37049"><a href="https://www.bajanreporter.com/category/new/voting-new/">Political</a></li><li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.bajanreporter.com/category/opinion/">Editorial</a></li></ul></li><li id="menu-item-37116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37116"><a href="https://www.bajanreporter.com/category/arts/">Arts</a><ul class="sub-menu"><li id="menu-item-37118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37118"><a href="https://www.bajanreporter.com/category/arts/galleries/">Galleries</a></li><li id="menu-item-37119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37119"><a href="https://www.bajanreporter.com/category/arts/painting/">Painting</a></li><li id="menu-item-37120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37120"><a href="https://www.bajanreporter.com/category/arts/sculpture-arts/">Sculpture</a></li></ul></li><li id="menu-item-37042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37042"><a href="https://www.bajanreporter.com/category/entertainment/books-entertainment/">Books</a></li><li id="menu-item-37041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37041"><a href="https://www.bajanreporter.com/category/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-37079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37079"><a href="https://www.bajanreporter.com/category/new/cinema-photography/">Cinema</a></li><li id="menu-item-37044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37044"><a href="https://www.bajanreporter.com/category/entertainment/games-entertainment/">Games</a></li><li id="menu-item-39648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39648"><a href="https://www.bajanreporter.com/category/entertainment/design/">Fashion</a></li><li id="menu-item-37043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37043"><a href="https://www.bajanreporter.com/category/entertainment/culture-entertainment/">Culture</a></li><li id="menu-item-37045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37045"><a href="https://www.bajanreporter.com/category/entertainment/music-entertainment/">Music</a></li></ul></li><li id="menu-item-37114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37114"><a href="https://www.bajanreporter.com/category/opinion/review-opinion/">Review</a></li><li id="menu-item-37059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37059"><a href="https://www.bajanreporter.com/category/gossip/">Gossip</a><ul class="sub-menu"><li id="menu-item-37060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37060"><a href="https://www.bajanreporter.com/category/gossip/cartoons-gossip/">Cartoons</a></li><li id="menu-item-37061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37061"><a href="https://www.bajanreporter.com/category/gossip/controversy/">Controversy</a></li><li id="menu-item-37062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37062"><a href="https://www.bajanreporter.com/category/gossip/oddity-gossip/">Oddity</a></li><li id="menu-item-37063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37063"><a href="https://www.bajanreporter.com/category/gossip/rihanna-gossip/">Rihanna</a></li></ul></li><li id="menu-item-37050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37050"><a href="https://www.bajanreporter.com/category/new/tech/">Technology</a></li><li id="menu-item-37051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37051"><a href="https://www.bajanreporter.com/category/new/travel-new/">Travel</a></li><li id="menu-item-37052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37052"><a href="https://www.bajanreporter.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-37054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37054"><a href="https://www.bajanreporter.com/category/sports/cricket-sports/">Cricket</a></li><li id="menu-item-37055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37055"><a href="https://www.bajanreporter.com/category/sports/soccer-sports/">Football</a></li><li id="menu-item-39249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39249"><a href="https://www.bajanreporter.com/category/sports/sports-rugby/">Rugby</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.bajanreporter.com/category/sports/automobiles/">Rally</a></li><li id="menu-item-37056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37056"><a href="https://www.bajanreporter.com/category/sports/martial-arts-sports/">Martial Arts</a></li><li id="menu-item-37057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37057"><a href="https://www.bajanreporter.com/category/sports/olympics-sports/">Olympics</a></li><li id="menu-item-37053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37053"><a href="https://www.bajanreporter.com/category/sports/athletics-sports/">Athletics</a></li><li id="menu-item-77955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77955"><a href="https://www.bajanreporter.com/category/sports/sailing-sports/">Sailing</a></li><li id="menu-item-37058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37058"><a href="https://www.bajanreporter.com/category/sports/polo-sports/">Polo</a></li></ul></li></ul></div></nav><div id="main" class="container" role="main"><div class="row"><section id="single-article" class="sevencol"><article id="post-99022" class="post-99022 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-crime-new category-featured tag-barbados tag-police tag-suicide"><h1>DISTRICT &#8216;C&#8217; OFFICERS PROBE SUSPECTED SUICIDE OF FORMER COLLEAGUE</h1><p class="post-meta">by Bajan Reporter / January 6th, 2020</p><div class="addthis_toolbox addthis_default_style "> <a class="addthis_button_preferred_1"></a> <a class="addthis_button_preferred_2"></a> <a class="addthis_button_preferred_3"></a> <a class="addthis_button_preferred_4"></a> <a class="addthis_button_compact"></a> <a class="addthis_counter addthis_bubble_style"></a></div> <script src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4eeff8c924fc206b"></script> <p>Police from District C are now investigating a suspected case of suicide at Banyan Circle, Gooseberry Drive, Ruby St. Philip – officers got a report around 6:20 am of a man hanging by the neck with a rope at a nearby residence.</p><p>District C responded immediately and on arrival, attended to the man but there was no sign of life. He was pronounced dead at the scene by a medical doctor.</p><div id="attachment_99023" style="width: 235px" class="wp-caption aligncenter"><a href="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005.jpg" data-rel="lightbox-gallery-IYKhP1uj" data-rl_title="" data-rl_caption="" title=""><img aria-describedby="caption-attachment-99023" class="size-medium wp-image-99023" title="IMG 20200106 WA0005" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20225%20300'%3E%3C/svg%3E" alt="IMG 20200106 WA0005" width="225" height="300" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005-400x533.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005.jpg 768w" data-lazy-sizes="(max-width: 225px) 100vw, 225px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005-225x300.jpg" /><noscript><img aria-describedby="caption-attachment-99023" class="size-medium wp-image-99023" title="IMG 20200106 WA0005" src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005-225x300.jpg" alt="IMG 20200106 WA0005" width="225" height="300" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005-225x300.jpg 225w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005-400x533.jpg 400w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20200106-WA0005.jpg 768w" sizes="(max-width: 225px) 100vw, 225px" /></noscript></a><p id="caption-attachment-99023" class="wp-caption-text"><br />Gone is 37 year old Police Constable 1939 <em>RYAN DELANO SPENCER COPPIN</em>, from Goosberry Drive, Ruby, St Philip.</p></div><p>He was a member of the RBPF and on suspension, having been charged with a number of Criminal matters.</p></article><div id="article-ad"><div class="ads468x60"> <a data-bid="1" href="https://www.bajanreporter.com/linkout/98781" target="_blank"><img width="468" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20468%20150'%3E%3C/svg%3E" alt='Bajan Reporter 468x150' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Bajan-Reporter-468x150.png" /><noscript><img width="468" height="150" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/Bajan-Reporter-468x150.png' alt='Bajan Reporter 468x150' /></noscript></a></div></div><h2 id="comments"></h2><p class="commentssubscribe">Stay in touch with the conversation, subscribe to the <a class="feed" rel="alternate" href="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/feed/"><acronym title="Really Simple Syndication">RSS</acronym> feed for comments on this post</a>.</p><div id="respond"><h3 class="comments-heading">Comments</h3><h4>add a comment</h4><form action="https://www.bajanreporter.com/wp-comments-post.php" method="post"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/#respond" style="display:none;">Click here to cancel reply.</a><p><abbr title="You can use: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; ">Some HTML is OK</abbr></p><textarea name="comment" id="comment" rows="8" cols="40" tabindex="1"></textarea><p> <input type="text" name="author" id="author" value="" size="22" tabindex="2" /> <label for="author">Name <em>(required)</em></label></p><p> <input type="text" name="email" id="email" value="" size="22" tabindex="3" /> <label for="email">Email <em>(required, but never shared)</em></label></p><p> <input type="text" name="url" id="url" value="" size="22" tabindex="4" /> <label title="Your website address" for="url">Web</label></p><p> <input name="submit" type="submit" id="submit" value="Post comment" tabindex="5" /> or, reply to this post via <a rel="trackback" href="https://www.bajanreporter.com/2020/01/district-c-officers-probe-suspected-suicide-of-former-colleague/trackback/">trackback</a>.</p> <input type='hidden' name='comment_post_ID' value='99022' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2719db8d57" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="193"/></p></form></div><div class="pagination_single"><ul><li><span class="previous">Previous: &laquo; <a href="https://www.bajanreporter.com/2020/01/uncut-gems-adam-sandler-julia-fox-kevin-garnett/" rel="prev">Uncut Gems &#8211; Adam Sandler, Julia Fox &#038; Kevin Garnett</a></span></li><li><span class="next">Next: </span></li></ul></div></section><div id="post-aside" class="fivecol last"><ul class="ad ads336x280 cf"><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98782" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='IGT MyBarbadosLottery 1' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2018/11/IGT-MyBarbadosLottery-1.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2018/11/IGT-MyBarbadosLottery-1.jpg' alt='IGT MyBarbadosLottery 1' /></noscript></a></li><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98784" target="_blank"><img width="337" height="281" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20337%20281'%3E%3C/svg%3E" alt='Bajan Reporter 336x280' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/12/Bajan-Reporter-336x280.png" /><noscript><img width="337" height="281" src='https://www.bajanreporter.com/wp-content/uploads/2019/12/Bajan-Reporter-336x280.png' alt='Bajan Reporter 336x280' /></noscript></a></li><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98783" target="_blank"><img width="336" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20336%20280'%3E%3C/svg%3E" alt='BGIS 336x280' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2018/10/BGIS_336x280.jpg" /><noscript><img width="336" height="280" src='https://www.bajanreporter.com/wp-content/uploads/2018/10/BGIS_336x280.jpg' alt='BGIS 336x280' /></noscript></a></li></ul><ul class="ad ads120x600 cf"><li><a data-bid="1" href="https://www.bajanreporter.com/linkout/98775"><img width="120" height="600" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20600'%3E%3C/svg%3E" alt='If you saw this then you came to the best place to get seen 1' data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2018/12/If-you-saw-this-then-you-came-to-the-best-place-to-get-seen-1.png" /><noscript><img width="120" height="600" src='https://www.bajanreporter.com/wp-content/uploads/2018/12/If-you-saw-this-then-you-came-to-the-best-place-to-get-seen-1.png' alt='If you saw this then you came to the best place to get seen 1' /></noscript></a></li></ul></div></div></div><div id="multimedia" class="container"><div id="photo-gallery" class="row"><div class="twelvecol"><h2>Photo gallery <em>&bull;</em> <a href="http://www.bajanreporter.com/category/photo-gallery" class="more-media">more photos &raquo;</a></h2><ul id="images-reel" class="cf"><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/01/show-up-play-2020-rugby-xvs-season-launch/" title="&#8216;Show Up &#038; Play&#8217; 2020 Rugby XVs Season Launch"> &#8216;Show Up &#038; Play&#8217; 2020 Rugby XVs Season Launch </a></div> <img width="117" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20117%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20191231 WA0009" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009.jpg 596w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009-400x566.jpg 400w" data-lazy-sizes="(max-width: 117px) 100vw, 117px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009.jpg" /><noscript><img width="117" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20191231 WA0009" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009.jpg 596w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009-212x300.jpg 212w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191231-WA0009-400x566.jpg 400w" sizes="(max-width: 117px) 100vw, 117px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/01/budget-your-2020-now-here-are-public-sector-dates-you-should-know/" title="BUDGET YOUR 2020 NOW, HERE ARE PUBLIC SECTOR DATES YOU SHOULD KNOW&#8230;"> BUDGET YOUR 2020 NOW, HERE ARE PUBLIC SECTOR DATES YOU SHOULD KNOW&#8230; </a></div> <img width="120" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20191223 WA0055" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055.jpg 657w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055-218x300.jpg 218w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055-400x551.jpg 400w" data-lazy-sizes="(max-width: 120px) 100vw, 120px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055.jpg" /><noscript><img width="120" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20191223 WA0055" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055.jpg 657w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055-218x300.jpg 218w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191223-WA0055-400x551.jpg 400w" sizes="(max-width: 120px) 100vw, 120px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2020/01/if-youve-seen-this-little-girl-call-the-total-loving-care-vet-clinic-now/" title="IF YOU&#8217;VE SEEN THIS LITTLE GIRL, CALL THE TOTAL LOVING CARE VET CLINIC NOW!"> IF YOU&#8217;VE SEEN THIS LITTLE GIRL, CALL THE TOTAL LOVING CARE VET CLINIC NOW! </a></div> <img width="153" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20153%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20191227 WA0010" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-279x300.jpg 279w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-953x1024.jpg 953w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-768x826.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-400x430.jpg 400w" data-lazy-sizes="(max-width: 153px) 100vw, 153px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010.jpg" /><noscript><img width="153" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="IMG 20191227 WA0010" srcset="https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010.jpg 1080w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-279x300.jpg 279w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-953x1024.jpg 953w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-768x826.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2020/01/IMG-20191227-WA0010-400x430.jpg 400w" sizes="(max-width: 153px) 100vw, 153px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2019/11/international-jockeys-challenge-2019-what-you-missed-british-and-local-jockeys-vying-for-handsome-purses-worth-thousands/" title="International Jockeys&#8217; Challenge 2019, what you missed&#8230; British and Local Jockeys vying for handsome Purses worth Thousands!"> International Jockeys&#8217; Challenge 2019, what you missed&#8230; British and Local Jockeys vying for handsome Purses worth Thousands! </a></div> <img width="213" height="120" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20213%20120'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="20191123 140420" data-lazy-srcset="https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420-300x169.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420-768x432.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420-400x225.jpg 400w" data-lazy-sizes="(max-width: 213px) 100vw, 213px" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420.jpg" /><noscript><img width="213" height="120" src="https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="20191123 140420" srcset="https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420.jpg 1024w, https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420-300x169.jpg 300w, https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420-768x432.jpg 768w, https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_140420-400x225.jpg 400w" sizes="(max-width: 213px) 100vw, 213px" /></noscript></li><li><div class="overlay"><a href="https://www.bajanreporter.com/2019/11/international-jockeys-challenge-2019-what-you-missed-flows-independence-deals/" title="International Jockeys&#8217; Challenge 2019, what you missed&#8230; Flow&#8217;s Independence Deals!"> International Jockeys&#8217; Challenge 2019, what you missed&#8230; Flow&#8217;s Independence Deals! </a></div> <img width="211" height="165" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20211%20165'%3E%3C/svg%3E" class="attachment-213x165 size-213x165 wp-post-image" alt="20191123 141446" data-lazy-src="https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_141446-576x450.jpg" /><noscript><img width="211" height="165" src="https://www.bajanreporter.com/wp-content/uploads/2019/11/20191123_141446-576x450.jpg" class="attachment-213x165 size-213x165 wp-post-image" alt="20191123 141446" /></noscript></li></ul></div></div><div id="video-gallery" class="row"><div class="twelvecol"><h2>Videos <em>&bull;</em> <a href="https://www.bajanreporter.com/category/videos" class="more-media">more videos &raquo;</a></h2><ul id="video-playlist" class="cf"><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/sS6EE4D3tjQ" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/sS6EE4D3tjQ" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/sS6EE4D3tjQ" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">January 6th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/01/uncut-gems-adam-sandler-julia-fox-kevin-garnett/" title="Uncut Gems &#8211; Adam Sandler, Julia Fox &#038; Kevin Garnett">Uncut Gems &#8211; Adam Sandler, Julia Fox &#038; Kevin Garnett</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/X0qk_GK9_d4" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/X0qk_GK9_d4" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/X0qk_GK9_d4" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">January 5th, 2020 <br /> <a href="https://www.bajanreporter.com/2020/01/2020-new-years-message-from-chairperson-of-caricom/" title="2020 New Year&#8217;s Message From Chairperson Of CARICOM">2020 New Year&#8217;s Message From Chairperson Of CARICOM</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/9FNBg_feexA" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/9FNBg_feexA" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/9FNBg_feexA" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">January 2nd, 2020 <br /> <a href="https://www.bajanreporter.com/2020/01/downhill-miranda-otto-will-ferrell-julia-louis-dreyfus/" title="&#8216;Downhill&#8217; &#8211; Miranda Otto, Will Ferrell &#038; Julia Louis-Dreyfus">&#8216;Downhill&#8217; &#8211; Miranda Otto, Will Ferrell &#038; Julia Louis-Dreyfus</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/abZAacwV67w" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/abZAacwV67w" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/abZAacwV67w" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">January 1st, 2020 <br /> <a href="https://www.bajanreporter.com/2020/01/the-gentlemen-dir-by-guy-ritchie-feas-charlie-hunnam-henry-golding-michelle-dockery-eddie-marsan-plus-more/" title="&#8216;The Gentlemen&#8217; Dir. by Guy Ritchie, fea&#8217;s. Charlie Hunnam, Henry Golding, Michelle Dockery &#038; Eddie Marsan plus MORE!">&#8216;The Gentlemen&#8217; Dir. by Guy Ritchie, fea&#8217;s. Charlie Hunnam, Henry Golding, Michelle Dockery &#038; Eddie Marsan plus MORE!</a></div></li><li> <object style="height: 150px; width: 213px" data="https://youtube.com/v/2wz2DsGls3U" type="application/x-shockwave-flash"><param name="movie" value="https://youtube.com/v/2wz2DsGls3U" /><param name="allowFullScreen" value="true" /><param name="allowScriptAccess" value="always" /> <embed src="https://youtube.com/v/2wz2DsGls3U" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="213" height="150" /> </object><div class="video-details">December 31st, 2019 <br /> <a href="https://www.bajanreporter.com/2019/12/bgis-in-focus-we-gatherin-fuh-wuh/" title="BGIS In Focus &#8211; &#8220;We Gatherin&#039;&#8221; Fuh Wuh?">BGIS In Focus &#8211; &#8220;We Gatherin'&#8221; Fuh Wuh?</a></div></li></ul></div></div></div>  <script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var click_object = {"ajax_url":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_layer_settings = {"layer_class":"bajan-layer"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.6.5'></script> <script type='text/javascript'>/* <![CDATA[ */ var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"bajan-sticky"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1.7.10'></script> <script type='text/javascript'>/* <![CDATA[ */ var advadsTracking = {"ajaxurl":"https:\/\/www.bajanreporter.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":null,"blogId":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.19'></script> <script type='text/javascript' src='https://www.bajanreporter.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script> <script async="async" type='text/javascript' src='https://www.bajanreporter.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script> <script>window.advads_has_ads = [["98786","ad",null],["98781","ad",null],["98782","ad",null],["98784","ad",null],["98783","ad",null],["98775","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');} });</script><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.bajanreporter.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script><script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = [];var advads_gatracking_uids = [];var advads_tracking_methods = [];var advads_tracking_parallel = [];var advads_tracking_linkbases = [];var advads_gatracking_allads = [];var advads_gatracking_anonym = true;</script><footer class="container"><div class="row"><div id="col1" class="threecol"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-37036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37036"><a href="https://www.bajanreporter.com/advertise-with-us/">Advertise With Us!</a></li><li id="menu-item-37035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37035"><a href="https://www.bajanreporter.com/contact/">CONTACT US NOW!</a></li><li id="menu-item-37038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37038"><a href="https://www.bajanreporter.com/about/">About Us</a></li><li id="menu-item-37037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37037"><a href="https://www.bajanreporter.com/disclaimer/">Disclaimer</a></li><li id="menu-item-59995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59995"><a href="https://www.bajanreporter.com/editorial-discretion/">Editorial Discretion</a></li><li id="menu-item-37034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.bajanreporter.com/attn-comments/">ATTN: COMMENTS</a></li></ul></div></div><div id="col2" class="threecol"><ul><li><a href="https://www.bajanreporter.com/sitemap.xml">Sitemap</a></li><li><a href="https://www.bajanreporter.com/feed">RSS feed</a></li></ul></div><div id="copyright" class="sixcol last"><div id="search" class="cf"><form id="searchform" method="get" action="https://www.bajanreporter.com"><div> <input type="submit" value="Go" /> <input type="text" name="s" id="s" size="15" /> <label for="s">Search:</label></div></form></div><p> &copy; 2020 Bajan Reporter &bull; All Rights Reserved &bull; No content may be reproduced without the express permission of Bajan Reporter.</p><p>Theme made by <a href="http://www.marcusthompsoninc.com" title="Barbados web design and development - Marcus Thompson Inc.">MTI</a></p></div></div></footer>  <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script> <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.flexslider-min.js"></script> <script src="https://www.bajanreporter.com/wp-content/themes/bajanreporter/js/jquery.cycle.all.latest.js"></script>  <script>$(window).load(function() {
    $('.flexslider').flexslider();
	
	 $('#chyrons').cycle({
		fx: 'fade' // choose your transition type, ex: fade, scrollUp, shuffle, etc...
	});	
  });</script> <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d24089ce0d","applicationID":"30915227","transactionName":"YQdSMUBWDENQVhYMDlhNcxBBQw1dHmYLCwZaBxBIEmcNQ0U=","queueTime":0,"applicationTime":580,"atts":"TUBFRwhMHxwTVEBfGksf","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1578374065 -->